Tom Feb 17, 2013 @ 12:28pm
*SteamStartEngine(0xbfb334f0) failed with error 1: CMultiFieldBlob(pSerialized) : Bad field -extends past end of blob
Problem:

((

I recently installed Linux Ubuntu and TF2 for Ubuntu. I loaded TF2 once and it didn't work, so I restarted Ubuntu. Then when I load Steam again and I get this message:

Fatal Error: Steam failed to load*SteamStartEngine(0xbfb334f0) failed with error 1: CMultiFieldBlob(pSerialized) : Bad field -extends past end of blob

))

FIX:

To fix the problem you have to delete your ClientRegistry.blob file.

Close Steam.

Open a terminal (you can search for it by typing "term" in the dashboard search box or Ctrl+Alt+T)

Once you have a terminal window type: rm ~/.local/share/Steam/ClientRegistry.blob

Then hit enter. Close the terminal window, and try running Steam again.

OR

Download a piece of software called Gentoo: http://www.gentoo.org/

Using the sofeware locate ClientRegistry.blob and delete it.


Hope this helps,
Tom
Last edited by Tom; Oct 20, 2013 @ 11:10am
Showing 1-14 of 14 comments
< >
Tom Feb 17, 2013 @ 12:36pm 
btw I'm logged onto steam on my Laptop, that why I can make the thread
Spy Cooper Feb 18, 2013 @ 11:06am 
I have this problem to I hope there is a way t fix it!
node357 Feb 18, 2013 @ 11:11am 
Close Steam. Open a terminal (you can search for it by typing "term" in the dashboard search box. Once you have a terminal window (text prompt), type:

rm ~/.local/share/Steam/ClientRegistry.blob

Then hit enter. Close the terminal window, and try running Steam again.
Tom Feb 18, 2013 @ 11:20am 
Thanks Man! I downloaded something called Gentoo, and located my Steam folder then deleted the ClientRegisty.

I leave this thread open in case anyone has the same problem. If anyone still has problems add me and I'll try and fix it. :)
██ Feb 19, 2013 @ 6:25pm 
Yes, thanks. I had the exact same problem!
hitman_0147 Feb 22, 2013 @ 11:00am 
ok i typed in the code and it is not working it keeps saying no such file exists and im still getting the same stupid error message please help
Tom Feb 24, 2013 @ 6:13am 
Are you on Ubuntu?
Spy Cooper Mar 2, 2013 @ 9:56am 
i forgot to say thanks becuase i was playing tf2 thanks
Jaboba Mar 3, 2013 @ 8:14am 
Thank you so much, this worked first try
Tom Mar 3, 2013 @ 8:44am 
No problem :D
iPapi Sep 3, 2013 @ 5:35pm 
WORKED Thanks
LittleOrphan Oct 20, 2013 @ 10:54am 
how do u get terminal up grr i cant find it
LittleOrphan Oct 20, 2013 @ 10:55am 
Originally posted by node357:
Close Steam. Open a terminal (you can search for it by typing "term" in the dashboard search box. Once you have a terminal window (text prompt), type:

rm ~/.local/share/Steam/ClientRegistry.blob

Then hit enter. Close the terminal window, and try running Steam again.


HELP
Tom Oct 20, 2013 @ 10:59am 
Ctrl+Alt+T
Showing 1-14 of 14 comments
< >
Per page: 15 30 50
Date Posted: Feb 17, 2013 @ 12:28pm
Posts: 14