Hrdkr Mar 17, 2013 @ 12:14pm
Running Steam on Debian (Wheezy) 64 bit (evading missing libGL.so.1 library problem)
UPDATE

Steam is in Debian's repo now. To evade all kinds of errors on Debian, just stick to this package. To install it, just throw the following command:

sudo apt-get install steam:i386 -t testing

It's i386 and testing only, so if you need assistance to get your Debian multiarch and capable of running packages from the testing repo, follow this simple guide: http://ein-eike.de/2013/12/02/installing-steam-on-debian-wheezy-64-bit-the-easy-way/

If the error from the thread title persists, stick to the solution below, it works.

ORIGINAL POST

Well, Steam runs on Ubuntu pretty well, but when it comes to another Linux distros, you should manually install all the dependencies. Almost all the dependencies must be satisfied in order to install steam (currently, steam-launcher) package, and it installs well, but once you trying to start it, you may get the following error:

You are missing the following 32-bit libraries, and Steam may not run: libGL.so.1

This is because steam-launcher package in fact doesn't require all the needed packages to be installed.

Well, I tried to resolve this issue on my Wheezy 64 machine with no luck, searching for a solution here on forum, making symlinks, installing ia32-libs and that kind of stuff. But then I realised, that I just need to install a 32 bit version of package, which contains this library (thanks to apt-file tool). At least one essential package is not required by steam-launcher package, but it should be installed. It is a libgl1-nvidia-glx:i386.

Long story short, if you get this error, do the following in the console:
sudo apt-get install libgl1-nvidia-glx:i386

May work on another distros as well. Hope it will help someone.
Last edited by Hrdkr; Mar 14 @ 1:07pm
Showing 1-15 of 106 comments
< >
Hrdkr Mar 17, 2013 @ 12:45pm 
Forgot to mention that this is relevant to those folks, which have NVidia GPUs.
Turulo Mar 17, 2013 @ 12:51pm 
Try installing the drivers from the vendor websites, both ATI and Nvidia driver packages come with 32 and 64 binaries.

The only problem is for people using libGL from libmesa (for example intel cards), in that case you will need libmesa 9.x which isnt available under debian (not even in experimental) so the best option would be to go with a chroot install of ubuntu.
Hrdkr Mar 17, 2013 @ 12:56pm 
I am personally not recommend to install anything from websites, when you are on Debian. It has different philisophy, than WIndows.
Software must be obtained from the repository, if available. The latest nvidia drivers are available in the official repo, under versions 304.64 in testing, 304.84 in unstable and 313.26 experimental. And working like a charm!
And yes, if you link libGl.so.1 to that, provided by some MESA package, you'll get the Steam running, but no any game.
Turulo Mar 17, 2013 @ 1:12pm 
Actually obtaining non-free software from Debian repositories doesn't use to be the best option. Indeed some people think (I think so too) that if the code isn't open source it shouldn't be distributed under the packaging systems, and so I never install non-free software from repositories (flash, proprietary drivers, etc...).

I don't want to start a flame as each one has his/her own preferences, so do whatever works for you, it was just my recommendation :)
Fibbles Mar 17, 2013 @ 1:16pm 
I've currently got nvidia-experimental-310 installed on Xubuntu 12.10 x64 and have spent most of the afternoon trying to fix TF2 performance issues. I've installed ia32-libs even though Steam didn't seem to need them. From reading elsewhere peformance issues can be solved by installing the 32bit driver alongside the 64bit. For the life of me though I can't get nvidia-experimental-310:i386 to install. I don't know if I'm being incredibly stupid or what but it's frustrating because I don't want to build the drivers using nVidia's script (because of the issues with kernel updates). I don't suppose you have any ideas?
Turulo Mar 17, 2013 @ 1:29pm 
Originally posted by Fibbles:
I've currently got nvidia-experimental-310 installed on Xubuntu 12.10 x64 and have spent most of the afternoon trying to fix TF2 performance issues. I've installed ia32-libs even though Steam didn't seem to need them. From reading elsewhere peformance issues can be solved by installing the 32bit driver alongside the 64bit. For the life of me though I can't get nvidia-experimental-310:i386 to install. I don't know if I'm being incredibly stupid or what but it's frustrating because I don't want to build the drivers using nVidia's script (because of the issues with kernel updates). I don't suppose you have any ideas?

I don't know your hardware setup, it may be due to poor hardware or misconfiguration.

Do the the performance problems occur when playing online only or also when training locally? First of all I would recommend:

- If your graphics card has some kind of power saving features, disable them.
- Set the the CPU governor to performance running the following command as root "cpufreq-set -g performance -r"

At last try running the game with libgl debugging enabled to see if its really using the Nvidia drivers:

LIBGL_DEBUG=verbose /storage/Games/Steam/SteamApps/turulo/Team\ Fortress\ 2/hl2.sh -game tf -steam

An example output when using the ATI drivers
LIBGL_DEBUG=verbose /storage/Games/Steam/SteamApps/turulo/Team\ Fortress\ 2/hl2.sh -game tf -steam
libGL: AtiGetClientDriverName: 9.1.11 fglrx (screen 0)
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/fglrx_dri.so
ukiDynamicMajor: found major device number 249
ukiDynamicMajor: found major device number 249
ukiOpenByBusid: Searching for BusID PCI:3:0:0
ukiOpenDevice: node name is /dev/ati/card0
............
Hrdkr Mar 18, 2013 @ 12:15am 
Originally posted by Fibbles:
For the life of me though I can't get nvidia-experimental-310:i386 to install
You don't have to install package nvidia-experimental-310 for both architectures (64 and 32) at the same time. You just can't (and don't need to).
By the way, I don't see this package in Quantal Quetzal's (12.10) repository (http://packages.ubuntu.com/search?keywords=nvidia-experimental-310&searchon=names&suite=quantal&section=all), where you got it from? From Raring's? Then, to eliminate the performance issues, you might have to upgrade your Ubuntu to the next release version (13.04 Raring Ringtail).
Fibbles Mar 18, 2013 @ 1:15pm 
Not sure where it was coming from to be honest. I guess this[packages.ubuntu.com] is it?

I just used ;

sudo apt-get install nvidia-experimental-310 nvidia-settings-experimental-310

I'm pretty certain it wasn't installing the 32bit binaries for compatibility though. I gave up in the end and manually installed 310.40 (long lived branch) from the nVidia website. It seems to have solved most of my performance problems as well as a weird error I was getting from Watchdog during boot (SP5100 TCO timer: mmio address 0xfec000f0 already in use) that was preventing Plymouth from running the full graphic splash.

EDIT: That page suggests that the 64bit package did in fact install the 32bit binaries. I'm back to having no idea what was causing the issues. I'm a bit reluctant to keep fiddling since I've solved most of them with the manual driver install.
KillerHT Oct 15, 2013 @ 2:40am 
This solution work for me (Debian 7.2 x64, nvidia driver dkms). Thanks!
Hrdkr Oct 15, 2013 @ 12:27pm 
Originally posted by KillerHT:
This solution work for me (Debian 7.2 x64, nvidia driver dkms). Thanks!
Glad it still works.
Raposa Dec 31, 2013 @ 11:27am 
Thanks man!
[Linux] Junior s2 Camila Dec 31, 2013 @ 12:31pm 
The best way to install on Wheezy http://ein-eike.de/2013/12/02/installing-steam-on-debian-wheezy-64-bit-the-easy-way/

Don't go for these old tutorials.
Hrdkr Jan 1 @ 6:59am 
Originally posted by Linux - Junior s2 Camila:
The best way to install on Wheezy http://ein-eike.de/2013/12/02/installing-steam-on-debian-wheezy-64-bit-the-easy-way/

Don't go for these old tutorials.
This is not a tutorial at all, I just explained how to fulfil package requirement. And I strictly advise all to avoid all kinds of "easy ways" (making symlinks to libraries and such kind of stuff), because these can simply damage your system. No need of quick and dirty hacks to get Steam running on Linux. By the way, happy New Year everyone.
Zyro Jan 1 @ 7:15am 
Originally posted by Hrdkr:
This is not a tutorial at all, I just explained how to fulfil package requirement. And I strictly advise all to avoid all kinds of "easy ways" (making symlinks to libraries and such kind of stuff), because these can simply damage your system. No need of quick and dirty hacks to get Steam running on Linux. By the way, happy New Year everyone.

Tell me what's wrong with my howto and I'll fix it.
It does not do any symlinks or anything, it's just pure Debian way of getting what's needed.
And it says that the task is easy because it is. People shouldn't be afraid of it.
I wrote it because people think it's still as hard as in the beta, with repackaging
stuff here, downloading packages manually there and such. It ain't.
I tried it and it works, and I'm playing on Debian Wheezy since the beta of Steam for Linux.
[Linux] Junior s2 Camila Jan 1 @ 7:43am 
Originally posted by Hrdkr:
This is not a tutorial at all, I just explained how to fulfil package requirement. And I strictly advise all to avoid all kinds of "easy ways" (making symlinks to libraries and such kind of stuff), because these can simply damage your system. No need of quick and dirty hacks to get Steam running on Linux. By the way, happy New Year everyone.
It's not that hard to get Steam on Wheezy anymore. Zyro's tutorial explains how easy it is and it never caused a problem for me.
Your tutorial on the other hand doesn't explain how you get the client (probably from a 3rd party).
And if you join both yours and Zyro's it's a perfect tutorial for modern days. I strongly advise Zyro to add how to install 32-bit libraries for NVIDIA's/AMD's/Intel cards.
Showing 1-15 of 106 comments
< >
Per page: 15 30 50