Crispy Dec 30, 2012 @ 5:08pm
Have DOOM 3 BFG edition installed, but it won't launch!
I've tried everything to find a solution by using google and haven't heard back from Steam yet. If anyone out there has had similar issues and was able to resolve the problem feel free to help me out :)
Showing 1-15 of 48 comments
< >
Dren Snow Dec 30, 2012 @ 5:30pm 
I'm having the same issue. I just bought it today since it's on sale and it keep crashing.
robertlawson Dec 30, 2012 @ 9:44pm 
so am i. want it to run pleaz
Doge ッ Dec 30, 2012 @ 9:48pm 
so weird, i just bought it today and it run normally
BrainSalad Dec 31, 2012 @ 12:20am 
I got the same problem..so ♥♥♥♥ing pissed
Chelmi Dec 31, 2012 @ 5:17am 
Same here.... DirectX installed, C++ 2005, 2008, 2010 and the 2012 redistributables...
CaptainFuture Dec 31, 2012 @ 6:44am 
Same problem, was so lucky having my old "friend" DOOM back in the game...
Hunter Dec 31, 2012 @ 7:08am 
This fix has worked for me in previous games, though I cannot guarantee it will work here... The fix is to right-click on the Doom 3 executable, click on the 'Compatibility' tab, and check off 'Disable desktop composition'. I had this issue with several games I recently bought with this sale (Fallout 3 & Oblivion) and this was the fix proposed. I hope it helps. I'm sorry if it doesn't.
CaptainFuture Dec 31, 2012 @ 8:34am 
@Hunter: This doesnt work on my machine :( I also updated the graphics card drivers and reinstalled directX out of the Doom BFG folder. MS Visual C redistributable tells me, i already got a newer version installed so I cannot install the Doom BFG Version.

Anyone with different hints? Thanks
CaptainFuture Dec 31, 2012 @ 8:35am 
to anyone: may that bea problem with win7 64Bit? Anyone with this OS where Doom BFG works?
Tànkwits Dec 31, 2012 @ 10:46am 
I have windows 7 64Bit and Hunters suggestion worked for me, ty btw
Nyrax-bag phone Dec 31, 2012 @ 10:51am 
i am having problems with the game as well, i am running windows xp and when i open the game it gives me like a whitish gray screen and tells me "an error has occured"
Kuraned Dec 31, 2012 @ 2:23pm 
I have the exactly the same problem and hunter's fix didn't work on mine. Win 7 64bit.
Last edited by Kuraned; Dec 31, 2012 @ 2:24pm
NoleDonkey Dec 31, 2012 @ 5:16pm 
I had to install Direct X 9 updates to get mine to work:
I have Win8 Pro 64 bit
http://www.microsoft.com/download/en/details.aspx?id=35&wt.mc_id=mscom_en_us_search_mssuggests_131z4enus22051
Last edited by NoleDonkey; Dec 31, 2012 @ 5:18pm
phillipsdavidl Dec 31, 2012 @ 6:56pm 
I am also having the same problem, have tried all of the support suggestions, and nothing has worked. Bioshock 2 and The Whitcher also don't run. The only game that has worked so far is Bioshock. Below is the text of the Doom 3 error screen.


Error during initialization
-----------------------------------

QA Timing INIT: 000165ms
D3BFG 1.1400 win-x86 Nov 9 2012 10:38:21
2395 MHz Intel CPU with MMX & SSE & SSE2 & SSE3 & HTT
6032 MB System Memory
-1984 MB Video Memory
Winsock Initialized
Found interface: {4BA7EEB3-9B22-447C-8001-AD6AA9945E28} Microsoft Wi-Fi Direct Virtual Adapter - 0.0.0.0 NULL netmask - skipped
Found interface: {C6F26AC6-7D33-4938-985E-D8B8877FE8F5} Ralink RT3290 802.11bgn Wi-Fi Adapter - 0.0.0.0 NULL netmask - skipped
Found interface: {996D9692-CDD1-46DB-B57B-93702B85F8C1} Realtek PCIe FE Family Controller - 192.168.0.2/255.255.255.0
Sys_InitNetworking: adding loopback interface
doom using MMX & SSE for SIMD processing
enabled Flush-To-Zero mode
enabled Denormals-Are-Zero mode
------ Initializing File System ------
Loaded resource file _common.resources
Loaded resource file _ordered.resources
Loaded resource file _sound_pc.resources
Loaded resource file _sound_pc_en.resources
Reading resource CRCs...
Current search path:
C:\Program Files (x86)\Steam\steamapps\common\DOOM 3 BFG Edition/base
C:\Users\david\Saved Games\id Software\DOOM 3 BFG/base
file system initialized.
--------------------------------------
WARNING: Unable to open resource file maps/_startup.resources
----- Initializing Decls -----
------------------------------
Couldn't open journal files
execing default.cfg
couldn't exec D3BFGConfig.cfg
couldn't exec autoexec.cfg
----- R_InitOpenGL -----
Initializing OpenGL subsystem with multisamples:0 stereo:0 fullscreen:1
...registered window class
...registered fake window class
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
...using WGL_EXT_swap_control_tear
display device: 0
DeviceName : \\.\DISPLAY1
DeviceString: Intel(R) HD Graphics 4000
StateFlags : 0x5
DeviceID : PCI\VEN_8086&DEV_0166&SUBSYS_1843103C&REV_09
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Video\{227ADE60-B95A-4EA9-88A5-84BCA379FC16}\0000
DeviceName : \\.\DISPLAY1\Monitor0
DeviceString: Generic PnP Monitor
StateFlags : 0x3
DeviceID : MONITOR\LGD027A\{4d36e96e-e325-11ce-bfc1-08002be10318}\0001
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Class\{4d36e96e-e325-11ce-bfc1-08002be10318}\0001
dmPosition.x : 0
dmPosition.y : 0
dmBitsPerPel : 32
dmPelsWidth : 1600
dmPelsHeight : 900
dmDisplayFlags : 0x0
dmDisplayFrequency: 60
...calling CDS: ok
display device: 0
DeviceName : \\.\DISPLAY1
DeviceString: Intel(R) HD Graphics 4000
StateFlags : 0x5
DeviceID : PCI\VEN_8086&DEV_0166&SUBSYS_1843103C&REV_09
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Video\{227ADE60-B95A-4EA9-88A5-84BCA379FC16}\0000
DeviceName : \\.\DISPLAY1\Monitor0
DeviceString: Generic PnP Monitor
StateFlags : 0x3
DeviceID : MONITOR\LGD027A\{4d36e96e-e325-11ce-bfc1-08002be10318}\0001
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Class\{4d36e96e-e325-11ce-bfc1-08002be10318}\0001
dmPosition.x : 0
dmPosition.y : 0
dmBitsPerPel : 32
dmPelsWidth : 1280
dmPelsHeight : 720
dmDisplayFlags : 0x0
dmDisplayFrequency: 60
...created window @ 0,0 (1280x720)
Initializing OpenGL driver
...creating GL context: created OpenGL 3.2 context
succeeded
...making context current: succeeded
...using WGL_EXT_swap_control_tear

------- Input Initialization -------
Initializing DirectInput...
mouse: DirectInput initialized.
keyboard: DirectInput initialized.
freespace_version: 0.6
0 freespace devices
------------------------------------
OpenGL Version: 3.2
OpenGL Vendor : Intel
OpenGL GLSL : 1.5
...using GL_ARB_multitexture
X..GL_EXT_direct_state_access not found
...using GL_ARB_texture_compression
...using GL_EXT_texture_compression_s3tc
...using GL_EXT_texture_filter_anisotropic
maxTextureAnisotropy: 16.000000
...using GL_EXT_texture_lod_bias
...using GL_ARB_seamless_cube_map
...using GL_ARB_framebuffer_sRGB
...using GL_ARB_vertex_buffer_object
...using GL_ARB_map_buffer_range
...using GL_ARB_vertex_array_object
...using GL_ARB_draw_elements_base_vertex
...using GL_ARB_fragment_program
...using GL_ARB_uniform_buffer_object
X..GL_EXT_depth_bounds_test not found
...using GL_ARB_sync
...using GL_ARB_occlusion_query
...using GL_ARB_timer_query
X..GL_ARB_debug_output not found
----- Initializing Render Shaders -----
While compiling vertex program renderprogs\gui.vertex
-----------------
1: #version 150

2: #define PC

3:

4: float saturate( float v ) { return clamp( v, 0.0, 1.0 ); }

5: vec2 saturate( vec2 v ) { return clamp( v, 0.0, 1.0 ); }

6: vec3 saturate( vec3 v ) { return clamp( v, 0.0, 1.0 ); }

7: vec4 saturate( vec4 v ) { return clamp( v, 0.0, 1.0 ); }

8: vec4 tex2Dlod( sampler2D sampler, vec4 texcoord ) { return textureLod( sampler, texcoord.xy, texcoord.w ); }

9:

10:

11: uniform vec4 _va_[4];

12:

13: float dot4 (vec4 a , vec4 b ) {return dot ( a , b ) ; }

14: float dot4 (vec2 a , vec4 b ) {return dot ( vec4 ( a , 0 , 1 ) , b ) ; }

15: vec4 swizzleColor (vec4 c ) {return c ; }

16:

17: in vec4 in_Position;

18: in vec2 in_TexCoord;

19: in vec4 in_Normal;

20: in vec4 in_Tangent;

21: in vec4 in_Color;

22: in vec4 in_Color2;

23:

24: out vec4 gl_Position;

25: out vec2 vofi_TexCoord0;

26: out vec4 vofi_TexCoord1;

27: out vec4 gl_FrontColor;

28:

29: void main() {

30: gl_Position . x = dot4 ( in_Position , _va_[0 /* rpMVPmatrixX */] ) ;

31: gl_Position . y = dot4 ( in_Position , _va_[1 /* rpMVPmatrixY */] ) ;

32: gl_Position . z = dot4 ( in_Position , _va_[2 /* rpMVPmatrixZ */] ) ;

33: gl_Position . w = dot4 ( in_Position , _va_[3 /* rpMVPmatrixW */] ) ;

34: vofi_TexCoord0 . xy = in_TexCoord . xy ;

35: vofi_TexCoord1 = ( swizzleColor ( in_Color2 ) * 2 ) - 1 ;

36: gl_FrontColor = swizzleColor ( in_Color ) ;

37: }
-----------------
ERROR: 0:? : 'gl_FrontColor' : variable is not available in current GLSL version


While compiling fragment program renderprogs\gui.pixel
-----------------
1: #version 150

2: #define PC

3:

4: void clip( float v ) { if ( v < 0.0 ) { discard; } }

5: void clip( vec2 v ) { if ( any( lessThan( v, vec2( 0.0 ) ) ) ) { discard; } }

6: void clip( vec3 v ) { if ( any( lessThan( v, vec3( 0.0 ) ) ) ) { discard; } }

7: void clip( vec4 v ) { if ( any( lessThan( v, vec4( 0.0 ) ) ) ) { discard; } }

8:

9: float saturate( float v ) { return clamp( v, 0.0, 1.0 ); }

10: vec2 saturate( vec2 v ) { return clamp( v, 0.0, 1.0 ); }

11: vec3 saturate( vec3 v ) { return clamp( v, 0.0, 1.0 ); }

12: vec4 saturate( vec4 v ) { return clamp( v, 0.0, 1.0 ); }

13:

14: vec4 tex2D( sampler2D sampler, vec2 texcoord ) { return texture( sampler, texcoord.xy ); }

15: vec4 tex2D( sampler2DShadow sampler, vec3 texcoord ) { return vec4( texture( sampler, texcoord.xyz ) ); }

16:

17: vec4 tex2D( sampler2D sampler, vec2 texcoord, vec2 dx, vec2 dy ) { return textureGrad( sampler, texcoord.xy, dx, dy ); }

18: vec4 tex2D( sampler2DShadow sampler, vec3 texcoord, vec2 dx, vec2 dy ) { return vec4( textureGrad( sampler, texcoord.xyz, dx, dy ) ); }

19:

20: vec4 texCUBE( samplerCube sampler, vec3 texcoord ) { return texture( sampler, texcoord.xyz ); }

21: vec4 texCUBE( samplerCubeShadow sampler, vec4 texcoord ) { return vec4( texture( sampler, texcoord.xyzw ) ); }

22:

23: vec4 tex1Dproj( sampler1D sampler, vec2 texcoord ) { return textureProj( sampler, texcoord ); }

24: vec4 tex2Dproj( sampler2D sampler, vec3 texcoord ) { return textureProj( sampler, texcoord ); }

25: vec4 tex3Dproj( sampler3D sampler, vec4 texcoord ) { return textureProj( sampler, texcoord ); }

26:

27: vec4 tex1Dbias( sampler1D sampler, vec4 texcoord ) { return texture( sampler, texcoord.x, texcoord.w ); }

28: vec4 tex2Dbias( sampler2D sampler, vec4 texcoord ) { return texture( sampler, texcoord.xy, texcoord.w ); }

29: vec4 tex3Dbias( sampler3D sampler, vec4 texcoord ) { return texture( sampler, texcoord.xyz, texcoord.w ); }

30: vec4 texCUBEbias( samplerCube sampler, vec4 texcoord ) { return texture( sampler, texcoord.xyz, texcoord.w ); }

31:

32: vec4 tex1Dlod( sampler1D sampler, vec4 texcoord ) { return textureLod( sampler, texcoord.x, texcoord.w ); }

33: vec4 tex2Dlod( sampler2D sampler, vec4 texcoord ) { return textureLod( sampler, texcoord.xy, texcoord.w ); }

34: vec4 tex3Dlod( sampler3D sampler, vec4 texcoord ) { return textureLod( sampler, texcoord.xyz, texcoord.w ); }

35: vec4 texCUBElod( samplerCube sampler, vec4 texcoord ) { return textureLod( sampler, texcoord.xyz, texcoord.w ); }

36:

37: uniform sampler2D samp0;

38:

39: in vec4 gl_FragCoord;

40: in vec2 vofi_TexCoord0;

41: in vec4 vofi_TexCoord1;

42: in vec4 gl_Color;

43:

44: out vec4 gl_FragColor;

45:

46: void main() {

47: vec4 color = ( tex2D ( samp0 , vofi_TexCoord0 ) * gl_Color ) + vofi_TexCoord1 ;

48: gl_FragColor . xyz = color. xyz * color. w ;

49: gl_FragColor . w = color. w ;

50: }
-----------------
ERROR: 0:? : 'gl_Color' : variable is not available in current GLSL version


While linking GLSL program 0 with vertexShader gui.vfp and fragmentShader gui.vfp
Link called without any attached shader objects.

--------- Game Map Shutdown ----------
--------------------------------------
0: Speakers and Headphones (IDT High Definition Audio CODEC)
2 channels, 48000 Hz
Front Left and Front Right
Default Console Device, Multimedia Device, Communications Device, and Game Device
Using device 0
********************
ERROR: While linking GLSL program 0 with vertexShader gui.vfp and fragmentShader gui.vfp

********************
Error during initialization
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...resetting display
...shutting down QGL
...unloading OpenGL DLL
chris999 Jan 1, 2013 @ 3:07am 
mine loads up or says it does... background music but all I get is a white screen. No exceutable to apply permissions to... just a url address in my steam box to click on.
Showing 1-15 of 48 comments
< >
Per page: 15 30 50
Date Posted: Dec 30, 2012 @ 5:08pm
Posts: 48