HIFYD Feb 6 @ 12:35pm
[Solved]
[Solved]
Last edited by HIFYD; Feb 6 @ 8:22pm
Showing 1-7 of 7 comments
< >
The Mystic Fox Feb 6 @ 1:00pm 
I am having exactly the same problem...

I go to change setting in any menu and wi will not let me change any settings whatsoever, not past 800x600. I have a 1080p Montior. The setting tell me that the graphics memory is coloured red with the warning sign, but the counter is at aprox. 203 / 3072. I have verified the game files, re-installed. GFWL seems to be working. (It says the whole press home to see start menu at the top.) I have tried most solutions but nothing seems to work.

GTA IV has worked before yet, it has been a while since I have last played, but the only things that have changed since I last played was my GPU (Drivers at latest vers.) and the OS from 8 to 8.1. I did build this PC also, not that I think it makes a difference.

Here is my full sys specs: (OP if you read this I suggest you post yours too)

PC STUFF: (All from DxDiag)

Operating System: Windows 8.1 Pro with Media Center 64-bit
Language: English (Regional Setting: English)
BIOS: BIOS Date: 10/20/10 09:47:36 Ver: 08.00.10 (ASUS UFEI)
Processor: AMD FX(tm)-8120 Eight-Core Processor (8 CPUs), ~3.1GHz (NEVER OC'd)
Memory: 8192MB RAM
Available OS Memory: 8138MB RAM
DirectX Version: DirectX 11
System DPI Setting: 96 DPI (100 percent)

MONITOR 1: (Primary Display - The one I play on...)

Card name: NVIDIA GeForce GTX 780
Driver Version: 9.18.13.3467
Manufacturer: NVIDIA
Display Memory: 7049 MB
Dedicated Memory: 2979 MB
Shared Memory: 4069 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: LG TV
Native Mode: 1920 x 1080(p) (60.000Hz)
Output Type: HDMI

MONITOR 2: (Second Display - Possibly Irrelevant, but may be useful info to someone)

Current Mode: 1024 x 768 (32 bit) (60Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: DELL E153FP
Native Mode: 1024 x 768(p) (60.004Hz)
Output Type: HD15 (DVI-I converted to VGA/D-sub via adapter)

Thanks to anyone that could help. I'm sure we will both be extremely grateful.
Xerpt Feb 6 @ 1:51pm 
It's a console Port, wouldn't that tell you everything you need to know?

Let's just hope GTA V will be a better port or i do wonder if Rockstar might screw that one up too:/

Let's hope not.
An Asian Bunny#Seattle Feb 6 @ 2:15pm 
Heres the solution:
(btw it has nothing to do with your specs its just how badly ported the game was sadly lol)

Step 1: locate the game in your library

Step 2: right click and go to properties

Step 3: type the following without the quotes "-nomemresrict -norestrictions -availablevidmem 60.0"

Step 4: launch the game and have fun!!!

- - - - - - - - -

PS: contact me if you need further help/this didnt work for you :D
Last edited by An Asian Bunny#Seattle; Feb 6 @ 2:17pm
Buck Feb 6 @ 6:36pm 
Just as an FYI, the cause is not because it's a "bad port", it's just a bug in GTA IV's hardware detection code that causes it to detect GPU memory >2GB correctly.
You don't actually needt o specify available memory, jst the -norestrictions and -nomemrestrict will do the job.

You really want to try sticking to all digital outputs if you can help it. Your video card must have multiple digital outpus
Last edited by Buck; Feb 6 @ 6:38pm
Cpt. 'murica Feb 6 @ 7:54pm 
or you could just change the aspect ratio...
HIFYD Feb 6 @ 8:22pm 
Originally posted by Juicy:
or you could just change the aspect ratio...
Or you could learn to read, halfwit.

*~Closed Topic~*
The Mystic Fox Feb 10 @ 12:49pm 
Thanks much Asian Bunny and Buck. Much appriciated.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Feb 6 @ 12:35pm
Posts: 7