Cities: Skylines

Cities: Skylines

Not enough ratings
MetroPed 1 platform (-14m) V1
 
Rate  
Favorite
Favorited
Unfavorite
File Size
Posted
Updated
1.187 MB
May 6 @ 2:38am
May 11 @ 12:03pm
3 Change Notes ( view )

Subscribe to download
MetroPed 1 platform (-14m) V1

Subscribed
Unsubscribe
In 1 collection by cacamaca8
MetroPed (modular stations with pedestrian underground access)
23 items
Description
Modular 1 platform MetroPed station (direct underground pedestrian access)
  • 1 platform (track position -14m, tunnel position -10m)
  • pedestrian tunnel connection (-8m)
  • entrance/exits at platform ends
  • works alone or combined with other MetroPed stations, creating metro hubs

For MOM users: MetroPed 1 platform (MOM designed)

You may have to do this:
  • subscribe to More Network Stuff and have it active
  • open Asset Editor, load any asset and only after this start/load your game, otherwise the pink paths are not working
The above mentioned steps are mandatory for me, probably a weird combo of installed mods. It is possible to work for you without having to do this.

You have to do this
  • link the tunnel loose ends with ped tunnel
  • go to surface with at least one pedestrian tunnel

More info:
  • size on ground = 1x1, empty square
  • template used is vanilla Metro Station, scaled 0.01
  • recommended to be placed on very flat ground, otherwise ped tunnels (-8m) may collide with metro tunnel (-10m)
  • cims are using both platform ends for enter/exit station
  • cims have to reach the middle of the platform, around station marker, to transform from pedestrians to passengers (they change from white to metro line colour). It seems this is how the game works, I hoped they transform faster, when they enter platform.

Thanks to everybody who made this asset possible. I hope you like it.

Please, be kind and do not forget to rate it!
< >
8 Comments
cacamaca8  [author] May 12 @ 7:21am 
Well, I've tested. Redesigned all stations with MNS active and then unsubscribed. When I load them in asset editor, without MNS subscribed and active, not all the pink paths are joined with ped tunnels (the joint is a small pink triangle).

So, I guess it's like this, by the way they look in asset editor when I load them without MNS:

- all assets I desgined using more paths connected on the same route (3 paths on a ped tunnel) probably work only with MNS active. Not all paths are joined.
- all assets designed with only one pink path connected with only one route (ped tunnel) probably work without MNS active (1 platform -14m V2 and Entrance Perpendicular). They seem to have all joints ok.

I don't know why, ask Bloddy Penguin, maybe he will respond to you. I told him already my UI is scrambled and assets designed with pink path do not work. I guess MNS is somehow assigning different ID to objects and when you are not using it, the game searches for original ID, not altered.
cacamaca8  [author] May 12 @ 5:45am 
I open asset editor, open any asset, doesn't matter which one, mine, vanilla etc, so More Network Stuff is loading. Because MNS is loading, it is breaking my UI, combining Paths with Canals. I asked Bloody Penguin if it's normal, haven't got an answer.

Then I quit asset editor and load my savegame (or start a new one). Paths are working. I tested my assets with downloaded savegames from stea (New York 350K people and Bella View 30K people) so it's not something special with my maps.

Really sorry, I have no clue how to help you. The usual advice: unisntall everything. I hate this advice...

Are you using "Loading Screen Mod"? I had prolems with it, so I've unsubscribed
mr.plexus May 12 @ 2:29am 
It seems that one feature breaks the other ))

When I start the saved game and try to put a new station - there will be no links for peds. Then I open assets editor and open this station there. After that I start saved game again - the links will appear. But! now I can't build pedestrian paths underground and above the ground ¯\_(ツ)_/¯ So I have to add new stations without paths, save and quit at all. Then load again and build paths for pedestrians... so difficult... but your stations are great! I love them! Please do something or tell me what should I do. Thanks in advance!
cacamaca8  [author] May 11 @ 9:09am 
hmmmm. If you open them in asset editor you don't have lots of pink paths? like...6 pink paths for 1 Platform stations (-14m), 3 paths each side of platform, connected to the ped tunnel? When they exist and are connected to ped tunnel, the joint is an arrow.

I'll update them in 1-2 hours, because I'm changing their base position to be easier to align with grid when you use Move It! Also shortened with one square the "stairs"
zapisol May 11 @ 8:50am 
Can't get it to work. Currenty I have two stations, one of them has no white arrows at all, and the other station has just two white arrows. One arrow the center on one side, and the other one on the oposite side but at the edge of it. All paths are connected and there are several exits on each station. The cims are using the underground path to move around the city, and also walk along the platforms never uses the metro. I don't see any pink paths. I've trided your "you may have to" and it's just the same.
cacamaca8  [author] May 10 @ 11:55pm 
The white triangles are the joint between hidden pink paths and normal ped tunnel. If you don't see them, the game didn't load the pink paths. I guess you have to take the steps with More Networks Stuff, as described above.
mr.plexus May 10 @ 3:34pm 
There is no white triangles at the platforms and cims don't "see" there is metro station. What's wrong?
cacamaca8  [author] May 7 @ 6:28am