Stellaris

Stellaris

25 ratings
British Empire
 
Rate  
Favorite
Favorited
Unfavorite
File Size
Posted
Updated
1.254 MB
Dec 19, 2017 @ 7:45am
Aug 7 @ 9:47pm
12 Change Notes ( view )

Subscribe to download
British Empire

Subscribed
Unsubscribe
Description
Play as the British Empire and expand your rule across the galaxy.

The world collapsed with economic and political ruin, wars started over petty disputes, but one nation was left ignored thought, and when the world was left in darkness, the island nation went out to reclaim what it lost. The Dominions united with them, and then, the world bent its knees to them, once again, The British Empire ruled the international stage, and then they set their eyes to the sky, to conquer for Queen and Empire. The Sun Never set on the British Empire, and in space, it never shall.

Mod includes custom Royal Emblem modernised to suet the galaxy expanding era. Also includes a background with the Union Flag (Union Jack), so you can change the background if you want.

Mod has a custom colour too (White) so I’m not curtain it will work with the extended colours mod.

Let me know if any balancing changes and so on I can do to make this more fun.
< >
31 Comments
Kennywnorth Oct 24 @ 11:00pm 
american version please? no good american flag mods
WolfCastGaming Apr 13 @ 9:54am 
ive Downloaded the Mod everything is fine however i cant get the flag to appear. Any solutions? I tried the fix that Magoozle tried but it hasnt helped me. perhaps i did it wrong. any help from anyone would be great.
Magoozle Mar 3 @ 9:34am 
I've verified files no joy, I deleted my entire stellaris workshop folder then closed steam and reopened, and resubbed to the mod, still no joy , just the flag missing.

However.... if i extract the files to a folder in my stellaris mod folder, it works perfectly. odd
tmikesecrist3 Feb 28 @ 5:59pm 
@ mattie HD It has been, it does give a compatabialty worning with the 2.0.1 update this morening, though it still works for me
Mattie HD Feb 28 @ 1:16pm 
is it going to be tpdated to 2.0 ?
tmikesecrist3 Feb 28 @ 5:44am 
update it does seem to still work at leat on my putter
tmikesecrist3 Feb 28 @ 5:41am 
any one know of the .0.1 update broke the mod, I am getting an incompatablaty worning on the launcher, but havent tested it yet
PlasmaticJj  [author] Feb 26 @ 10:40am 
@tmikesecrist3 what I do is go to the propertys and clock on "Varify Game Files" in steam to see of anything has been messed around with the code. Still looking into this, seems to be working fine for me, so trying to replicate the problem for myself so I can fix it is a bit of a challenge :/
Magoozle Feb 25 @ 3:21pm 
Flag not working here either, fresh install.
tmikesecrist3 Feb 25 @ 1:59pm 
@PlasmaticJj I am still having issues. with the flag to, I dont think I changed any of the game files though it is posable one of the mods, I have played with did. how would I check that Varify geme files?