Liftoff

Liftoff

Not enough ratings
Taranis Configuration w/model download
By Marklyftar
This is no longer needed in the latest version of Liftoff!

Setting up the Taranis to work with Liftoff on Windows or Mac.
Model download included.
   
Award
Favorite
Favorited
Unfavorite
Intro and Prerequisites
I noticed a few of you were having problems getting the Taranis to work, so I thought I'd go through the process of how I got it working.

  • First make sure you're on the latest OpenTX firmware. (available at http://www.open-tx.org/)
  • Download the eepe-file containing the two models for Windows and Mac, available here.[www.dropbox.com].



Writing the models to the Taranis
Start the Taranis in Bootloader Mode:


Insert the USB in the back:


Wait for the Taranis to be recognised. The Taranis has a reputation of being a little cranky on Windows. if you're having trouble, you can find lots of good info on the opentx web page linked above.


If you haven't already, install OpenTX Companion and/or open it.
It should look like this:


Now open up the eepe-file you downloaded earlier by clicking the folder icon, navigating to where you saved the file, and clicking 'open'.


You should now see the two sim models displayed within a seperate window in Companion.


With your Taranis plugged in, click 'Read Models and Settings from Radio'.


Wait for it to complete, you should now see something like this:
You will probably have different models listed, as this is what is on your radio.


Find an open spot in the list, and simply drag the model(s) you need over to the list from your Taranis.


Now make sure the window with the list you want on the Taranis is highlighted, then click 'Write Models and Settings to Radio'.
WARNING: If you highlight the wrong list before writing, you will lose the models already stored on your Taranis. It might be a good idea to close the window called 'Sim_models_taranis.eepe' before writing, leaving only the newly created list to be written. This way you keep your models safe :)

You should now be able to select the new models on the Taranis:
In Liftoff
Select the model on the Taranis corresponding to your system (Mac or Windows).

Launch Liftoff, go to the controls menu, and click on the Taranis preset.

I didn't have to do any calibration after this, but I can't guarantee that it will be the same for you.
Just check the sliders to make sure you have full range on all sticks.

I hope some of you find this helpful. I can't guarantee success, but this is what worked for me, so I thought why not share it if it can help others :)

Have fun flying!
< >
37 Comments
Marklyftar  [author] Oct 3, 2018 @ 1:30pm 
You're welcome, I'm glad it's still helpful!
MantisMax09 Oct 3, 2018 @ 10:59am 
Thanks, Great info!
Joey Aug 3, 2018 @ 9:49pm 
I finally got my D9X to connect to window 10. I had to change the USB Mode to Joystick in my D9X radio setup page 1.
Pherexian Jul 2, 2018 @ 7:06am 
I have a Taranis q x7, When I thouch my sticks it barely moves. But when they reach the limit it flippes like hell. What settings did u do in the remote? Ive got the weights and the offsets to 50
Marklyftar  [author] May 20, 2018 @ 2:04am 
Hey joberbr! I'm glad to see this is still helpful. Have fun flying!

fitrirz, I'm not sure why your Taranis stopped working after the update. My advice would be to have a look in the discussions to see if anyone else has experienced the same thing, and perhaps found a solution.
feet May 20, 2018 @ 1:11am 
hello...cant use my taranis after i updated liftoff to the latest versin. i tried but no success...any help? what should i look into?
joberbr May 18, 2018 @ 11:37am 
Hey this worked very well still. I just had to calibrate. I wasn't sure if it was because it was a new radio or not. But it only took a couple of minutes extra. Thanks so much for your help to the community.
gaggasi Mar 18, 2018 @ 1:35pm 
как сделать чтоб рестарт на тумблер был?
LuGus Studios  [developer] Dec 4, 2017 @ 3:02pm 
With the latest input changes to Liftoff, this information is now outdated.
Marklyftar  [author] Aug 24, 2017 @ 9:38am 
Hi Buzz, it might be that your version of OpenTX is below v2.x . I think the older versions won't let you enter bootloader mode with the procedure described here.

Have a look at this Open-TXU page [open-txu.org]

At the bottom of the article you'll find an alternative method for flashing the bootloader.
Hope that helps you solve your problem.