Quake
65 ratings
List of compatible mods for Quake Remastered
By Hal9000
Since the remastered version of Quake came out, I've been testing a few single player mission packs from start to finish and wrote down any issues I had with them so you don't have to. You're welcome.
5
2
   
Award
Favorite
Favorited
Unfavorite
About this guide
So you wanted to try a mod without having to check if it is compatible with the Quake Remastered version (or QuakeKEX, for short)? Well, today it's your lucky day because I fully tested plenty of them from start to finish and noted any compatibilty / performance issues I found on them.

Cool, but, where I can download them?

Most of them were downloaded from Quaddicted, the best Quake map database you can find on the net. I would link all the mods listed here, but the infamous Steam spamfilter would probably delete them all.

Are you a map author? Has your mod been updated?

If any of these mods marked as 🟨 or 🟥 is fixed, feel free to comment and I will update the guide.



Color guide:

🟩 Green mods are fully playable.
🟨 Yellow mods are mostly playable, expect bugs / performance issues.
🟥 Red mods have serious issues or don't work at all. Check for alternative sourceports like QuakeSpasm or DarkPlaces.
List of mods [A-H]
MODNAME
Found Issues
Workarounds / Fixes
🟩 Abyss of Pandemonium - Final Mission
N/A
N/A
🟨 Alkaline
ALK_CORRUPT not working.
ALK_TELLUS has low FPS.
Just use QuakeSpasm for those two. Rest of the maps will run fine.
🟨 Arcane Dimensions 1.8
AD_SEPULCHRE not working.
AD_TEARS not working.
Just use QuakeSpasm for those two. Rest of the maps will run fine.
🟩 A Roman Wilderness Of Pain
Prompts an error at startup
Type 'map start' in console.
🟩 Beyond Belief
Loading default Quake Start map
Type 'map bbstart' in console.
🟩 Black
N/A
N/A
🟥 Bloodmage
Essential custom bindings don't work (like 'use' or 'consume'), making this classic total conversion unplayable.
N/A
🟥 Bluemonday Jam
This map pack requires Quoth, which is not compatible for QuakeKEX
N/A
🟩 Contract Revoked
N/A
N/A
🟩 Contract Revoked - The lost chapters
N/A
N/A
🟩 Copperstone Summer Jam
Older versions of Cooper mod are incompatible.
Make sure you have at least 1.17 version installed.
🟩 Coven of Ebony
Loading default Quake Start map
Type 'map coestart' in console.
🟩 Digs01
N/A
N/A
🟥 Death's Dominion
Crash at K2M3 map.
N/A
🟥 DM4 Jam
DM4JAM_IONOUS is unplayable
DM4JAM_WW crashes
DM4JAM_ARTISTICAL crashes
DM4JAM_MUKOR crashes
DM4JAM_GIFTMACHER is unplayable
N/A
🟥 Dwell
Crash after killing final boss and finishing last map.
N/A
🟩 Epochs of Enmity
N/A
N/A
🟩 Func Map Jam 1 - Honey
N/A
N/A
🟩 Func Map Jam 2 - IKBlue/White
N/A
N/A
🟩 Func Map Jam 3 - Zerstörer
N/A
N/A
🟩 Func Map Jam 4 - Low Gravity
N/A
N/A
🟥 Func Map Jam 6 - Fire and Brimstone
All moving platforms (i.e. elevators) move backwards, making most maps unplayable.
N/A
🟥 Func Map Jam 7 - Back to Base
Ladders not working, new enemies missing.
N/A
🟩 Func Map Jam 8 - Noir
N/A
N/A
🟥 Func Map Jam 9 - Knave
This map pack requires Quoth, which is not compatible for QuakeKEX
N/A
🟨 Func Map Jam X - Insomnia
JAMX_FW not working
JAMX_PINCHY not working
Just use QuakeSpasm for those two. Rest of the maps will run fine.
🟥 Future vs. Fantasy
Mod works, but models for new weapons aren't shown, so you can't distinguish one class from another.
N/A
🟨 Halloween Jam 1
HWJAM_NYO crashes
Use other sourceport for that map, rest of the maps work fine.
🟨 Halloween Jam 2
HWJAM2_ARTISTICAL crashes
HWJAM2_PINCHY crashes if you pick the Nail Piercer powerup.
Use other sourceport for that map, rest of the maps work fine.
🟨 Halloween Jam 3
HWJAM3_SHADES crashes (Bad Pointer error)
HWJAM3_ENTJOY crashes
HWJAM3_ARTISTICAL crashes if you pick the Nail Piercer powerup
Use other sourceport for those crashing maps, rest of the maps work fine.
🟨 Halloween Jam 4
HWJAM4_RIKTOI crashes
Use other sourceport for those crashing maps, rest of the maps work fine.
🟩 Honey
N/A
N/A
List of mods [I-Z]
MODNAME
Found Issues
Workarounds / Fixes
🟩 Insomnia
Loading default Quake Start map
Type 'map cgz07' in console.
🟩 Malice
Need to bind keys for new actions (Thanks Malek86).
impulse 13 (torch)
impulse 14 (cycle items)
impulse 16 (reload)
impulse 17 (use item)
impulse 30 (cycle camera mode)
🟥 Nehahra
Crash at startup.
N/A
🟩 Navy Seals
Need to bind keys for new actions.
Essential binds are (check readme file for more):
bind r "impulse 100" to reload weapons
bind f "impulse 105" to switch firing modes
bind mouse_right "impulse 102" to zoom with sniper rifles
bind c "impulse 104" to crouch
🟩 Ontranto
Loading default Quake Start map
Type 'map fc1' in console.
🟨 Operation Urth Majik
Stuck at cinematic scene in Eye of the Storm map after picking up Blue Keycard.
Type 'impulse 175' in console to skip cinematic.
🟩 Penumbra of Domination
Loading default Quake Start map
Type 'map mexx9' in console.
🟩 Phantasmal Garrison V2
Loading default Quake Start map
Type 'map pgstart' in console.
🟩 Prodigy Special Edition
N/A
N/A
🟩 Rapture
N/A
N/A
🟩 Q2 Weapons Project
N/A
N/A
🟥 Quake 1.5
Not compatible for QuakeKEX
This mod only works for Darkplaces.
🟥 Quake Sewer Jam
Crash at startup.
N/A
🟥 Realm of the Lost
Crash at W1M4 AND W1M7 maps.
N/A
🟩 Retro Jam 1 - Medieval / Castle
N/A
N/A
🟨 Retro Jam 2 - Fantasy Brick Cities in the Skies
RETROJAM2_RICKYT23 stairs to the exit move backwards, making the map unplayable.
Use other sourceport for that map, rest of the maps work fine.
🟩 Retro Jam 3 & DLC - Vertical Metal / Runic
N/A
N/A
🟥 Retro Jam 4 - Episode 4 Tribute
All moving platforms (i.e. elevators) move backwards, making most maps unplayable.
N/A
🟥 Retro Jam 5 - The Wind Tunnels
All moving platforms (than includes wind tunnels) move backwards, making most maps unplayable.
N/A
🟥 Retro Jam 6 - Egyptian
All moving platforms (i.e. elevators) move backwards, making most maps unplayable.
N/A
🟩 Rubicon 1&2
N/A
N/A
🟨 Rubicon Rumble Pack
TELEFRAGGED map has low fps
N/A
🟩 Shrak
N/A
N/A
🟨 Sinister 625
SINISTER625_PALMLIX crashes
SINISTER625_NAITELVENI could crash if you kill too many zombies at once.
Moderate your killing spree on Naitelveni map.
🟨 SMEJ Jam
Crashes on START map when entering on some portals.
Type 'map SMEJJAM_<author>' on console to play. Look up internal readme file for maplist.
🟩 Something Wicked
Loading default Quake Start map
Type 'map wickedstart' in console
🟨 Soul of Evil
Every time you load a map the game shows an error message.
Just press 'Continue' button, the map will load anyway.
🟩 Soul of Evil - Indian Summer
N/A
N/A
🟩 Terra
N/A
N/A
🟩 The Altar of Storms
N/A
N/A
🟩 The Punishment Due
Older versions of Cooper mod are incompatible.
Make sure you have at least 1.17 version installed.
🟥Torrent of Impurities
Crash at startup.
N/A
🟩 Travail
N/A
N/A
🟥 Underwater Jam
Crash at startup.
N/A
🟩 Underdark Overbright
Older versions of Cooper mod are incompatible.
Make sure you have at least 1.17 version installed.
🟩 Unforgiven
Loading default Quake Start map
Type 'map unfstart' in console
🟨 Unused Jam
UNUSED_CUNNA crashes
N/A
🟨 Xmas Jam 2017
XMASJAM_ICEQUEEN crashes
XMASJAM_PRITCHARD crashes
N/A
🟨 Xmas Jam 2018
XMASJAM_BAL crashes after pulling lever to extend bridge
N/A
🟨 Xmas Jam 2019
XMASJAM_BEEP crashes
N/A
🟩 Xmas Jam 2020
N/A
N/A
🟨 Xmas Jam 2021
XM21_GRUE crashes
XM21_HERESY crashes
START map crashes when you unlock Evil Difficulty
🟩 Zerstörer
N/A
N/A
< >
14 Comments
MUG slayer Apr 16 @ 12:10am 
Is "Slayer's Testament" compatible with the remaster?
Axer128 Mar 19 @ 8:19am 
Great guide.. But your weird unicode colored characters system does not work on my browser - chrome. Probably it's dark mode breaking it, but tons of people use dark mode so recommend you change that to something more normal.

Does work okay on firefox.
twoplugs Jan 18 @ 1:23pm 
Running Malice in the remaster: whenever I pick something up the screen goes black, except for hud elements. Happens with ammo, weapons and useable items. Also cheating in items then using them makes the screen black. Made the game unplayable.
Mopey bloke Dec 31, 2021 @ 1:51pm 
Where is that new version of Quake Injector. It isn't on their GitHub.
Ninjamestari Dec 11, 2021 @ 4:31pm 
I wonder if Air Quake still works. Best mod ever.
SHADOWELITE7 Dec 8, 2021 @ 7:18am 
A new version of Quake injector on GitHub doesn't require java as its now in its own executable vs opening it as a jar file.
ksy Nov 22, 2021 @ 8:29pm 
Try this: https://github.com/hrehfeld/QuakeInjector/#installation

And try installing latest jdk (16). To check your currently installed version do 'java -version' in powershell
.⁧⁧⁧⁧MR.HEADCRAB_VR Nov 6, 2021 @ 4:12pm 
Oh allright Also thanks for answering
Hal9000  [author] Nov 6, 2021 @ 1:50pm 
@MR.HEADCRAB_VR Nope, Quake 1.5 is a Darkplaces-only mod.
.⁧⁧⁧⁧MR.HEADCRAB_VR Nov 6, 2021 @ 1:08pm 
so that means Quake 1.5 isnt compatible?