Killing Floor

Killing Floor

47 ratings
Better tool for fixing Gimli That Axe
By Jippen Faddoul
Hey achievement hunter - wanna get Gimli That Axe? Don't like your steam achievements going through some random heroku server that might fail at any time? Don't trust sketchy exes from {LINK REMOVED} Come here for a better solution.
4
   
Award
Favorite
Favorited
Unfavorite
Intro
So, I saw the guide and code posted by Leeson, and I honestly didn't like it.

I mean, sure it *worked*, but it had several flaws.
  • Just download this exe from this site that steam makes the URLs break
  • Just trust me (ick)
  • Random pastebins pointing to unversioned libraries that might break in the future
  • Reliance on a free tier heroku instance thats... not needed at all

The community deserves better. So I made a better tool.

  • Hosted on GitLab
  • Build process is public, logged, and auditable - don't trust me, check yourself
  • Also builds a linux compiled version in case someone wants that. ( Sorry OSX users, its a massive pain to build binaries for OSX without spending $100+ these days.)
  • All local - no sketchy heroku instance needed
  • Proxies other steam API requests so the world doesn't break if you forget to clear your hosts file immediately


Additionally, this tool, like leeson's, IS approved under both the Unified Achievement Hunting Rules[achievementhunting.com] and the AStats Guidelines[astats.astats.nl]
0. Get "Not A War hammer" in Dwarfs?!
Prerequisite: You need to play this F2P game until you've collected 40,000 gold and unlocked the achievement "Not A War Hammer"

My tip: Start a 60 minute arcade game on easy, then just click on a dwarf and drag a line to the nearest pile of silver or gold. Repeat and fumble until you eventually lose due to flooding your base or w/e - but should have more than enough gold for the achievement to pop anyways!

https://store.steampowered.com/app/213650/Dwarfs__F2P/
1. Set your Steam Profile to be Public
In order for this to work, Killing Floor has to be able to view your game details. Steam, by default - broke this for enhanced privacy.

So, if you havn't already, you'll need to open that up. On your steam community page, click "Edit Profile" then go to "Privacy Settings"

Or, if you're logged in, this link should work: https://steamcommunity.com/id/me/edit/settings

Then, set things to public as shown below. If you're concerned about your privacy, you can set this all back when you're finished.

2. Download my tool
Binaries are here: https://gitlab.com/jippen/killing-floor-gimli-that-axe/-/releases
Source code is here: https://gitlab.com/jippen/killing-floor-gimli-that-axe


For ease of use, download the binary appropriate for your platform. If you want to verify my work, click the source code, download it, install the requirements in requirements.txt with pip, and run it with python.

You'll want to unzip this somewhere. Preferably into its own folder for easy cleanup when you're done.


Now, before you start getting excited: Don't run it yet. We need to set up the hosts file.


3. Setup your hosts file
So, there are two ways to do this. The Manual Way, or the Easy Way (windows only)

Manual Way

First, locate your hosts file.

Operating System
File location
Windows
%windir%/system32/drivers/etc/hosts
Linux
/etc/hosts
OSX
private/etc/hosts

Once you find the file, you'll need to add the following line to it:


NOTE: On windows, that should be a single space. Don't get fancy with tabs or multiple spaces, as some versions of windows will fail to parse that line if you do.

Easy Way (windows only)

There's a nice, simple opensource tool for this called Hosts File Editor[hostsfileeditor.com].

Simply download it, accept the popup when you run it to run as admin, and you get a nice GUI. Double click the boxes, edit them as you see in this screenshot - ensure the checkbox is selected, and hit "Save"

4. Start up the tool
Now, double click the KF_GimliThatAxe.exe (or run the python script if you're hardcore) and... probably get greeted by this scary window:

So, whats with the warning? Turns out these days, if you don't pay for a code signing key, and sign your .exe files (about $100), Microsoft will freak out and say that its unrecognized and dangerous. This is very, very annoying for the open source developer. If you believe I'm not going to wreck your computer, or have checked out the gitlab repo enough to satisfy your paranoia, then click *More Info*






You should now get this equally scary looking screen. Yay. Now you can click the magic new button *Run anyway* to keep going.













Now, you might get a terminal that looks like this. If you get this error message, well, scroll back up to where I said you had to set up your hosts file, and do that. This is why I said don't get all excited. :)






But, if everything's right, you should how have a window that looks like this

5. Get the achievement
Now, we have our achievement in Dwarfs?!, we have our tool running - so launch Killing Floor and start a solo game. Pick any map, then hit the "Ready" button.

As soon as you enter the map, the game checks and you should have the achievement!
6. Cleanup
Now that you're done, its time to clean up after the previous steps.

For your convenience, here's a little checklist:

  • Close the tool's window by pressing Ctrl + C, or just clicking the x in the corner
  • Delete the folder
  • Remove the entry for "api.steampowered.com" in your hosts file
  • (Optional) Set your steam profile privacy settings to what they were before
  • *Drop a thank you in the comments*
Shoutouts
If you're looking for a group to hunt for achievements with, consider joining 100Pals. We emphasize creating a non-toxic, diverse group of achievement hunters, and happily welcome folks who want to join the hobby.

Find out more at https://achievementhunting.com
< >
15 Comments
Rantsi Feb 18 @ 7:31am 
Cheers Jippen. Appreciated
Bad_squirrel Jan 17 @ 9:29am 
wow! I did not expect that to work as intended but it did follow the steps and the achievement could be yours. thank you for making this file. The tripwire website says that the achievement can not longer be unlocked and they do not intend on fixing it.
ViperinZ Dec 4, 2020 @ 1:24am 
Tried it in 04.12.2020 and worked! Cheers!
Ultionys Aug 3, 2020 @ 1:20pm 
Thanks dude ! Worked simply, as advertised !
Barbatos99 Jul 28, 2020 @ 3:45pm 
Thanks a lot dude! i will love to see a translation of this in spanish / portugues so the word spreads that it still works!
3 Suns Gaming Jul 15, 2020 @ 5:56pm 
Worked like a charm with no issues, Thank you
Jippen Faddoul  [author] Jul 10, 2020 @ 12:06pm 
Thanks a ton, adxim for getting me on the right track, and Hamstersex for being a great tester. Version 1.1.0 is now on gitlab with better error messages and that dll error fixed!
Hamstersex Jul 10, 2020 @ 10:55am 
Got it, thank you! :strength:
Hamstersex Jul 7, 2020 @ 2:08pm 
@Jippen Faddoul
Sure thing!
adxim Jul 7, 2020 @ 12:59pm 
I had to install all python libraries to make it work for both the exe and main.py script
dnspython
hosts
requests

without these modules your script and exe wont work, anyway got the achievo, Thanks for the fix.