Prototype

Prototype

172 ratings
*WORKING* resolution fix for Win 7 & 10
By EvilPolygons
Problems running Prototype on Windows 7 or 10? Try this.
4
   
Award
Favorite
Favorited
Unfavorite
The Fix:
This fix actually worked for me under Windows 7 (and 10), whereas the other "fixes" I found did not. Go to http://www.wsgf.org/dr/prototype and look under the Solutions & Issues section. From there, download "Prototype_All_Res.zip." !!! See updates section below for current download locations !!!

Backup "prototypeenginef.dll" and replace it with the file inside the zip. The original file is located in C:\Program Files (x86)\Steam\steamapps\common\Prototype. This will set your game resolution to whatever your Desktop is set to.

You may or may not be able to change your video settings ingame anymore after using this fix, but you can, if necessary, still set your AA and AF through the Nvidia Control Panel.

Hope this works for you! Prototype is an awesome (if very underrated) game!


NOTE: This fix is for the resolution bug in Prototype. It isn't meant for fixing general crash issues. However, BioEvilCat has this tip for those experiencing crashes on modern hardware:
"After doing all file processes (ie, applying the fix described above), open TASK MANAGER --> DETAILS tab --> and go to the STEAM.EXE process. Set its affinity to only FOUR cores and hit okay. PROTOTYPE 1 is optimized to run on processors with 4 cores down."
BioEvilCat was suffering crashes on a 12 core CPU and setting the affinity to only 4 seems to have fixed their problem.


Update 12/30/2015
The original file link is down. Thanks to Steam user Shaidon, it is currently hosted at:
https://mega.co.nz/#!29MjlYRa!qt2ai0-ofJQgqbvnB1UXNjOhATlz4cPhR9FAXj4To7o

This fix was originally for Windows 7, but some Windows 10 users have reported that it has worked for them, as well.

Update 07/31/2020
As of this date, the original Wsgf.org page again has links for where the fix can be found, but still no direct download links.

The Mega download link from 2015 still works for the original fix.

This page has a direct download link to what I believe is a more recent version of the fix: https://community.pcgamingwiki.com/files/file/1486-prototype-resolution-and-fov-fix/ .

I've long since upgraded to Windows 10, and can confirm that the fix currently found at pcgamingwiki.com works for me!



85 Comments
EvilPolygons  [author] Apr 15 @ 2:18pm 
@morteza56
I just checked and the pcgamingwiki link is still good. It takes you right to the download page.
morteza56 Apr 14 @ 6:28pm 
there is no file .
post file here plz
EvilPolygons  [author] Nov 22, 2023 @ 7:04pm 
@Dovahkiin
This fix is for the resolution bug, not a crash fix. You can try BioEvilCats's fix if you're having crashes.
Dovahkiin Nov 22, 2023 @ 3:33pm 
crashes... try to load up campaign (new game) and loads for a few second...crashes
KryptikRVR Jan 22, 2023 @ 5:57am 
This worked a treat ( along side 2 other fixes haha)
EvilPolygons  [author] Jan 9, 2023 @ 5:44pm 
@TRUTE
Awesome! Glad it helped!
TRUTE Jan 9, 2023 @ 8:41am 
Still working, thanks!
SpaceWingman Sep 29, 2022 @ 1:51pm 
Does only run in slideshow mode, no fix, setting, cpu setting, mod pack or else worked.
My last hope is basically a virtual machnie with windows 7
Duljish mi pari Aug 10, 2022 @ 12:02pm 
Try the game on VULAKN api.
☪Al3xM3rc3r✠ Mar 18, 2022 @ 6:45am 
finaly