Dragon Age: Origins - Ultimate Edition

Dragon Age: Origins - Ultimate Edition

197 ratings
Enabling the console in the Steam version of DA:O Ultimate
By MonkeySeeker
A simple guide on how to enable the console in the Steam version of Dragon Age Origins Ultimate.

Link to download files is now fixed.
 
Rate  
Favorite
Favorited
Unfavorite
Intro
For the purposes of this guide I'm going to assume Steam is installed in the default location and your Steam games are also installed in the default location. If not you'll obviously need to look in whatever directories you installed them in.

You now have two options:

You can either download the pre-edited files and place them in the relevant locations, in which case just follow "The simplest method" part of the guide.

You can also just edit the files yourself if you prefer, in which case follow the "Editing The DAOriginsLauncher.xml File", "Editing The KeyBindings.ini File" & "Making The Console Visible" parts of the guide.
The simplest method
Download the pre-edited files from OneDrive
[1drv.ms]

There's two files in there and they need to go in the following locations - please note the locations carefully and make sure they go in the exact folders:

  • The DAOriginsLauncher.xml file
    C:\Program Files (x86)\Steam\SteamApps\common\Dragon Age Ultimate Edition\data

  • And the keybindings.ini file
    \My Documents\BioWare\Dragon Age\Settings\

Note that I have set the console to open with F7 rather than the tilde ` key as it causes issues with non-US Keyboard layout users. If you don't like that choice of key then see the section on editing the keybindings.ini to change it to a key of your choice.

Then go to Nexus Mods[www.nexusmods.com] to download the fonts.erf file to make the console visible. Place it in:
\My Documents\BioWare\Dragon Age\packages\core\data

That's it, the console should be working and visible.
Editing The DAOriginsLauncher.xml File
Go to
  • C:\Program Files (x86)\Steam\SteamApps\common\Dragon Age Ultimate Edition\data

  • Right click the DAOriginsLauncher.xml file and open the file with notepad.
  • Find the line
    <condition name="FirstRunCheck" type="FileExist" file="${USERDATA_DIR}\SystemInformation.xml">
  • Below that line should be this line
    <true action="execute" file="${BINARIES_DIR}\DAOrigins.exe" path="${BINARIES_DIR}" autoquit="true" />
  • Just before autoquit="True" /> add this: arguments="-enabledeveloperconsole". The line should then read
    <true action="execute" file="${BINARIES_DIR}\DAOrigins.exe" path="${BINARIES_DIR}" arguments="-enabledeveloperconsole" autoquit="true" />
  • Save the file
Editing The KeyBindings.ini File
You now need to edit your keybindings file to assign a key to open the console.

  • Go to \My Documents\BioWare\Dragon Age\Settings\
  • Open the KeyBindings.ini file in notepad
  • Find the line that starts OpenConsole_0=
  • Change the part after the = sign to the key of your choice. For example Keyboard::Button_Tilde to use the Tilde key which is above Tab and to the left of 1.

    NOTE: Some people have reported issues using the Tilde key when using a non-US International keyboard layout. I usually just set it to OpenConsole_0=Keyboard::Button_F7 so the console opens with the F7 key instead to avoid any issues

  • Once you have chosen and set your key save the file.
Making The Console Visible
Now those two edits are done the console should now work in-game.

However you will be unable to see it without the use of a mod (the console is invisible at this point though it does work).

  • Download this mod[www.nexusmods.com] from the Dragon Age Nexus
  • Extract the fonts.erf file from the archive (use WinRar or 7-Zip)
  • Place the fonts.erf file into
    \My Documents\BioWare\Dragon Age\packages\core\data

Now the console should be both enabled and it should be visible.

Thank the maker!
< >
85 Comments
123 Nov 11, 2018 @ 5:17pm 
OMG thank you very much. Was failing in doing this for Years. Thank you so much
viperness73 Jun 28, 2018 @ 1:57am 
Yo
callum521 Mar 9, 2018 @ 1:15pm 
Omg finally! I swear I have spent a good couple hours trying to get this to work from other people but they either are way too vague or just overcomplicate it. Thank you good sir for making this!
janusqc Jul 16, 2017 @ 5:43am 
Thank you very much!
FllnPhnx Jul 1, 2017 @ 9:08pm 
Did everything that was said. Console still didn't open. So, I tried the way I had originally done it for my disc version. Which was right clicking on the DA shortcut, going down to properties and in the Target box, typing -enabledeveloperconsole after the bin_ship\daorigins.exe" Make sure there is a space between daorigins.exe" and -enabledeveloperconsole . Still had to change the keyboard ini to the tilde key and downloaded the font.erf file from nexus to see the console. Works fine now.

I see that some people had no trouble with the instructions in the original post, so I guess you just have to try different methods and see what works for you.
darkdream787 Jun 29, 2017 @ 6:10pm 
I noticed in his files he edited it differently

On here it says put it before autoquit=true like this
<true action="execute" file="${BINARIES_DIR}\DAOrigins.exe" path="${BINARIES_DIR}" arguments="-enabledeveloperconsole autoquit="true" />"

While in his edited file it is after autoquit=true and this one actually works.
<true action="execute" file="${BINARIES_DIR}\DAOrigins.exe" path="${BINARIES_DIR}" autoquit="true" arguments="-enabledeveloperconsole" />"


The console appeared to work, but the font was not visible.

Adding the fonts.erf file to "\My Documents\BioWare\Dragon Age\packages\core\data" like stated above did not work, so I listened to the text document included with the fonts.erf file instead of what this guy put.

What I had to put fonts.erf in for this to work was "C:\Program Files (x86)\Steam\steamapps\common\Dragon Age Ultimate Edition\packages\core\data"
Whiskeyjack Apr 24, 2017 @ 6:13am 
Maybe it doesn't work on windows 8.1?Because I did everything written here and I have the open console entry in KeyBindings.ini, I tap the key assigned and nothing happens
maxirace Nov 5, 2016 @ 11:57am 
Great! Thanks, It's working
Tuld Sep 7, 2016 @ 5:15pm 
Since upgrading to Windows 10, I've been unable to get this to work. It worked swimmingly in Windows 7. I've tried all the methods mentioend above.
victoura56 Jun 25, 2016 @ 7:47pm 
Had a mini panic attack when I couldn't find the BioWare folder. Forgot to realise the game needs to be installed before that shows up. I feel like such an idiot. But thanks for this guide! :)