Pro Office Calculator

Pro Office Calculator

Not enough ratings
I give up! Spoil the crap out of this game for me!
By brightshadow
This guide will give you the tools you need to get through the stages of Pro Office Calculator. Or beat you over the head with the answers, if you prefer.

Spoiler tags used heavily throughout for your protection if you just want hints.

Read at your own risk!
 
Rate  
Favorite
Favorited
Unfavorite
Guide to the Guide
I will explain the stages of the game vaguely. The chapter topics might be minor spoilers, but you're looking at a guide, so you're probably okay with a tiny amount of spoilers at the very least.

I'll include spoiler tags for anything that isn't color commentary -- the spoilers will typically begin with a small "have you checked ____?" hint and get more specific until they explain in no uncertain terms how to complete the level.

Spoilers look like this. Mouse over to read them. Be careful not to mouse over ones you don't want to read.
Stage 1: The Calculator
Yep. It's a calculator. It's kind of a crappy calculator, but it works.

Hint: Have you looked at the Help -> About menu?

Bigger hint: Have you tried turning it off and on again?

Even bigger hint: Close and reopen the game repeatedly. The number on the Help->About menu will decrement from 10 to 1 and then change to a couple of symbols.

Still stuck? How do you confuse a calculator?

RUIN IT FOR ME: Divide something by zero. 1/0= will do the trick. Congratulations, you're on the next stage!
Stage 2: I think I broke it
Yep. It's still a calculator. Except now it doesn't make sense.

Hint: Have you checked the menus?

Bigger hint: Why does the settings menu not have any settings? What's that weird number mean?

Even bigger hint: The calculator still works, but the buttons are all scrambled. Not just the characters on the buttons; the buttons themselves are mixed up. Note that when you open Settings it's in a new window -- just drag it off the top of the main window so you can see both things if you like.

RUIN IT FOR ME: You need to make the calculator display the number in the Settings menu. You can figure out which buttons correspond to what actual buttons through trial and error.

First, find the C button. This should be easy; it clears the display.

Next, find the equals operator. After clearing the display, spamming the = button will show a result of 0. Note the symbol for 0. Note that you now know which button is 0 on the calculator. Now we know C, =, and 0.

Next, find the decimal point button. This will only appear once on the display no matter how many times you hit it, unlike the other digits, which will let you enter them repeatedly.
Then, identify the digit buttons 0-9 (see above).


All that's left are the operators + - / * =. These appear under the display when pressed.

You can figure out the division operator by dividing something by zero; that will display an error.

You can then figure out the 1 by figuring out which symbol divided by 1 always equals itself [x/1=x].

Next, figure out the subtraction operator (-) by finding which button lets you perform 0-1 for a result of -1: The digit displayed before the 1 symbol on the display will match the button symbol you use to subtract values.

You can figure out the rest of the numbers by just adding 1+1 and that shows you what symbol means 2, then add 1 repeatedly to see what all the other numbers are.

If you want to know which one is division, you can do [2/2=1], and then you know which is multiplication because it's the last operator remaining.

At this point you have more than enough information to enter the number on the Settings screen to proceed.

It helps to take notes on paper or in notepad/excel as you figure the buttons out. I just did it in Notepad, like this (below is the layout of the buttons as they were when I played it to write the guide - I don't know if it's randomized every time or not):

(-)
(C) (6) (0) (7)
(5) (8) (=) (*)
(.) (9) (1) (4)
(+) (3) (/) (2)

All you need to do now is clear the display and enter the number showing in the Apex OS window. Congratulations!
Stage 3: Admin Login
Well, now you've got a login and the Settings dialog just has a single button to open the admin console. Now what do?

Hint: Are you sure you want to continue?

Bigger hint: Yes, these get ridiculous. You just need to figure out whether you need to answer 'no' or 'yes' to continue as it gets more and more ridiculous.

HOW THE HELL DO I DO THIS?!: This one is confusing on its face, but what you need to do is distill the questions it asks down to whether it's asking if you want to continue (yes) or abort (no).

How I handled this is to keep track of whether the question is asking if I want to continue or not by just thinking of 'yes' or 'no' and toggling the answer back and forth as I counted the negatives.

Here's a moderately ugly example:
"Are you sure you are not not not sure you are not not sure you want to abort not aborting continuing aborting aborting continuing to abort aborting?"

Are you sure [yes] you are not [no] not [yes] not sure [no] you are not [yes] not sure [no] you want to abort [yes] not aborting [still yes because this means continue] continuing [still yes] aborting [no] aborting [yes] continuing to abort [no] aborting [yes]?

I literally pointed my finger up if I was going to say yes and then switched to pointing down when it hit a negative, and repeated up/down as the above example dictates.

Most (possibly all) of the time "not" and "abort" are the things you count. Start assuming you want to click yes, then toggle as you hit those words.

You'll get the hang of it. Probably.

You can also try simplifying the statement by typing it up and removing double negatives if that's easier, though it's much more tedious.

Anyway, after several attempts, you'll get a "proceed" button. Click that. Yes, it tries to get away. You can still click it if you catch it quickly enough, keep trying.


I got to the admin console, now what?

Hint: You can already see the username right there.

Another hint: It says you can hit arrow up or arrow down to scroll through the history, just like you would do at a normal command prompt.

RUIN IT FOR ME: I already did. Hit the up arrow a couple times. There's the password. Type in the user (rob) and the password (what he changed his password to before he typoed logging out of the console) into the main window. Congratulations!

Stage 4: Tetromino Troubleshooting
Okay. Well, this is a mess. Do I have some sort of virus?

Hint: Help -> Troubleshoot.

Still stuck: Click troubleshoot. Tell it that it fixed the problem. Hey, why is there another tab on the troubleshooter window?

Still stuck. RUIN IT FOR ME: The image there is instructions on how to interact with that tab. Click somewhere in the image to begin [or to resume interacting with it if you've left focus]:

Esc: Leave window focus
WASD: Movement
E: Jump
Space: Interact
Click: Enter window focus

Yep. It's Doom. Kinda.

Open the door that opens, interact with the switch to turn on the green light, then return to the top room. The previously locked door will be open, and you can just leave into the sky to complete the level. Congratulations!
Stage 5: Installing Pro Office Calculator
No exciting description here. I guess some jerk uninstalled your calculator software. Let's put it back.

Hint: You don't need all the features. In fact, installing them all will make the Doom level basically impossible.

Bigger hint: You need to ride the elevator that slowly rises (more slowly the more options you chose to add to the calculator buttons) while killing the dudes opposite the elevator to avoid losing all your health before reaching the top. If you're dying before you get to the top, use fewer features.

I keep dying! Halp!: Choose fewer features if you have to. You should be able to collect 40 ammo before running to the button and hitting it; once you're on the elevator, you can dodge back and forth a little while it rises while shooting the dudes. Keep holding S (and jumping if you want) -- when you reach the top you can back up then run down the hallway to escape the dudes' line of sight and thus danger. Now you're in a room with a number, and the calculator will appear with the buttons you've selected. Find a way to enter that number into the calculator display using the tools you selected.

RUIN IT FOR ME: The 5 will dodge your clicks like the other button did; you can use the 5, but you have to want it.

The 'experimental' buttons explode after you click them once, so make it count if you want to use them, or else you're restarting the level.

Every 21 clicks, the number will reset, so you need to be able to make the number on the calculator match that above the door in 20 clicks (the 21st click must be the equals button).


NO, I MEAN SERIOUSLY RUIN IT: The easiest way to do it without having to figure out math is to take several digits including 0, and the decimal point.

When you reach the door, spam click 0 until you get a number that you can enter with only the numbers you have selected; then simply enter the number directly into the calculator (it will ignore the zeroes for the purpose of satisfying the password). The decimal point will explode when you click once, but you only need to click it once. On my guide run, I went up the elevator with 0, 1, 2, 4, 6, 7, and the decimal point and it took a couple dozen resets to get a friendly number generated (1071.42). Congratulations!

Stage 6: Checkin' the Mail
Well, now we've got a text document explaining the Y2K problem, an email client, and our trusty calculator. Guess we should read Larry's email while we're here, right?

Hint: Read all the emails, top to bottom. Check the desktop window again. Why's the calculator red now?

Who's this guy?: Larry's just doing his job, man. You should probably get him away from his desk somehow. What happens if you shoot stuff from in here? WAIT, ARE WE INSIDE HIS COMPUTER?

Still stuck?: You can shoot the calculator buttons to press them.

STILL stuck?: Divide something by zero to crash the calculator. Larry freaks out and runs into the room. Just kill him; he's got a key to the server room door. Check your email again. Notice anything different?

What's this room for: It's a connection to the mailserver. You can shoot the servers to destroy them.

Oh no! I'm out of bullets!: You can jump up on the file cabinet to get out the window. There's a bunch more ammo out there. You can get back in the main area using the crates outside the window. Look around while you're out there.

Hint: Check Larry's email again. Rob left you a note.

I JUST KEEP FALLING TO MY DEATH, ARGH: Did you look at that diagram outside? There's a ledge halfway down the shaft. Hold D to slide into it on your way down and you won't take lethal damage from the fall.

Doors? Just enter the doors in the order of the code Rob gave you and travel through the loop back to the main room -- it will enter a number above the door that has no number above it. Repeat to enter the code for the exit door and it will open. Congratulations!
Stage 7: File Browser
Welp. Only one thing to interact with. Guess we're playing Doom again.

Maze section 1 hint: It's a normal maze to start. You can just follow the left wall until you reach the white-walled area. If you follow the right wall, you may have gotten yourself really lost. Don't go that way. If you really want to go that way, the guy in there tells you 'people go north to die.'

Maze section 2 hint: There are four switches you need to hit in a fairly short time frame. One switch will activate, which unlocks a second switch, which unlocks a third, and then a fourth.

I can't do section 2 quickly enough: You may have noticed that activating one switch appears to activate another switch at the same time in the white walled area. It's the same switch; some of the archways actually exit into the same room as you came from -- if you've played Portal, then this will make more sense. You can use these 'portals' to your advantage to quickly move from switch to switch. Hitting the fourth switch lowers the large gray pillar, so you can get on top of it from the staircase.

I did the switches, but what now? Go up onto that pillar that lowered down. You'll see a guy. Shoot him. People go North to die. Congratulations?

Final room hint: Jump up the platforms in the main room, hit the switch to open the door, Larry runs out of the recycling bin. If you check the refreshments room, there's a number on the vending machine. It was 0684 for me. I have absolutely no idea what that number means, though. Maybe there's an easter egg I haven't found? Follow Larry out into the sky. Congratulations!
Stage 8: Doomsweeper
THIS MINESWEEPER GAME IS IMPOSSIBLE: No it isn't.

THIS DOOOM GAME IS IMPOSSIBLE: No it isn't.

YES IT IS/YES THEY ARE: Try opening both at once.

Bigger hint: The Dooom game and the Minesweeper game are the same map. You can use Minesweeper to track your movements on the Dooom map; "mine" rooms will contain enemies and/or hazards; numbered or blank rooms will not.

This is hard (more of a tip): If you have the health to spare, you can just run through the dangerous rooms and leave through another door. The rooms with four bad guys are particularly rough to run through, but not impossible; be sure when you're running through the room and hitting the exit door that you don't interact with the door twice, because you'll shut it in your own face doing that. Be careful of the danger rooms with the abyss between the jumping platforms; those are instant death.

You cannot leave back through a door you entered the room from, however, you have to always go forward.

Many rooms have ammo or health packs.


Even bigger hint: You need to find three special rooms in the Dooom maze that contain whiteboards with the instructions that the whiteboard in the first room mentioned. These instructions need to be entered into the Terminal window in the order mentioned.

Bigger still hint: The special rooms have diagrams showing where you came into the maze in Dooom and where you need to exit in the top right. They also show the grid locations of the other special rooms. Find the three rooms, type the commands from the whiteboard into the terminal window (it will say 'success' when you enter one correctly) and then exit the maze in the top right to find the final command. Enter that into the terminal and you should be good to go from there. Congratulations! Put your name in the high score list.
Stage 9: Rockin' New Years Eve
OH NO IT'S TIMED!

Hint: You've been here before. Go to Rob's house. He's left you a note. Don't forget to check the basement.

These stupid stairs are too tall! If only you had something to throw with which to jam up that giant gear there!

I made it over the jumping platforms but now it's just a wall! What is this crap?! It certainly looks that way. Maybe a leap of faith is what you need?

RUIN IT FOR ME: It's just your perspective that makes it look like a wall. You can jump across and there's a staircase that leads up to a switch. Go up and hit it before the timer's up. Let the timer run out so the clock rolls over to Y2K. Congratulations!
Stage 10: Office Work
RUIN IT FOR ME: No. That's it. You're done. Kinda anticlimactic, huh?

Check Help -> About for that easter egg you worked so hard for.