Watch_Dogs 2

Watch_Dogs 2

31 ratings
Fix Watch_Dogs 2 not starting (Multiplayer enabled)
By Kerolyte
A guide to fixing Watch Dogs 2's launching problem
4
   
Award
Favorite
Favorited
Unfavorite
The fix that worked for me (Multiplayer works, too)
For this fix, we need to delete a file in the game repository.

1. Head over to your Steam Library

2. Right-click Watch_Dogs 2

3. Click Properties

4. Go to the Local Files tab

5. Click Browse Local Files..

6. Access the bin folder

7a. Delete the DbgHelp.dll file.

7b. Alternatively, you can Cut the file and safekeep it in another folder just in case. However, it's likely you can recover it by Verfying Game Cache.

7c. There might be a third method: Renaming the DbgHelp.dll file to something else so the game doesn't recognize it, and considers it deleted. Would appreciate if someone confirmed this (You will be credited)

7c. Thank you Lazahrus (76561198003339259)!
Renaming DbgHelp.dll works, with a minor remark: read below for more information.

Originally posted by Lazahrus:
Confirmed, it works renaming just the file. I would also like to add that I had to do it in the bin_plus folder, instead of the bin folder.

That's it! I really hope this fixed your game. I have been reading the the support page of Ubisoft and browsed pages of Steam Discussions until I found this fix.
The fix, with screenshots
For this fix, we need to delete a file in the game repository.

1. Head over to your Steam Library



2. Right-click Watch_Dogs 2
3. Click Properties







4. Go to the Local Files tab




5. Click Browse Local Files..



6. Access the bin folder








7a. Delete the DbgHelp.dll file.





















7b. Alternatively, you can Cut the file and safekeep it in another folder just in case. However, it's likely you can recover it by Verfying Game Cache.

That's it! I really hope this made you able to launch your game successfully and made it worth your money.
A fix that worked, but disables Multiplayer
For this fix, we need to add a launch paramater to the game. Keep in mind this fix disables multiplayer; since it disables the anti-cheat software EasyAntiCheat, which is required for online play.

1. Head over to your Steam Library

2. Right-click Watch_Dogs 2

3. Click Properties

4. Click Add Launch Paramaters..

5. Paste this in the field:
-eac_launcher

This fix is much simpler. However, remember this fix disables all online features.
Other general pointers that might help
Follow these steps as a last resort

For your convenience, this list is ranked from easiest to follow, least time-consuming (•) to more time consuming (•••)

You can try:
• Reinstalling EasyAntiCheat manually from C:\ProgramFiles(x86)\Steam\steamapps\common\Watch_Dogs2\EasyAntiCheat_Setup.exe
• Launching Watch_Dogs 2 from Uplay
• Starting Uplay as admin
•• Verifying Game Cache on Steam
••• Updating Graphics Card drivers

NVIDIA Drivers: NVIDIA GeForce Experience[www.geforce.com] (auto-detect) OR NVIDIA[www.nvidia.com] (manual)

AMD Drivers: Follow instructions here[support.amd.com] (auto-detect and manual)

•••••••• Re-installing game (To avoid wasting time and frustration, only do this if launching issues have risen after you had played the game without problems recently)
38 Comments
ivanhoe Feb 25 @ 2:56pm 
I had troubles launching the game and tried all of the above, but what really solved the problem was quitting UbiSoftConnect before launching the game.
Milk Apr 2, 2023 @ 1:55pm 
"-dx11" was the fix for me Windows 10; March 2023
irodeyourmom Jan 31, 2023 @ 4:41pm 
this did not work for me
Jasper Dec 29, 2022 @ 9:47am 
I tried everything in this guide, even the -eac_launcher fix and it doesn't work. It just quits after the splash screen.
Der Jumper-Kai Dec 21, 2022 @ 11:10am 
did not work for me.. but if i go to the game files and start the EAC.exe it launches a small loading window, but from there nothing happens...
Stardog Sep 10, 2022 @ 1:13pm 
"-dx11" in launch parameters in Ubisoft Connect 100% worked.
RT Oct 26, 2021 @ 7:01pm 
I'm unable to find the bin_plus folder. Where would this be located?
Ethan Ending Oct 3, 2020 @ 10:29am 
not worked
Kerolyte  [author] Sep 23, 2020 @ 5:47am 
ikr? i'm glad it worked for you 🤍
FatBrioche Sep 22, 2020 @ 10:37am 
Deleting the dll file (I just moved it to the parent folder actually) worked. Never saw a fix as weird as this. Thanks!