STEAM GROUP
Steam In-Home Streaming homestream
STEAM GROUP
Steam In-Home Streaming homestream
4,227
IN-GAME
29,554
ONLINE
Founded
November 7, 2013
All Discussions > Bug Reports > Topic Details
Hellbender Nov 9, 2014 @ 5:15am
Weird bug with beta on OS X (client) loses icon and gives "Streaming error"
Here's a weird bug that I'd already noticed before when streaming to my 2012 Mac mini (client) from my Windows 7 PC (host). It seems to happen on and off again, now somewhat more consistently since the last beta update. I've only seen it happen once on my MacBook Air, but I don't often stream there.

Basically, after streaming a game and exiting the application, the Steam application loses its icon in both Applications and in the Dock and gets replaced by the OS X default application icon. If you start the beta application again from the Dock, it's not actually opening the application, but it attempts to reopen the last stream which you played. Then you get a black screen and a "Streaming error" message: Couldn't find a streaming game for your account on the local network. (screenshot[i.imgur.com])

Steps to reproduce
  1. Clean install of Steam application on OS X
  2. Start Steam from Applications or from the Dock, opt-in to Beta and optionally run Big Picture Mode (this seems to trigger the bug more frequently)
  3. Stream a game
  4. Correctly exit streaming game (check on host machine that it is closed)
  5. Exit Steam application >> the icon should now be replaced by the default OS X icon in the Dock and/or in Applications (screenshot[i.imgur.com])
  6. Start Steam again from the Dock >> you should get the "Streaming error" (screenshot[i.imgur.com])
If you reopen from Applications, it opens correctly (and the icon is restored once the client is started).

Removing the icon from the Dock and dragging it over again from Applications seems to fix the issue. Reinstalling Steam temporarily fixes the issue, but it never really goes away.

I'm stumped as to what causes it. Perhaps in some way, the Steam client application gets overwritten by the streaming service, but it doesn't explain why it's not happening more frequently on my MacBook Air.

UPDATE: Aaaand I can't reproduce it anymore. Yay? Maybe someone else has had the same thing happen?
Last edited by Hellbender; Nov 9, 2014 @ 5:22am
< >
Showing 1-15 of 40 comments
triwyn Nov 10, 2014 @ 6:28pm 
I have had the exact same problem. Sometimes I play a game on my macbook from my windows streamed from my windows 10 machine and it will exit with the "streaming error." Then it will change the steam icon to the "defualt "A" application osx yosimite icon.

However sometimes I will exit the game as normal and then when I go to click on the steam icont it switches to the "A" icon and the only fix i have found is to reinstall steam on the macbook.
mouseme Nov 12, 2014 @ 11:31pm 
I've had this exact same issue many times :(

I have been able to fix this until it happens another time by going to your "Applications" folder and locating Steam and then moving Steam to the desktop, then move Steam back to the "Applications" folder and launch Steam (this fixes the error and the missing icon and should fix everything until it happens another time).

Hope this helps :)

P.S Also the finder will ask some question about whether you want to keep the files (I don't remember the exact wording of the alert but just click leave files), then it should be fixed.
Hellbender Nov 23, 2014 @ 2:46am 
Originally posted by mouseme:
I have been able to fix this until it happens another time by going to your "Applications" folder and locating Steam and then moving Steam to the desktop, then move Steam back to the "Applications" folder and launch Steam (this fixes the error and the missing icon and should fix everything until it happens another time).

Had it happen again today and this fix worked beautifully! Thanks mouseme!

Still hoping for an official fix, as I'm clearly not the only one affected by this.
kode54 Nov 26, 2014 @ 7:18pm 
I am experiencing this issue with the current stable release, not opted into the beta. Better still, I didn't know offhand how to move a file from Applications to the Desktop, so I Option/Alt dragged, which produced a copy, rather than the default that Finder has chosen of creating a symlink.
Last edited by kode54; Nov 26, 2014 @ 7:19pm
mouseme Nov 26, 2014 @ 7:46pm 
Originally posted by kode54:
I am experiencing this issue with the current stable release, not opted into the beta. Better still, I didn't know offhand how to move a file from Applications to the Desktop, so I Option/Alt dragged, which produced a copy, rather than the default that Finder has chosen of creating a symlink.

So did you get Steam working again?
kode54 Nov 26, 2014 @ 8:29pm 
Yes, the copy to desktop, then drag move/overwrite to Applications fixed it. Until the next time that whatever resource fork or stream is signaling it to launch the streaming client gets left behind again.
sammargh Nov 29, 2014 @ 11:10am 
I was able to fix this by running the following from terminal:
/Applications/Steam.app/Contents/MacOS/steam.sh

This forces the client to update and fix itself.
Chris Nov 29, 2014 @ 2:31pm 
I did have the same issue a couple days ago, only way I found to fix was to uninstall/reinstall Steam on my MBP (the client machine). Had the issue again this morning and reinstalled again and now when I open Steam on the client MBP I have a different issue.

Now the library shows no games available to stream. Host PC is on and I've tried various restarts, changes of settings for streaming on both client and host, reinstall on both, all with no success. The problem now is the same as here:

http://steamcommunity.com/groups/homestream/discussions/0/617320628169781313/

I've posted on that thread but thought I might as well ask here in case it's in any way related this issue as I had that straight before. Probably still would tbh if I could actually manage to run a game first!

Any advice would be appreciated! Cheers
kode54 Dec 4, 2014 @ 8:58pm 
Please read the post directly above yours, running that shell script from Terminal.app should allow you to restart Steam manually without removing it.

If that doesn't fix it, you can at least Option-drag it to another folder, then drag it back and confirm overwrite.

As for your games being missing, you should be able to manually install them one by one and they will hopefully be detected from your existing install folder, unless you completely trashed everything.
oleost Dec 7, 2014 @ 9:54pm 
Got same issue, happens 100% of the time for me. Only fix is the ones mentioned here, but they are only temporarily
kode54 Dec 7, 2014 @ 11:53pm 
The copy/move and overwrite trick works for repeated restarts, at least until you ever decide to stream something again. The steam.sh method may be more convenient, since it doesn't involve file overwrite action, especially if you are like me and keep a Terminal.app session open all the time.
DoMessWithProfile Dec 10, 2014 @ 9:18pm 
I found a easy, faster way.

1. Click steam.dmg and drag it again to applications.
2. Find steam in the applications.
3. Click the steam icon.
4. Wait for download and done!

I hope this works.
Last edited by DoMessWithProfile; Dec 10, 2014 @ 9:19pm
kode54 Dec 11, 2014 @ 6:02pm 
Dragging it out of applications and back again, or simply running steam.sh, saves bandwidth. Your method also implies that I've saved the original installer.
brimstone Dec 15, 2014 @ 5:37am 
Hi, the same fix worked for me but I just moved it to trash and then in trash when you right click there is the option to put back so it is fast that way and GUI options all the way so no hassle.

This fixed it for me.

Thanks for the above hints for fixing this issue, they are the only ones that I could find on the Internet ....

Annoying the issue is still persisting though.
kode54 Dec 15, 2014 @ 10:10pm 
Just don't try the beta client right now to see if it fixes this, as it's currently not starting up at all, with some failed to load steamui.dylib notice. If you do enroll in the beta, you'll have to delete all your files except for SteamApps, and possibly reboot before Steam will work again.
< >
Showing 1-15 of 40 comments
Per page: 15 30 50

All Discussions > Bug Reports > Topic Details
Date Posted: Nov 9, 2014 @ 5:15am
Posts: 40