Nicky Mar 4, 2013 @ 10:21pm
Steam keeps downloading update, won't start.
Hi, this issue's been bugging me for some time and I've not been able to find an answer.

A few days ago I found that my game downloads kept getting suspended, so I did a full uninstall of the Steam client. I uninstalled all my games as well.

After I reinstalled Steam, it keeps showing 'searching for available updates' and then proceeds to download an update that's 13,956kb. It then closes once it gets to 'extracting update'.

This thing has been going on for close to a week. I found on a thread somewhere that it could be due to a hardware/driver problem?

Does anyone else have this issue? Any help is greatly appreciated. Thanks.
< >
Showing 1-15 of 31 comments
I have a similar problem. Games weren't downloading, so I did a full uninstall/reinstall, and now whenever I try to start Steam, it "updates" with a 4 MB update, then closes. I haven't changed my hardware for over a year, and Steam was working fine a month ago. My bootstrap_log file says something about a corrupt package file, so maybe the update is bad?
I found this thread that helped me out: http://steamcommunity.com/discussions/forum/1/864960987071412450/

Turns out, the new wireless driver available through Microsoft Update is bad. I reverted back to an old version, and everything works fine now. Hope this helps.
same problem..............waiting.......extracting package.......... and waitng steam support
Nicky Mar 5, 2013 @ 4:21am 
Originally posted by pant weasel:
I found this thread that helped me out: http://steamcommunity.com/discussions/forum/1/864960987071412450/

Turns out, the new wireless driver available through Microsoft Update is bad. I reverted back to an old version, and everything works fine now. Hope this helps.

How did you manage to identify that it was your wireless driver? I'm also pretty sure that the problem is due to a Microsoft update, but I don't know which driver is causing the problem.
I identified that it was my wireless driver by deleting it in device manager, then reinstalling with the CD that came with my wireless adapter. In Windows Update, it's called "Ralink - WLAN - ASUS 802.11n Network Adapter", but someone in that thread above says it's titled differently depending on which wireless adapter you actually have.
TheBot Apr 4, 2013 @ 1:07pm 
OMG THANK YOU! I have been having issues with Steam and Chrome lately. I didn't know what to do to fix it, trying many different things! Rolling back the driver update on my Airlink Wireless-N USB adapter fixed it!!! Holy damn hell that was awesome! I hope other people can see this.
Steam Updating Repeating Not Opening Fix
astralglide May 19, 2013 @ 2:21am 
This seems to be an RA Link Issue for me. I uninstalled Steam, re-installed the old driver (RT2860 Verson: 3.0.11.0 Released 11/19/2009)
Darkzyrklord Aug 24, 2013 @ 6:43pm 
definitely a Ralink driver issue. Rolling back to the old driver in the device manager fixed the problem.
Fr0G*O.oF!? Sep 2, 2013 @ 9:05am 
///
karnifex Dec 16, 2013 @ 3:23pm 
I have a linksys AE3000 Wireless N adapter that I just started using and all of sudden Steam updates wont finish updating correctly. Also my game updates aren't working correctly. I have re-installed steam, flushed steam, nothing seems to work.
Top Shotta Jan 22, 2014 @ 6:51am 
I just got steam and am dying to play gmod but when I go to launch steam it says searching for update and searches for a few minutes then says fatal error steam needs to be online to update please confirm your online connection and try again. but my connection is perfectly fine. plz help
The_king Mar 20, 2014 @ 2:23am 
hey found something that works! Right click on steam and do run as administrator that worked for me! i hope it works for you to.
Alemão Mar 20, 2014 @ 2:39am 
:D
ziaxe Aug 15, 2014 @ 10:07am 
im have this exact problem myself idk what to do though.. im not good with computers so...
Plovman2K Mar 1, 2015 @ 4:17am 
I had the same problem. If you tried full reinstall and couldn't delete the package folder, that was why. Just move the package folder somewhere else and thats it. steam will make a new one and you can freely use steam.
< >
Showing 1-15 of 31 comments
Per page: 1530 50

Date Posted: Mar 4, 2013 @ 10:21pm
Posts: 31