Leather Jacket Aug 17, 2014 @ 2:06pm
steam crashes when i play multiplayer games
when i try to play a game online the game will crash during the loading screen and than both the game and steam will close. i then have to sign back into steam. this happens for multiple games like payday 2, borderlands 2, and CS:GO
< >
Showing 1-5 of 5 comments
Thanatos Returns Aug 18, 2014 @ 3:41am 
Same happening here. Also includes Sanctum 2 multiplayer, but I've had it happen with Borderlands 2. Thought it may have been related to a recent installation of Spybot Search and Destroy - However, it only happens to those games, and has not affected Team Fortress 2.

Going to try updating Video Drivers. I have a Nvidia GForce GTX 580 driver version 320.78. Well come back with any fix that works.
Last edited by Thanatos Returns; Aug 18, 2014 @ 3:45am
Leather Jacket Aug 21, 2014 @ 8:22am 
i tried re-installing graphics driver, i refreshed my steam files using a method steam support recommends, i tried turning off windows firewall, and i have tried replacing the clientregistry.blob file in the steam folder but the problem still persists. i got a steam support ticket but steamsupport has been no help. when i find a fix i will post it and hopefully it will help you
Thanatos Returns Aug 21, 2014 @ 5:14pm 
Well, the crashing has stopped for Sanctum 2 and I have seen no updates come out for it - so thinking it is what I did.

Bascially I updated everything, including network card (I have a Gigabyte Killer mobo, apparently it's network management software is a bit painful towards games). So yeah, latest software package for the Network card from Gigabyte, also updated Windows (specially look to see if you have any .Net updates).

Testing has shown no current crashes and I've tried some long multi-player sessions in Sanctum 2. Mind you, I still cannot connect to miscellaneous hosts, but friend invites work ok. I keep getting the "connection to host lost" when trying a server from the list.

Hope that help any...
ayacoi Aug 21, 2014 @ 5:14pm 
.)
Leather Jacket Sep 16, 2014 @ 8:40pm 
hey i found out my problem was also 'killer network manager" i had no idea what that was until now. i reinstalled it and everything is working again.
< >
Showing 1-5 of 5 comments
Per page: 15 30 50

Date Posted: Aug 17, 2014 @ 2:06pm
Posts: 5