TK266 Dec 15, 2016 @ 8:58pm
“Library folder not writable" problem
I am getting a “Library folder not writable” error on 7 games (Fallout 4, Age of Mythology, Democracy 3, AI war, GTA Liberty city and IV, and Civ 4)

the drive with all these games is the default drive. It is an external USB hard drive.

I have cleared the the download Cashe.

Any help would be appreciated.
< >
Showing 1-15 of 33 comments
shiel Dec 15, 2016 @ 9:30pm 
Steam doesn't like using external drives. You can run into several different issues using them. Your best solution would be to purchase a proper hard drive such as a WD Blue/Black.
TK266 Dec 16, 2016 @ 12:11pm 
any idea why the problem would pop up just recently? the external drive has worked for the previous 5 years
YMCA! Dec 16, 2016 @ 2:22pm 
Yea, I just got this problem two with my second hard drive. Suddenly the Library folder isn't writable, not sure why.
FrogToad Dec 17, 2016 @ 11:46am 
I had this problem for Downloading updates, try going to which ever folder it says is not writable and check the properties. Make sure the folder says that it isn't read only, if it is change it. It fixed my problem hopefully will help you too.
YMCA! Dec 17, 2016 @ 3:03pm 
Changed everything out of Read-only but still having the issue
grue2u Dec 21, 2016 @ 9:55am 
I gave full permissions to users and authenticated users for the whole drive and propagated the permissions down. I unchecked read only for the steam library root folder, and propagated the permissions to all files. I cleared download cache. I uninstalled and attempted a reinstall of the games that can't update. No luck with any of this. I suspect it's related to a MS update that was pushed, as it started quite suddenly, but we still need a solution. Very frustrated at the moment.
radioman970us Dec 24, 2016 @ 10:34am 
I've had this problem for a short while. I've also had problems with disk write errors for years and years. I have 3 internal HDs that are in good health. Really irritating.

Going to try unchecking the read only thing on the steam folders and see if that clears things up.
radioman970us Jan 10, 2017 @ 6:35am 
I reinstalled all the problem games, all were on my C: drive, and it cleared up the problem for a while. Since then I installed a ton of games on multiple drives and have had no problems up until today. A game installed a year ago on drive E:, Elite Dangerous, gives me the error. :(

Because of grue2u comment I think it may be a wait and see thing. But I plan to do a steam ticket with this as soon as I can get to it. See if that does anything. Debating about reinstalling Elite or not. I was hoping perhaps that moving games to other drives manually might fix things. Haven't looked up how to do that yet.
AmyLiw265 Jan 23, 2017 @ 11:52am 
I just had this same issue. I went to Steam>settings>downloads>steam library folders>right click on the drive having an issue>repair library folder. Idk if it was just a fluke that I got that to work? Usually I don't have this kind of luck! Haha. But maybe it'll help someone else?! :)
radioman970us Jan 23, 2017 @ 12:05pm 
thanks for posting this. Didn't work for me. Just had Dying Light pop up with the error. All 28 gigs of it. :( all that works for me is download again. I"m lucky to have a fast connection and 1 TB limit each month. still, we need a perm fix for this.
Strayokami Feb 1, 2017 @ 5:54am 
I'm having the same problem with Ark. I have tried everything I can think of including what you all posted and no luck. I don't know what to do.
Stait x3 Feb 2, 2017 @ 4:12am 
Maybe this will help, worked for me:Before anything you need to uninstall the game that is giving you the problem (in case that your game doesnt start or dont allow to install). Just create a new folder for your downloads in a different driver then run Steam as Administrator then go to settings - downloads click on Steam library folders and there click on Add library folder, select the folder that you created and its done! now when you want to install the game just select the new folder as destination
Last edited by Stait x3; Feb 2, 2017 @ 4:15am
Originally posted by Strayokami:
I'm having the same problem with Ark. I have tried everything I can think of including what you all posted and no luck. I don't know what to do.
i have it with ark too
hoodxgaming2009 Feb 17, 2017 @ 9:35pm 
having same issue with csgo
radioman970us Feb 18, 2017 @ 4:00am 
reinstalling problem games has worked for me for the most part. I had a problem with the EA game Stranded Deep. I believe it was when in the game menu trying to create a new map I get an error about it not being able to write to the folder. So I went to the game folder and unchecked "read only" for the only folder in there and that fixed the problem. I haven't had anything come up with the similar error when trying to update yet... when it comes up I'll try the same thing with other games.
< >
Showing 1-15 of 33 comments
Per page: 15 30 50

Date Posted: Dec 15, 2016 @ 8:58pm
Posts: 33