ibb & obb

ibb & obb

View Stats:
ibb & obb > General Discussions > Topic Details
Alex Gleason Nov 19, 2016 @ 8:51pm
Game immediately crashes on Linux when opened
I've tried disabling the Steam overlay, no effect. Here is terminal output when running directly:

XRandR support not available
Xinerama support not available
XVidMode available at version 2.2!
Compiled SDL version: 2.0.4
Linked SDL version: 2.0.4
Using video target 'x11'.
Num displays: 1
Preferred display: 0
[S_API FAIL] SteamAPI_Init() failed; no appID found.
Either launch the game from Steam, or put the file steam_appid.txt containing the correct appID in your game folder.
Failed to initialize Steam API. Is Steam running?
PApplication::Init: App failed during InitApplication with error: "Failed to initialize Steam API. Is Steam running?"
< >
Showing 1-10 of 10 comments
Alex Gleason Nov 19, 2016 @ 9:11pm 
This may be a compatibility issue with the latest version of Steam. VVVVVV has a similar problem and has posted a fix, but it's not applicable here. details: http://steamcommunity.com/app/70300/discussions/0/333656722972841299/

I'm guessing the library files are just outdated compared to what Steam is expecting. I've tried overriding them with the ones from VVVVVV to no avail.
Pyrice Dec 1, 2016 @ 6:00am 
I've also had problems with this; in the end it was probably caused by the fact that I am running a 64-bit system and ibbandobb.elf is not looking for the steam libraries on my computer (it only looks for system wide libs). Everything solved itself with and update of the library path in ibandobb.elf
#!/bin/sh export LD_LIBRARY_PATH=$(pwd):~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/:~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/ ./ibbobb-i386.elf 2>&1

It might have been solved by installing the necessary packages (pulseaudio etc.) with 32-bit support as well. But I went this way to use the libraries provided by Steam.

The file steam_appid.txt should contain the AppID which you see when you run Steam from the console and try to start Ibb&Obb from within Steam.
IsoaSam Apr 1, 2017 @ 7:44am 
I am on Kubuntu 16.10 and I can't launch the game either.

Here is what I get when I launch the game from the command line :

XRandR support not available Xinerama available at version 1.1! XVidMode available at version 2.2! Compiled SDL version: 2.0.4 Linked SDL version: 2.0.4 Using video target 'x11'. Num displays: 1 Preferred display: 0 [S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed. [S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so. Failed to initialize Steam API. Is Steam running? PApplication::Init: App failed during InitApplication with error: "Failed to initialize Steam API. Is Steam running?"

I followed Pyrice suggestion and edited ibbobb.elf, adapting the paths :

#!/bin/sh export LD_LIBRARY_PATH=$(pwd):~/.steam/ubuntu12_32/:~/.steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/:~/.steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ ./ibbobb-i386.elf 2>&1

It didn't change anything. Now if anybody has any suggestion, it would be of great help.
Richard80Oslo Apr 24, 2017 @ 10:55am 
Crash at startup:

ERROR: ld.so: object '/home/richard/.steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
LOADING IO.FEV
ERROR LOADING IO.FEV
Segmentation fault (core dumped)
Sonic debris Dec 23, 2017 @ 10:18am 
Hey, I see the same error on ubuntu 17.10:

steam.desktop[4764]: ERROR: ld.so: object '/home/me/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
steam.desktop[4764]: GameAction [AppID 95400, ActionID 28] : LaunchApp changed task to WaitingGameWindow with ""
steam.desktop[4764]: ERROR: ld.so: object '/home/me/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
steam.desktop[4764]: ERROR: ld.so: object '/home/me/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
steam.desktop[4764]: GameAction [AppID 95400, ActionID 28] : LaunchApp changed task to Completed with ""
steam.desktop[4764]: >>> Adding process 11295 for game ID 95400
steam.desktop[4764]: >>> Adding process 11296 for game ID 95400
steam.desktop[4764]: >>> Adding process 11298 for game ID 95400
steam.desktop[4764]: Game update: AppID 95400 "", ProcID 11298, IP 0.0.0.0:0
steam.desktop[4764]: Setting breakpad minidump AppID = 95400
steam.desktop[4764]: Steam_SetMinidumpSteamID: Caching Steam ID: [removed]
[API loaded no]
steam.desktop[4764]: ERROR: ld.so: object '/home/me/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ibbobb-i386.elf[11298]: segfault at 0 ip 00000000080700f9 sp 00000000ff8f7140 error 4 in ibbobb-i386.elf[8048000+691000]
LittleJawa Dec 27, 2017 @ 7:46am 
I had the same issue, but I could fix it. I'm on Ubuntu Gnome 16.04.

Reading this thread made me realize the file ibbobb.elf doesn't look good.
It says :
export LD_LIBRARY_PATH=$(pwd)

This means the game will try to locate its libraries ONLY in the local working folder. I'm pretty sure it's not supposed to be that way.
I've replaced it with :
export LD_LIBRARY_PATH=$(pwd):$LD_LIBRARY_PATH

It makes sure that it first searches the local folder, and if the library is not found, it defaults to the system libraries...
... and the game started :-)

For what it's worth, removing the "LD_LIBRARY_PATH" line worked for me too, meaning all the needed libraries are available in my system - but that may differ with other Linux distributions.

You may want to add the PATHs mentionned Pyrice above, but I think you still need to keep a reference to the system folders, at the end of the line.

Now the game works for me - hope it helps others :-)
IsoaSam Dec 29, 2017 @ 1:59am 
Thank you littlejawa, I tried your fix and it works for me. Very good news for me, because I had given up on that game.

So now my ibbobb.elf file looks like this :
#!/bin/sh export LD_LIBRARY_PATH=$(pwd):$LD_LIBRARY_PATH ./ibbobb-i386.elf 2>&1
massimodong Feb 20, 2018 @ 1:45am 
Originally posted by LittleJawa:
I had the same issue, but I could fix it. I'm on Ubuntu Gnome 16.04.

Reading this thread made me realize the file ibbobb.elf doesn't look good.
It says :
export LD_LIBRARY_PATH=$(pwd)

This means the game will try to locate its libraries ONLY in the local working folder. I'm pretty sure it's not supposed to be that way.
I've replaced it with :
export LD_LIBRARY_PATH=$(pwd):$LD_LIBRARY_PATH

It makes sure that it first searches the local folder, and if the library is not found, it defaults to the system libraries...
... and the game started :-)

For what it's worth, removing the "LD_LIBRARY_PATH" line worked for me too, meaning all the needed libraries are available in my system - but that may differ with other Linux distributions.

You may want to add the PATHs mentionned Pyrice above, but I think you still need to keep a reference to the system folders, at the end of the line.

Now the game works for me - hope it helps others :-)
Works like a charm. :)
Steve Apr 14, 2018 @ 10:05am 
Originally posted by LittleJawa:
I had the same issue, but I could fix it. I'm on Ubuntu Gnome 16.04.

Reading this thread made me realize the file ibbobb.elf doesn't look good.
It says :
export LD_LIBRARY_PATH=$(pwd)

This means the game will try to locate its libraries ONLY in the local working folder. I'm pretty sure it's not supposed to be that way.
I've replaced it with :
export LD_LIBRARY_PATH=$(pwd):$LD_LIBRARY_PATH

It makes sure that it first searches the local folder, and if the library is not found, it defaults to the system libraries...
... and the game started :-)

For what it's worth, removing the "LD_LIBRARY_PATH" line worked for me too, meaning all the needed libraries are available in my system - but that may differ with other Linux distributions.

You may want to add the PATHs mentionned Pyrice above, but I think you still need to keep a reference to the system folders, at the end of the line.

Now the game works for me - hope it helps others :-)

You're a prince.
Purin64 Oct 21, 2018 @ 10:31am 
Originally posted by LittleJawa:
I had the same issue, but I could fix it. I'm on Ubuntu Gnome 16.04.

Reading this thread made me realize the file ibbobb.elf doesn't look good.
It says :
export LD_LIBRARY_PATH=$(pwd)

This means the game will try to locate its libraries ONLY in the local working folder. I'm pretty sure it's not supposed to be that way.
I've replaced it with :
export LD_LIBRARY_PATH=$(pwd):$LD_LIBRARY_PATH

It makes sure that it first searches the local folder, and if the library is not found, it defaults to the system libraries...
... and the game started :-)

For what it's worth, removing the "LD_LIBRARY_PATH" line worked for me too, meaning all the needed libraries are available in my system - but that may differ with other Linux distributions.

You may want to add the PATHs mentionned Pyrice above, but I think you still need to keep a reference to the system folders, at the end of the line.

Now the game works for me - hope it helps others :-)

Fixed
< >
Showing 1-10 of 10 comments
Per page: 15 30 50

ibb & obb > General Discussions > Topic Details