BioShock

BioShock

View Stats:
BioShock > General Discussions > Topic Details
cj2288 Aug 25, 2015 @ 8:20am
Win 10 and no sound
Hello,
So, I also have problem with missing sound after first cutscene, I whas digging some time now and every solution was no good fof me. For start I'm running on Win 10 prof. (x64) my sound card is Relatek on MSI X99S motherboard, 5 sockets at back where is my 5.1 Creative's pluged in and 2 in front (mic, headphones). Solutions that I tested:
1. Enable stereo mix recording device
2. Running with different compatibiliti (7, XP SP2, XP SP3, 8.1)
3. Running in window mode
4. Plug in mic (in the both sockets)
5. There whas few modifications in "default" file
6. Drivers whas downloaded yesterday so I believe that they are newest
7. Checking almost every configuration in sound driver and game (stereo, mono, 5.1 etc)
8. Running steam with different compatibiliti (7, XP SP2, XP SP3, 8.1)

So I'm reaching moment that google is running out of ideas :) any help?
< >
Showing 1-15 of 58 comments
Harzzach Aug 25, 2015 @ 1:20pm 
Tried to deactivate or even unplug/remove your Creative soundcard?

I have also W10 prof., a MSI Z87-G45, no external soundcard, just onboard sound chip. Sound in the game only when starting with Compatibility Mode XP/2 or XP/3. But its not perfect. I have several sound errors in other games (cracks & hisses, only a few channels active), Bioshock is one of them.

I guess better sound driver will do the trick someday.
Last edited by Harzzach; Aug 25, 2015 @ 1:21pm
d00m6r Aug 25, 2015 @ 6:56pm 
did you install OpenAL? and enable EAX in game?
Houston ^_^ Aug 26, 2015 @ 1:12am 
Activate "Stereo mixer" at playback device.Then go to the Bioshock directory(bioshock\Builds\Release) and use compatibility to Bioshick.EXE "Windows XP SP3" thats all.
cj2288 Aug 27, 2015 @ 10:54am 
Originally posted by Houston ^_^:
Activate "Stereo mixer" at playback device.Then go to the Bioshock directory(bioshock\Builds\Release) and use compatibility to Bioshick.EXE "Windows XP SP3" thats all.
Done that
cj2288 Aug 27, 2015 @ 1:52pm 
Originally posted by LeThArGiCa:
did you install OpenAL? and enable EAX in game?
install OpenAL: yes
enable EAX in game: it is imposible for me to enable EAX
AwareJesus Aug 31, 2015 @ 10:53pm 
realtek has issues with windows 10. its not your pc. its windows 10 itself. alot of people are having this issue
rafaelherschel Sep 2, 2015 @ 1:10pm 
For me the solution was setting the executable (shortcut on the desktop to the executable) to compatible with Windows XP SP3 and running the program as Administrator. This made my game crash while changing the resolution, so I reverted, got the settings right and then went back to compatible with Windows XP SP3.
suzinsyn Sep 20, 2015 @ 12:02pm 
Originally posted by Houston ^_^:
Activate "Stereo mixer" at playback device.Then go to the Bioshock directory(bioshock\Builds\Release) and use compatibility to Bioshick.EXE "Windows XP SP3" thats all.
Activating stereo mixer worked perfectly in Windows 10 x64, and no windows xp or 2000 compatibility was needed! I also noticed some sound quality improvement, particularly in the main menu. Thanks for the advice!
Last edited by suzinsyn; Sep 20, 2015 @ 12:13pm
Ya Pizzas Burnin Sep 27, 2015 @ 11:17am 
Hey, I'm not the brightest of guys and I'm trying to resolve this issue as well, can someone explain how I activate stereo mix. It says it's ready and when I go into the options, I end up getting lost. Also, do the later Bioshock games have these problems? I was hoping to start a lets play channel with the Bioshock series being my start up and I don't think I'll enjoy having this hassle five times over.
suzinsyn Oct 2, 2015 @ 12:23pm 
Originally posted by Delta Metroid:
Hey, I'm not the brightest of guys and I'm trying to resolve this issue as well, can someone explain how I activate stereo mix. It says it's ready and when I go into the options, I end up getting lost. Also, do the later Bioshock games have these problems? I was hoping to start a lets play channel with the Bioshock series being my start up and I don't think I'll enjoy having this hassle five times over.
Go to "Control Panel" and find "Sound" (if there is no Sound icon, click on "All control panel items" and you'll see Sound there). In the sound settings there should be four "pockets": Playback, recording, sounds and communications. Open recordings and right-click on stereo mix, then click enable. That's pretty much it. Start the game and it should be good. Later Bioshock games have no sound issues and require no such manipulations.
Last edited by suzinsyn; Oct 2, 2015 @ 12:30pm
MainMan B Oct 20, 2015 @ 1:05pm 
I have no sound neither in BioShock, and I have no entries at all in the Recordings section, Realtek HD, exept for an message saying: "There is no sound units installed" (I think it's called in english. I have an danish version of Windows 10)
IndrldCold Nov 3, 2015 @ 9:44am 
Sterio mix doesnt show up when I right click. I tried to download drivers but how do I unpack them?
JPSilveira Nov 6, 2015 @ 6:12pm 
The same issue here. After the ariplane cutscene, it lost the sound.
TheBasher Nov 6, 2015 @ 10:17pm 
I am running Windows 10 pro. I upadated/reinstalled all my drivers after the update using the software that came with my Mother board and GPU.
All I had to do to get the sound to work was.
1. right click the speaker symbol on the bottom right.
2.click recording Devices
3 right click in the box and pick show disabled devices
4 right click stero mix and click enable

I did not have to run in compatability mode or run as admin. The game plays perfect. Guess I got lucky.
Chris Jan 4, 2016 @ 2:24pm 
Thanks for the 4 step dummies guide ;) - It did the trick. Step 3 was the one that wasn't obvious.
< >
Showing 1-15 of 58 comments
Per page: 15 30 50

BioShock > General Discussions > Topic Details