Prehistoric Kingdom

Prehistoric Kingdom

Tutorial trouble - Torvo's water and foliage needs won't update
Anyone else having this problem with the tutorial? No matter how much or how little water there is in the Torvo enclosure, his needs don't change. The water need is "slightly too much" (even with no water at all) and the foliage need is already listed as fine. What do?
< >
Showing 1-5 of 5 comments
Seems like a bug. Did you retry the tutorial to see if that makes any difference? If you get the same issue, report the bug to the developers by using the "report bug" button on the main menu of the game.
Becca May 1 @ 3:15am 
I started the tutorial again and it worked this time. Only difference was I created the first Torvo skin, rather than the second. Not sure if that was what did it or not.
Becca May 1 @ 3:35am 
So now I have a new issue - the mammoth won't unlock. It shows all three skins as already unlocked and holding the left mouse button down on them doesn't do anything. Baffling.
Originally posted by Becca:
I started the tutorial again and it worked this time. Only difference was I created the first Torvo skin, rather than the second. Not sure if that was what did it or not.

I had the same issue and also "fixed" it by restarting the tutorial. Doesn't seem to be related to the dino skin, though, as I picked exactly the same in my second attempt.
Rosie May 1 @ 7:50am 
Hello! The team is currently working on some tutorial bug fixes that should be out in the next patch!

- Rosie (PK Community Manager)
< >
Showing 1-5 of 5 comments
Per page: 1530 50