X Rebirth VR Edition

X Rebirth VR Edition

View Stats:
Quest 2 via Link
Anyone have positive experience playing XR on Quest 2 via Link? Will it play on this setup?
< >
Showing 1-15 of 20 comments
Does not work.

Vive version looks fine but you cannot control the craft.
Rift S version flickers in one eye and cockpit position is off and causes nausea.

I refunded. :(
travelperson Nov 9, 2020 @ 9:14pm 
I too just bought this game and experienced flickering on quest 1 with link. Is there no way to adjust the flickering? Modify config files? Am new to this and really want to play and like this game.
sclose Dec 12, 2020 @ 9:18am 
Yeah I have the same. Quest 2 via link. Really gutted about it as it looks like a great game and I was looking forward to seeing it in Quest 2 resolution. I imagine with the right knowledge it's quite a simple fix but definitely beyond me!
yes Dec 14, 2020 @ 10:02pm 
only issue i had was that the game keeps thinking im using the vive
ImpSeal Dec 20, 2020 @ 4:40pm 
its not working for me as well. Is their a fix?
Chrono_Hood Jan 20, 2021 @ 12:41am 
game crashes too much for me to even play with rift s anymore.. Waste of money
Lord Kefka Feb 12, 2021 @ 7:03pm 
Looks like you have to get on on the oculus store for the quest 2 to work, ill test it soon
dave Mar 20, 2021 @ 11:11am 
I'll contribute my findings. TLDR: it doesn't work properly from either Steam or the Oculus Store. If you can pretend your controller is a Vive controller then you may get by, but I haven't tested that.

System: Oculus Quest 2, AMD Ryzen 7 3700X, GTX 1060

*Oculus Store + Link Cable*

This was my first port of call, since I'd read that the controller wasn't supported in Steam.

However, there are serious graphical artefacts. If feels like incredibly low headache-inducing refresh rate or something , plus serious "ghosting" as you move your head around, where objects appear in two places at once for a split second.

I dove into Oculus Tray Tool and put everything on lowest settings. That did seem to help (but not solve) the "ghosting". However the low refresh rate problem, or whatever it is, was still really headache-inducing.

I tried toggling various ASW modes in Oculus Tray Tool, but nothing changed.

I tried different refresh rates in the main Oculus app's settings, nothing changed.

On the plus side, the controller seems to be mapped correctly.

*Oculus Store + Virtual Desktop ("Games" menu)*

Sometimes Virtual Desktop can, unintuitively, give better performance than the link cable, so I thought that worth a go.

But the game wouldn't start at all. It immediately crashes with some fatal error that disappears too quickly to glean any info.

*Oculus Store + Virtual Desktop (desktop)*

Just launches in desktop mode, i.e. 2D. Not really surprising.

[... refunded]

*Steam (default) + Link Cable*

Initially this excited me, because the game fires up and the graphics are perfect!

However, the controller is assumed to be the Vive controller. You can navigate the menu by pointing and pressing the thumbstick.

I didn't actually realise it was assumed to be the Vive until I got in game and tutorial hints were referring to a "touchpad", which seems to be mapped to the thumbstick. At that point I quit.

It's possible that all Vive buttons have corresponding Oculus equivalents, in which case perhaps the game is playable like this, but I haven't tried.

*Steam + Virtual Desktop or ALVR*

Exactly the same as link cable

*Steam (swapped exe) + Link Cable*

According to the FAQ Steam should support an Oculus version by right-clicking on something. I tried right-clicking all over the place but never saw an option for Oculus. Other people have reported this and found a workaround is to replace the exe file, which I did.

Unfortunately the result is just the same as the Oculus Store.

[...refunded, again]
Last edited by dave; Mar 20, 2021 @ 11:24am
Blodius Mar 21, 2021 @ 9:14am 
Works fine on Rift S with Rtx only problem is that the newer touch controller is not fully supported... i fixed that with a xbox controller.
DrGNOLA May 4, 2021 @ 8:15pm 
Originally posted by Blodius:
Works fine on Rift S with Rtx only problem is that the newer touch controller is not fully supported... i fixed that with a xbox controller.

What Blodius said. I, too, really wanted to play this in VR so just picked it up. Works well if you use X Box controllers with a Q2 via Link cable. Haven't tried VD or Air Link but I suspect if I wrangled enough I might get the touch controllers to work also--they do partially when I have my game controller switched off; but the movement thumbsticks do not seem to register. I've taken the easy route and am using an X-Box game controller and having no trouble. Game runs smoothly and seems very cool. Give it a try if you have an Xbox controller handy is my advice. Otherwise you may have to return it. Doesn't intuitively pick up the Q2 touch controllers in my case. All other inputs work (mouse and keyboard, game controllers) and I don't have a HOTAS to comment on.
Last edited by DrGNOLA; May 5, 2021 @ 7:21am
DuxterNewman Aug 24, 2021 @ 1:55pm 
I just Brought the game and the same for me on Quest 2 / Link.... flicker flicker flicker any solution? Thanks
Reaves Sep 20, 2021 @ 3:08pm 
I run on Quest 1 with Xbox controller (it's better anyway) via Air link but run the Steam VR version and not Oculus. You need to load via Steam VR Home.

- Active airlink in Quest.
- Load into Steam VR
- Load XRVR
- Enjoy

I've spent hours playing and even have a floating window pinned via Oculus home so I can watch Star Trek while building my empire.
Topher Dec 31, 2021 @ 10:21pm 
i was trying to play with an xbox controller but i got an x56 hotas for xmas and decided to try setting that up. it actually works wonders. i have been able to setup every command ive needed so far....im not as mad about purchasing now but it in no way has out of the box support for vr controllers. also there are a few mods that work from the standard version that work for the vr version including the infinite boost mod
BossGalaga Mar 14, 2022 @ 1:48pm 
It looks great, I own other X series titles, both digital and physical, but it's already tedious as it is, and for Quest 2 users, it seems even more so.

Does anyone know if there are any updates planned...ever? It was released in 2017, there were a few updates in 2017, and since then...nothing. That's disappointing, especially considering that there are many things that they should update.
< >
Showing 1-15 of 20 comments
Per page: 1530 50