The Elder Scrolls V: Skyrim Special Edition

The Elder Scrolls V: Skyrim Special Edition

View Stats:
xprinceps Jan 11, 2019 @ 3:50pm
No NPC voices on Linux/Steamplay
I recently installed SSE on my Linux box (18.04.1 64-bit), and it seems to work with Steamplay with the exception that the NPCs have no voices, though I can see their lips moving. All other sounds seem fine. I have seen a few other related threads but haven't found an answer that works for me.
I have never installed any mods, and the installation was totally default. I have tried uninstalling & reinstalling, verified local files, and cleared cache. Skyrim_default.ini includes in the Archive section
sResourceArchiveList=Skyrim - Misc.bsa, Skyrim - Shaders.bsa, Skyrim - Interface.bsa, Skyrim - Animations.bsa, Skyrim - Meshes0.bsa, Skyrim - Meshes1.bsa, Skyrim - Sounds.bsa sResourceArchiveList2=Skyrim - Voices_en0.bsa, Skyrim - Voices.bsa, Skyrim - Textures0.bsa, Skyrim - Textures1.bsa, Skyrim - Textures2.bsa, Skyrim - Textures3.bsa, Skyrim - Textures4.bsa, Skyrim - Textures5.bsa, Skyrim - Textures6.bsa, Skyrim - Textures7.bsa, Skyrim - Textures8.bsa, Skyrim - Patch.bsa
Both Skyrim - Voices.bsa and Skyrim - Voices_en0.bsa are found in .steam/steam/steamapps/common/Skyrim Special Edition/Data.
If it matters, here are some system specs:
Processor: AMD® A6-3620 apu with radeon(tm) hd graphics × 4
Graphics: GeForce GT 1030/PCIe/SSE2
Drive: 500 Gb SSD
Any help you can give me would be greatly appreciated! I tried to think of all the info that might be useful, but if there's anything else, I'll happily provide it.
By the way, I also have vanilla Skyrim installed, and it works flawlessly.
Last edited by xprinceps; Jan 11, 2019 @ 3:54pm
< >
Showing 16-24 of 24 comments
mr.tajny Jul 12, 2020 @ 11:18am 
Is the file wine_setup_faudio.sh really present in the extracted folder?
Originally posted by Maquina Agricolas:
From https://www.protondb.com/app/489830

The game (with 50+ bethesda.net mods) is working great for me, using the following steps: 1. Install xact audio libraries to game pfx folder by running: "WINEPREFIX=$HOME/.steam/steam/steamapps/compatdata/489830/pfx winetricks --force xact" 2. Configure wine by running "WINEPREFIX=$HOME/.steam/steam/steamapps/compatdata/489830/pfx winecfg". In config window, click libraries tab. Then add xaudio2_6, and xaudio2_7 and set them both to native 3. Download the latest FAudio build from https://github.com/Kron4ek/FAudio-Builds/releases, and untar. 4. Cd to the folder with extracted files (it should have the wine_setup_native script in it), and run "WINEPREFIX=~/.steam/steam/steamapps/compatdata/489830/pfx bash wine_setup_native"

It worked for me after following the instructions

I would also like to add that the above step was the final step to get this working, as of 24th Jan 2021, on Ubuntu 20.04 LTS.

Before that I had executed these summary steps: https://www.reddit.com/r/linux_gaming/comments/99i4se/skyrim_on_linux_steam_play_no_voiceno_music_audio/
I also would like to confirm and thank Maquina Agricolas for these instructions. They fixed my problem on Ubuntu 20.04.
taonn Feb 6 @ 1:19pm 
WINEPREFIX=/path/to/489830/pfx winetricks --force xact
was enough for me (ubuntu 20.04)
I can confirm that
WINEPREFIX=/path/to/489830/pfx winetricks --force xact
is working on Arch Linux 5.10.16 too.

Thanks... that's awesome!
Last edited by [Bamboocha] Bloody Burger; Mar 1 @ 9:10am
I can confirm this works as of 13/03/2021, Manjaro Kernel 5.10, KDE 5.21.2 (detailed config below)

Thanks so much for the guy who found this solution. I can confirm it works (solution on https://www.reddit.com/r/linux_gaming/comments/99i4se/skyrim_on_linux_steam_play_no_voiceno_music_audio/)
Because of the update, I'm going to detail steps 5 to 8:
5 - same as indicated (find the directory steamapps/compatdata/489830 and ensure it has a pfx directory. cd into it.);
6 - same as indicated (execute WINEPREFIX=$PWD/pfx winetricks --force xact).
Wine may ask you to download .NET stuff, press yes. Don't worry about warning messages about 32 bit; some people indicate this alone works, so try launching the game etc after that. If it doesn't work, move to the steps below
7 - not necessary for me;
8 - as indicated by others, download the latest version of FAudio from https://github.com/Kron4ek/FAudio-Builds/releases.
The FAudio packages are already installed on my distro, but I still downloaded it from there as it seems to be more a config file than anything else;
9 - extract the tar.xz into a folder. Then, if you open that folder, you will see one subfolder named x64, as well as the wine_setup_faudio.sh file.
10 - In that folder, again right click and "open terminal here" or cd into it.
11 - then type "WINEPREFIX=~/.steam/steam/steamapps/compatdata/489830/pfx bash wine_setup_faudio.sh " and press enter.
12 - [updated after moving my folder to where I actually wanted it using Steam "move folder" functionality]
If you install your games in another location than the default, then the command in step 11 should include that path rather than the default. The best is to give an example. My games are installed at /mnt/Data/Games (partition "Data" mounted under /mnt), so the command I entered (and which works) is:
WINEPREFIX=/mnt/Data/Games/steamapps/compatdata/489830/pfx bash wine_setup_faudio.sh

And it worked for me! I'm really grateful as Skyrim has an amazing soundtrack and playing without it would be like watching the lord of the rings without soundtrack!

My config:
Manjaro Linux (Arch based) - KDE 5.21.2, Kernel 5.10
AMD Ryzen 3600
Radeon RX 570 (XFX)
All settings in steam and install are the default (apart from library folder)
Last edited by 76561199063278924; Mar 14 @ 1:13am
all you really need to do is add this line to your steam play option for Skyrim:
WINEDLLOVERRIDES="xaudio2_7=n,b" %command%
Originally posted by nivritti.kuzma:
all you really need to do is add this line to your steam play option for Skyrim:
WINEDLLOVERRIDES="xaudio2_7=n,b" %command%
This worked for me. Thx!
Edit: I resolved this by completely uninstalling (purge) wine winetricks steam steam-devices, and deleted the ~/.steam directory. I then rebooted and reinstalled all of the above packages, and after mapping my SteamLibrary folder once again in Steam so it detected my games, they launched appropriately.



Originally posted by Maquina Agricolas:
1. Install xact audio libraries to game pfx folder by running: "WINEPREFIX=$HOME/.steam/steam/steamapps/compatdata/489830/pfx winetricks --force xact" 2. Configure wine by running "WINEPREFIX=$HOME/.steam/steam/steamapps/compatdata/489830/pfx winecfg". In config window, click libraries tab. Then add xaudio2_6, and xaudio2_7 and set them both to native 3. Download the latest FAudio build from https://github.com/Kron4ek/FAudio-Builds/releases, and untar. 4. Cd to the folder with extracted files (it should have the wine_setup_native script in it), and run "WINEPREFIX=~/.steam/steam/steamapps/compatdata/489830/pfx bash wine_setup_native"

Following these steps actually broke ALL of my Steam games running under Proton. Now SkyrimSE, nor any of my other Proton games, will launch at all. Running Steam from CLI does not give me any feedback, clicking "Play" simple cycles the button then does nothing.

I ran the following commands:
480 "WINEPREFIX=$HOME/.steam/steam/steamapps/compatdata/489830/pfx winetricks --force xact" 481 WINEPREFIX=$HOME/.steam/steam/steamapps/compatdata/489830/pfx winetricks --force xact 482 WINEPREFIX=$HOME/.steam/steam/steamapps/compatdata/489830/pfx winecfg 483 cd ~/Downloads/faudio-20.07 485 WINEPREFIX=~/.steam/steam/steamapps/compatdata/489830/pfx bash wine_setup_faudio.sh 486 WINEPREFIX=/mnt/c33e59a3-e4af-4470-b644-cfdd0498f331/SteamLibrary/steamapps/compatdata/489830/pfx bash wine_setup_faudio.sh 487 WINEPREFIX=/mnt/c33e59a3-e4af-4470-b644-cfdd0498f331/SteamLibrary/steamapps/compatdata/489830/pfx winetricks --force xact

If anyone knows how to remedy this, or simply how to "undo" those Wineprefix commands I did, I would appreciate it very much...
Last edited by Strange World; Oct 14 @ 11:56am
< >
Showing 16-24 of 24 comments
Per page: 15 30 50

Date Posted: Jan 11, 2019 @ 3:50pm
Posts: 24