Titan Quest Anniversary Edition

Titan Quest Anniversary Edition

View Stats:
KillerBOY Sep 1, 2016 @ 11:43am
cant start game - failed to initialize graphics engine
cant start game - failed to initialize graphics engine
in german: Grafik Engine konnte nicht initialisiert werden

Graphiccard: Geforce GT 540M
newest driver
OS: WIndows 10 x64
< >
Showing 1-14 of 14 comments
Malgardian Sep 1, 2016 @ 11:47am 
check the vcredist packages and maybe reinstall vc++ redist 2005 or 2008
Master_Sandro Sep 1, 2016 @ 12:27pm 
Go to the game folder and start the TQ.exe in windows xp mode.
Igorious Sep 1, 2016 @ 2:27pm 
I have same issue.
Win 10 x64, GeForce GTX 850M, latest NVidia drivers (2016-08-30).

XP compatibility mode / «Run as Admin» doesn't help.

I've «repaired» C++ 2005/2008 from _CommonRedist folder and updated DirectX 9c, but it has no effect.

I've tried force usage of NVidia processor in NVidia Control Panel, but it also doesn't help.
Last edited by Igorious; Sep 1, 2016 @ 3:51pm
Angry_Owl Sep 1, 2016 @ 2:38pm 
Same problem, also Win10. Verified files, repaired MS redist files, tried compatibility modes.
if i started Titan Quest the first time it use my integrated intel 520 gpu, i need to force the game in the nividia control center to use my 940mx dedicated laptop gpu.
KillerBOY Sep 2, 2016 @ 1:25am 
-vcredist packages (2005,2008,2010,2013,2015) >> dont work
-windows xp mode ( compatibility mode ) >> dont work
-force nvidia graphic card >> dont work
-reinstall >> dont work
Angry_Owl Sep 2, 2016 @ 6:22am 
I had the same issue. I eventually got the game running by using my onboard graphics card. An easy way is to right click the TQ executable and select 'run with graphic processor' -> 'intergrated graphics'.

The game doesn't run as smooth as the original but it got the game working at least. Hope this helps others.
Tony Moneo Sep 2, 2016 @ 6:29am 
Been happening to me, but all I did was add '-dx9' without the quotes to the launch options (Properties -> Set launch options)

Game launches fine now.
Igorious Sep 2, 2016 @ 9:51am 
Originally posted by InterDimensionalOwl:
I eventually got the game running by using my onboard graphics card. An easy way is to right click the TQ executable and select 'run with graphic processor' -> 'intergrated graphics'.
Originally posted by Tunns Moneo:
Been happening to me, but all I did was add '-dx9' without the quotes to the launch options (Properties -> Set launch options)

Unfortunally, I have error for both graphic processors (NVidia and integrated).
Adding '-dx9' doesn't help :(
Last edited by Igorious; Sep 2, 2016 @ 9:52am
D00MH4MM3R Sep 7, 2016 @ 8:56am 
I tried all of the above ((re)installing vcredist and dx from the folders, different compatibility modes, admin mode) and it still didn't start correctly, then I tried letting windows do the work. In the right click Menu of TQ.exe there should an option "Solve compatibility problems" (roughly translated from german), at least in Win10. This told me there weren't any problems, but now it successfully starts directly from the explorer.
Still crashes when I try starting from steam though, with or without -dx9. Weird but I'll take it, maybe it'll work for someone else too ;).
Xatmamune Sep 7, 2016 @ 9:40am 
I am getting the same error message where it can't innitiate graphics engine. However, before it gives me this error, the game will attempt to go from windows mode into full screen mode back to windows mode literally 100 times over the course of 2 and a half minutes, automatically attempting every 1 and a half seconds until after 100 tries it finally gives me the error message. I've just about tried everything mentioned and even reinstalled the steam client, multiple 'compatibilities' attempts, nothing works. The game never begins. I use win 7 64bit pro.
Xatmamune Sep 7, 2016 @ 2:04pm 

My problem was fixed by following this idea that a user here named Numb-Tung just told me to try:

Go to: documents/my games/ titan quest anniversary/settings folder..

Either delete "options.txt" file (save a copy before hand just in case) and try restarting the game.

Or instead of deleting it, you could also try editting the options file and REPLACE all of your current options settings with these below:

networkSpeed = medium
networkMTU = 1400
displayDamage = false
quickBuy = true
itemComparison = true
extraRollovers = true
showMonsterLevelOnRollover = false
dayNightCycle = true
textureQuality = high
shadowQuality = high
shadows = true
reflectionQuality = high
detailLevel = high
resolution = 1920 1080
antiAliasing = true
fullscreen = true
syncToRefresh = true
tripleBuffer = false
masterVolume = 0.99
musicVolume = 0.462185
effectsVolume = 0.99
dialogVolume = 0.99
ambientFrequency = medium
rockOn = false
device = Direct3D
language = English
forceSingleProcessorMode = false
skipCompatibilityChecks = false
useArchives = true

What I did was the second choice and I just copy-pasted these options completely over my default options from the game, and my game is working 100%! When the game loads for the first time, the options will then correct themselves to what they should be, adding in any that are missing.

I hope this helps someone else as much as it did me! Good luck all!
Igorious Oct 16, 2016 @ 7:12am 
Today I have tried to run another game and found one tip: delete all «d3dx9_NN.dll» (NN=24..43) files from «C:\Windows\System32» and «C:\Windows\SysWOW64» folders and install DirectX 9c again (https://www.microsoft.com/en-us/download/details.aspx?id=35).
And now game works! :steamhappy:
Maybe it helps to you.
samzdrone Jan 29, 2018 @ 11:53am 

After trying several solutions proposed by the community that of Inorious worked for me .
I know the subject is old but in case someone will look for a solution ...
Last edited by samzdrone; Jan 29, 2018 @ 11:53am
< >
Showing 1-14 of 14 comments
Per page: 1530 50

Date Posted: Sep 1, 2016 @ 11:43am
Posts: 14