SteamVR Developer Hardware

SteamVR Developer Hardware

jboss Feb 29, 2016 @ 1:18pm
Compositor is not available (400)
After unboxing and connecting all the hardware I started Steam VR, got green icons for all the 5 hardware items, but Steam VR still shows Not Ready, with the error message Compositor is not avaiable. There is a link to launch the compositor, but that does not seem to do anything.

I found a thread saying that I can start the compositor manually, but that also did not seem to do anything, also not when I tried running it as administrator (can I check somewhere if it is running?)

So I'm stuck, hope someone can help me out.
< >
Showing 31-45 of 81 comments
Kookyoo Mar 21, 2016 @ 2:59am 
Hi,

We just received the new link box for the old headset. My 2 screens & the Vive are plugged in the same graphic card (GTX 970, drivers up to date) and I'm using Win10. I got the exact same error Toddpi314 had, wich doesn't allow me to use the Direct Mode because something seems wrong between SteamVR and the nVidia API.
Tried every solution you guys shared here, with no success for now :(
MysticCrusher Mar 21, 2016 @ 10:27pm 
Cool! The procedure described by Acegikmo worked for me! Thank you!

Unfortunately I have Vive and Oculus on the same computer and face this problem all the time :(
I wonder if there's a solution without unplugging everything.

Originally posted by Acegikmo:
I recently ran into this issue, resetting the SteamVR USB devices did the trick for me.

  1. Exit Steam
    ...

Bean Seller Apr 6, 2016 @ 4:41am 
- I've got this problem. Acegikmo's solution didn't help.
- Win10 / GTX970 (gigabyte) using it's (only) HDMI port.
- Got things plugged into 4 other ports, tried setting each of them as primary, didn't help.
- Noticed that I've got Steam installed on both my C drive and another drive (where the games are) -- tried running SteamVR via the other one (which needed an update) - didn't help.
- Tried changing to SteamVR [beta] - didn't seem to update or change
- There's a windows update available to version `Upgrade to Windows 10 Pro, version 1511, 10586`. Won't try that just yet..
Last edited by Bean Seller; Apr 6, 2016 @ 4:46am
Bean Seller Apr 6, 2016 @ 7:23am 
Got it working!!
What I had to do was remove all my monitors but one.
Now I've got the Vive in a Display Port -> Mini Display Port cable, and a TV in an HDMI port.
(Haven't tried w// the vive in HDMI and only one - I assume that'll work too).
I'll try adding my other monitors back one by one (I have a tri-screen setup + a TV + vive, so I'm typnig this on the TV just now) but I'll do all that tomorrow, just finished a few hours of Hover Junkers and it's time for bed! (hover junkers is awesome :))
Predatux Apr 15, 2016 @ 2:28am 
Using Windows 10 recognizes all the USB .
Using windows 7 fails a USB port , there is no way to fix it ...

Using Windows 10 does not recognize the hdm.
Using windows 7 recognizes the hmd, but does not work.

The composer does not work (error 400).

More errors:
SteamVR could not be started for unknown reasons (error 109 )


Room setup program breaks. (The game crashed . The crash report folder named " 2016-04-15_111502 " next to executable game . It would be great if fou'd send it to the developer of the game! )

steam_api64_dll missing. The check does not work.

I take two days trying to work without success.
Pixel Apr 15, 2016 @ 9:59am 
ive got the same issue also trying to get my vive working since 2 days, support is clueless....
MysticCrusher Apr 15, 2016 @ 1:50pm 
After updating everything and using on/off outlet on the Vive adaptor Vive and Oculus work fine on my end. I connected Vive through the outlet with a remote on/off switch, it also helps to reset the drivers.
Baumdoktor Apr 18, 2016 @ 7:10pm 
I can confirm , that this issue has something to do with how HDMI ports get handled i just let you guys know what worked for me since i no longer have the problem -

I have one other display connected with my vive over HDMI and the moment i unplugged the second one ( a projector - but could have been a simple monitor as well i guess) the compositor would start and everything works fine - i can even plug the projector back in afterwards and it stays fine - it is reproducible - meaning : i can unplug the vive and plug it in again and end up with the same problem - unplugging the second HDMI fixes it every time. (note: two gpu's involved (gtx780) and the HDMI in question are on different cards)
XboxVillain1 May 5, 2016 @ 9:35pm 
I am a little upset over this issue now, after the countless other problems I have met during the setup process. I have tried everything to get this working and it still gets the compositor issue. If I disable Direct Mode I get stuck out of Direct Mode and have to edit the config file to re-enable it. If I re-enable it compositor is still screwed.
Just wish i hadn't dropped a grand on hardware that has this overly buggy software.
spacegazelle May 8, 2016 @ 7:47am 
I had this problem and it's ongoing. It might be linked to the EVGA 980TI, but maybe not. I bought a DP to miniDP cable which sorted it the first time I used it but am getting the error again. EVGA suggested getting a HDMI to displayport converter instead so I'll report back when it arrives next week.
maplesyrupghost May 11, 2016 @ 8:21pm 
try go into the 'bin' folder of steamvr, you'll see compositor's .exe file, hold shift and right click on it and choose "launch as administrator"
^ω^ Marco >_< May 22, 2016 @ 3:50am 
This is how to solve this problem: 1.put your HMD directly to the graphics card 2. only use 1 monitor...i use a vga/dvi display and i have a second monitor with hdmi and when i unplugged the hdmi from the motherboard and restartet it workd fine :)
Dopadream May 27, 2016 @ 3:22pm 
Originally posted by Turboclaw:
Try this, if you haven't yet:

Head into the Settings screen in the SteamVR application.
Hold Shift and click on Devices. A link under the headset should read 'Enable Direct Mode' - Click it. Your monitors should flash black, and SteamVR will restart. If you go back to Devices, the link should now read 'Disable Direct Mode' which can be used to reverse this change.

My Pre would sometimes revert to extended, but I haven't had that occur since performing the above step.
Got the step from here, would be worth it to run through them all if you haven't: https://developer.valvesoftware.com/wiki/SteamVR/Enable_Direct_Mode_Legacy
thanks a lot, i did that and it ruined it even more. now it doesn't even detect the headset all together and i can't reverse it. ♥♥♥♥♥♥♥♥♥♥.
Dopadream May 27, 2016 @ 3:29pm 
Originally posted by Quack:
Originally posted by Turboclaw:
Try this, if you haven't yet:

Head into the Settings screen in the SteamVR application.
Hold Shift and click on Devices. A link under the headset should read 'Enable Direct Mode' - Click it. Your monitors should flash black, and SteamVR will restart. If you go back to Devices, the link should now read 'Disable Direct Mode' which can be used to reverse this change.

My Pre would sometimes revert to extended, but I haven't had that occur since performing the above step.
Got the step from here, would be worth it to run through them all if you haven't: https://developer.valvesoftware.com/wiki/SteamVR/Enable_Direct_Mode_Legacy
thanks a lot, i did that and it ruined it even more. now it doesn't even detect the headset all together and i can't reverse it. ♥♥♥♥♥♥♥♥♥♥.
i have still yet found a way to fix it, the monitor is showing on my vive's screen now. i hate you so much.
Zarka17 May 27, 2016 @ 4:04pm 
The solution that finally worked for me was this:

1)Open up NVIDIA Control panel
2)Manage 3d settings
3)Change preferred graphics processor to "High-Performance NVIDIA processor
4)Go to programs and ensure steam application is using high-performance nvidia processor

My issue was that my computer was set to use the dedicated graphics card for games only and would use the integrated card on the motherboard otherwise. Forcing the nvidia card at all times fixed it.
< >
Showing 31-45 of 81 comments
Per page: 15 30 50

Date Posted: Feb 29, 2016 @ 1:18pm
Posts: 81