SteamVR Developer Hardware

SteamVR Developer Hardware

jboss Feb 29, 2016 @ 1:18pm
Compositor is not available (400)
After unboxing and connecting all the hardware I started Steam VR, got green icons for all the 5 hardware items, but Steam VR still shows Not Ready, with the error message Compositor is not avaiable. There is a link to launch the compositor, but that does not seem to do anything.

I found a thread saying that I can start the compositor manually, but that also did not seem to do anything, also not when I tried running it as administrator (can I check somewhere if it is running?)

So I'm stuck, hope someone can help me out.
< >
Showing 1-15 of 81 comments
r0bbie90 Feb 29, 2016 @ 1:28pm 
Was about this make this identical post when we came across yours.

We've had the exact same issue - unboxed and set up all the hardware this evening, updated all the firmware, got green icons for all of the hardware components, but we're still getting a "Not Ready" message with "Compositor is not available (400)". Similarly, when we click the "Launch Compositor" button nothing happens.

We were concerned when Google turned up no similar issues, so relieved to hear we're not alone.

Screenshot[i.imgur.com]
Last edited by r0bbie90; Feb 29, 2016 @ 2:44pm
DeepElement Feb 29, 2016 @ 1:37pm 
+1. Hitting this on my pre, same 5 green lights.
DeepElement Feb 29, 2016 @ 1:42pm 
The relevant stuff:

Mon Feb 29 2016 13:41:55.585 - VR compositor (v1456770167) starting up
Mon Feb 29 2016 13:41:55.585 - RuntimePath : C:\Program Files (x86)\Steam\steamapps\common\SteamVR\
Mon Feb 29 2016 13:41:55.638 - Events created
Mon Feb 29 2016 13:41:55.661 - Initializing D3D resources...
Mon Feb 29 2016 13:41:55.673 - Headset is using direct mode
Mon Feb 29 2016 13:41:55.747 - Creating nvapi display
Mon Feb 29 2016 13:41:55.772 - Failed to create render targets for NvAPI display in direct mode!
Mon Feb 29 2016 13:41:55.775 - Failed to initialize compositor
Mon Feb 29 2016 13:41:55.776 - Failed to start compositor: VRInitError_Compositor_Failed
DeepElement Feb 29, 2016 @ 1:52pm 
This obviously has something to do with directmode support. Still digging to see if i can find any more clues.
Megaforce Feb 29, 2016 @ 2:07pm 
Try this, if you haven't yet:

Head into the Settings screen in the SteamVR application.
Hold Shift and click on Devices. A link under the headset should read 'Enable Direct Mode' - Click it. Your monitors should flash black, and SteamVR will restart. If you go back to Devices, the link should now read 'Disable Direct Mode' which can be used to reverse this change.

My Pre would sometimes revert to extended, but I haven't had that occur since performing the above step.
Got the step from here, would be worth it to run through them all if you haven't: https://developer.valvesoftware.com/wiki/SteamVR/Enable_Direct_Mode_Legacy
Last edited by Megaforce; Feb 29, 2016 @ 2:09pm
DeepElement Feb 29, 2016 @ 3:17pm 
Tried that and I do see something that might aid in the investigation:
- With Direct Mode disabled, I see all green, White light on HMD and the mirror screen rolling without correct tracking... but the HMD is Black and has no screen activity
- Direct Mode enabled causes Red/White flashing on the HMD, Compositor errors and no Mirror Mode
DeepElement Feb 29, 2016 @ 3:46pm 
There is definitely a relationship here. 1) I can't see extended desktop in non-direct and 2) direct mode fails with the 400.

I actually haven't seen the HMD light-up in any scenario. When not in direct mode, SteamVR reports healthy connection over USB, even displaying framerates and allowing mirror mode. No screen activity on the HMD.
Axorr Feb 29, 2016 @ 4:05pm 
Same issue here. Everything seems to update well. I had video to the HMD until the firmware updates. Now, the HMD is dark (but the little white light is solid) and SteamVR indicates a good connection. I also get the 'Big Picture' Steam menu loading up in a window on my primary monitor - yet nothing to the HMD.
DeepElement Feb 29, 2016 @ 4:48pm 
thanks for the feedback @axorr. I updated firmware on first setup, which could be the reason I haven't seen any screen activity so far.
Spooks Feb 29, 2016 @ 5:20pm 
+1 to this-- Would love to add more to the convo but I'm having literally the same issues. Though I have yet to see any white light.
Spooks Feb 29, 2016 @ 5:39pm 
Update: USB issue fixed it. Tried a few different plugs and found one that worked.
RollWave Feb 29, 2016 @ 6:29pm 
I had this issue but found a fix. Question - where is your monitor plugged in? To your motherboard or to your graphics card?

If motherboard integrated graphics, just unplug from there, and replug into your graphics card.

That fixed it for me. No idea why this became an issue. My hmd worked perfectly find with multiple monitors 1 on graphics card, 1 on integrated graphics. Then still worked fine with just 1 monitor on integrated graphics. Then next day, nothing changed, but compositor error 400.

Moved the cable on the back of the pc, and it went away and worked perfectly fine.
Last edited by RollWave; Feb 29, 2016 @ 6:30pm
zalo Feb 29, 2016 @ 7:08pm 
Recycling the GPU-side HDMI plug is almost always the solution when everything is green, and the LED is white, but you don't see anything on the display.
jboss Mar 1, 2016 @ 3:55am 
Thanks for the reactions, somehow it solved itself. When I started Steam VR this morning the message no longer showed up. Although I now have the problem that the controlers are no longer recognised wirelessly.....
Axorr Mar 1, 2016 @ 10:43am 
OK. My headset is working today. The only change I made was to plug the HDMI cable into the primary video card (I have two of them in this box). Why wouldn't it work from the second identical card...? I did not reboot, this machine is rarely ever off.
< >
Showing 1-15 of 81 comments
Per page: 15 30 50

Date Posted: Feb 29, 2016 @ 1:18pm
Posts: 81