Rain World

Rain World

View Stats:
Rain World > General Discussions > Topic Details
sgsrules Mar 27, 2017 @ 9:35pm
Graphics related bug
I just installed the game and booted it up. I'm psyched that steam released it a bit earlier than expected but unfortunetly it's unplayable on my pc at the moment. There seems to be an odd bug that is affecting the characters in the game, you can only see their shadows. Is anyone else experiencing this? I'm running on a 980ti 378.78 driver ver.
< >
Showing 1-6 of 6 comments
Normal Primate  [developer] Mar 27, 2017 @ 9:41pm 
Ah! This is one we've solved a few times but keeps popping up.

2 possibilities: First, check to make sure Rain World is running on your GPU rather than some integrated graphics card. And if that doesnt work, try altering the games resolution settings, going between windowed mode, etc.

If neither of those work, let me know and we'll follow up!
sgsrules Mar 27, 2017 @ 9:46pm 
Thanks for the quick reply! I already tried various resolutions as well as windowed and fullscreen and get the same results. I'm currently updating to the newest nvidia driver to see if that helps. How do i make sure if it's running with my GPU vs integrated graphics. If i'm not mistaken this is a Unity game so it should automatically use my GPU.
Normal Primate  [developer] Mar 27, 2017 @ 9:54pm 
I believe the easiest way is to open up your Nvidia control panel.

Search for Control Panel -> Hardware and Sound -> NVIDIA Control panel

Then when inside, go to "Manage 3D settings", and make sure your preferred graphics processor is your NVIDIA card.

If it already IS selected, then go to the next panel over, "Program Settings", "Select program to customize" and manually select Rain World from the list.

It realllllly shouldn't be that way, but who knows, sometimes settings get weird. Let me know how it goes!
sgsrules Mar 27, 2017 @ 9:58pm 
Ok updating drivers didn't help neither did changing any of the ingame settings. But i did find a solution:

I play my games on a 720p projector so my dektop resolution is set to 1280x720. I discovered that if i changed my desktop resolution to 2560x1440 (using nvidias DSR) before launching the game everything works as expected without glitches. So it seems to be that the culprit is the desktop resolution. Unity games generally don't run in fullscreen mode, they usually just run in borderless windowed mode so the desktop resolution can affect the game. I Hope this info helps, I'd hate top see other people refund this or give it bad reviews over an easy fix.
sgsrules Mar 28, 2017 @ 8:16am 
The issue seems to popup whenever your monitors vertical resolution is less than any of the supported resolutions. The lowest vertical resolution that the game supports is 768 so if youre running it on a 720p display the game will glitch out. If possible you should add support for lower vertical resolutions like 720p so that people dont run into this issue.
so the fix is to Run a 1280 X 768 using Nvidia control panel instead of the 1280X720 native resolution?
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

Rain World > General Discussions > Topic Details
Date Posted: Mar 27, 2017 @ 9:35pm
Posts: 6