Saints Row: Gat out of Hell

Saints Row: Gat out of Hell

View Stats:
Dezoul Jan 20, 2015 @ 9:11am
Keybindings
Has anyone had any trouble setting keybindings? When I try to set a keybinding it tells me to hit the key, when I hit the key the screen goes away and the option I try to change just stays blank. It worked on crouch toggle but taunt or compliment is not changing.
< >
Showing 16-26 of 26 comments
Carighan Jan 23, 2015 @ 3:40pm 
Same issue here, cannot rebind half the keys on my keyboard, also it's somewhat random what can be boudn to which keys.
Kevitysearch Jan 25, 2015 @ 9:27am 
Weak sauce, Also can't bind many keys. No running left for me either, or steering vehicles left for that matter. Patch this shiz!!
DvST8 Jan 28, 2015 @ 8:39am 
I can't bind the Z key either.
Also every time I start the game it resets to 720p from 1080p.
Hope we get a patch to fix this soon.
Last edited by DvST8; Jan 28, 2015 @ 8:40am
cchargin Jan 28, 2015 @ 7:26pm 
Hey all,
I found a workaround that will help with some of the keybinding problems. I found an app called AutoHotKey. It lets you re-map keyboard keys without a reboot. I used it to turn g into h!

One downside is that it does NOT change the ingame prompts. For example in my game tutorial text still says "press h to blah, blah, blah" when in fact I can now press g. So don't forget all of the re-assignments you make.

Remember that you must run AutoHotKey before you run the game and don't forget to shut down AutoHotKey when you exit the game!

AutoHotKey is free and opensource: http://www.autohotkey.com/
Emmerich Ersatz Jan 28, 2015 @ 10:12pm 
I ended up finishing the DLC without my walk left key bound. I didn't use any vehicles, and if I needed to go in that direction, I just turned the camera.

I would really, really like it if this could be fixed.
Philtastic Jan 29, 2015 @ 9:05am 
I suspect that there won't be a fix given how short the game is and probably only a minority actually change their keybindings.
stylez Jun 20, 2015 @ 8:12am 
Minority or not, how exactly do you ♥♥♥♥ up keybind setup? Especially when it worked in the previous games?

For anyone having problems with keybindings, I think I have a workaround. It requires a hex editor (HxD is my preference) and some trial and error; I don't have specific offsets for things so the onus will be on you to figure out whatever offset you need to change for yourself.

For my purposes, I wanted to use "G" for Move Right, as I prefer RDFG over WASD, but G could not be assigned. So what I did was assign "H" to the secondary Move Right slot. Then in the Steam userdata folder for SR:G, I made a copy of C:\Program Files (x86)\Steam\userdata\<userid>\206420\remote\srgDEF_PROFILE, so now I have 2 files:

srgDEF_PROFILE
srgDEF_PROFILE - Copy

Back in SR:G, I went back into the edit keybind screen, and changed "H" to "J".

Comparing the two files with HxD, I saw a few differences - the first difference in the file was around offset 0x301A, and the difference in value between the two files didn't really make much sense, probably a checksum or timestamp or something. On to the next difference, at offset 0x3EF4, which changed from 0x23 to 0x24.

OK, well it still doesn't make sense from a key value as "H" and "J" should have a difference in value of 2, but they are adjacent to each other, so ... let's test that theory. Back in SR:G, replaced J with L. Recompared the files, sure enough the value was now 0x26. So the keymappings appear to be in order of how they appear on the keyboard; let's try changing 0x26 to 0x22 (since H is 0x23, G should be -1 from that). Change the value, save. Reload SR:G and how about that: Move Right secondary key is now "G".

Following the above, you should be able to remap any action to any key you want with a bit of trial & error. This works best if the secondary key is currently blank for the action you're trying to rebind.
  • Make a copy of your current profile file
  • Add a secondary key to whichever action you're trying to rebind, which is near the key that currently doesn't work ("H" instead of "G", "X" instead of "Z", etc)
  • Exit the keybind screen to save the changes
  • Compare the copy of your profile w/ the current profile, making note of any differences (particularly a 00 to ## change, assuming the secondary key was previously not set for the action you're modifying)
  • Change the same command's secondary key to the next key over (from H to J, X to C, etc), exit the screen to save
  • Compare the two profile files again, looking for the value that has changed +1/-1, at the same offset that had previously changed from 00 to ##.
  • Exit the game
  • Change the value accordingly depending on the key layout, save the profile
  • Relaunch the game
  • Go into the keybind screen and confirm the key is set as desired

We determined G=22 and for my own purposes I also figured out Z=2C, so we know at least the following keys/values:
A=1E S=1F D=20 F=21 G=22 H=23 J=24 K=25 L=26 Z=2C X=2D C=2E V=2F B=30 N=31 M=32
Last edited by stylez; Jun 20, 2015 @ 2:05pm
Silk Nov 4, 2016 @ 4:37pm 
Err so I don't use WASD to play cos I can't. So I am trying to play this today and can't rebind G, arrow up, arrow down, or Z. It is literally unplayable and i bought the game some time ago so cant' get a refund. Is there at least some config override to this bug that the devs clearly have no intention of fixing (even though as a programmer I know it would be minimal effort... sigh)
headholo Dec 18, 2017 @ 11:20am 
I use Glovepie v.4.5 when a game doesn't have a proper key-config.
It has a easy to use gui tab for setting up what key you want to use ,you can literally do it with the left-click of a mouse,
Ron Mar 24, 2021 @ 12:24pm 
Hello everyone, i hope my intervene will not be considered as necro because this is an important thread and i think i've found a solution to this problem, if i remember i had the same problem in SR4 with few keys and used same method.
So, as default jump is assigned to spacebar and when you try to assign right mouse it doesn't work (me too like to use the right mouse to jump in games) so, first thing delete the spacebar assignment leaving both options as blank, then assign the jump to the middle mouse button(use the first option, the one that had the spacebar before) , it will works, now, go to another key assignment (i used the zoom) and assign right mouse button to the zoom option, it will works, now, return to the jump and try to assign the right mouse button to the jump, a tooltip will tell you that the key is already assigned to another key and ask you if you want overwrite it, just answer yes, and this time the game will assign the right mouse button to the jump ^^
I hope i was useful to someone, have fun playing the game :lunar2019coolpig:
Last edited by Ron; Mar 24, 2021 @ 12:26pm
Nayko93 Apr 10, 2021 @ 9:15am 
Originally posted by TRB4:
You might need to manually change the bindings in the .ini file.
where is this file please ?
< >
Showing 16-26 of 26 comments
Per page: 1530 50

Date Posted: Jan 20, 2015 @ 9:11am
Posts: 26