Krita
Ganância Sep 13, 2019 @ 10:02pm
Linux Version Won't Launch
Trying to launch it from Steam and game won't pass splash screen,

But I can run it by double-click the .appimage

Is anyone having a similar problem?
Originally posted by EmmetPDX:
I've updated the fix to the default launcher and default branch. Sorry about the nasty bug and thanks again for the help everyone.

https://steamcommunity.com/gid/103582791435216837/announcements/detail/1663444077014521470
< >
Showing 16-30 of 55 comments
Blackcats43 Sep 22, 2019 @ 6:06am 
Originally posted by EmmetPDX:
I'm looking into this, everybody. The more information you can give me about your system and what happens when trying to run Krita through Steam, the easier it will be to figure out what's going wrong and who is affected. Sorry :(

If you could, please tell me which distro you're running, including the version. Internally we've tested on the latest Ubuntu as well as Manjaro, but obviously it difficult to test across every distro. And, if you could also check Help > About Steam, to see which version of Steam you're running, that might give more insight.

I'm not sure what would cause the AppImage to run on your system, but fail to run via Steam. But I'm looking into it.



Hi !!!
i am french sorry bad english

I am under debian 10 and to launch the .appimage site no problem and the one in the folder steam no problem too! it's OK

on the other hand launch it by the interface of steam ca crash immediately
I use krita for a very long time and never have a problem with the appimage
I try to even my side and what I can deduce
the steam id ok it has the check area the windows version
I'm launching it in terminal and no mistake just it launches and crash
I think of the link between the steam panel and the .appimage

good otherwise i love kritat i just took it on steam to support the project
clean interface with nikel layer management
on the other hand just a little twisted the management of police selection

I recomande widely krita
OSA413 Sep 23, 2019 @ 7:12am 
Same problem. Ubuntu 16.04 x64
OSA413 Sep 23, 2019 @ 9:11am 
Originally posted by spiritabsolute:
Errors logs are here! ~/.steam/error

/steamapps/common/Krita/krita.appimage: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.12' not found (required by /tmp/.mount_krita.T3W2yk/usr/bin/../lib/libkritacolord.so.18)

I've just looked into that directory and found
libQt5Core.so.5, libQt5Core.so.5.5, and libQt5Core.so.5.5.1
EmmetPDX  [developer] Sep 25, 2019 @ 12:38pm 
One of the other Krita developers suggested that I check if any of you have the QT_PLUGIN_PATH environment variable globally set. You can do this by opening a terminal and entering `echo $QT_PLUGIN_PATH`. If the next line is not blank, then this variable may be causing the issue. I suspect that this isn't the problem but it's worth checking.

Krita's core dependencies, including Qt, are all supposed to be contained in the AppImage. So my guess right now is that the AppImage isn't working quite right inside the Steam Runtime. I'll do some more testing and contact Steam support to see if they can help.
[BRE] Fortin Sep 25, 2019 @ 1:50pm 
`echo $QT_PLUGIN_PATH` === is blank for me
EmmetPDX  [developer] Sep 25, 2019 @ 8:37pm 
Ok, thanks for checking.

I'll have to get in touch with Steam support tomorrow. I'll update here when I have more info. I know it's a pain but, for now, please launch Krita externally.
EmmetPDX  [developer] Sep 26, 2019 @ 8:41pm 
Hey all, just a quick update. I've reached out to Steamworks support for help, and I'll update back here when I can.
[BRE] Fortin Sep 27, 2019 @ 1:47pm 
Cool! Thanks! :steamhappy:
Ganância Sep 28, 2019 @ 3:38pm 
Great!
EmmetPDX  [developer] Oct 4, 2019 @ 12:43am 
Update:

Hey all. My contact with Steam support has suggested that this could be the result of "Steam Overlay injection" failing. We don't know for sure if this will fix the Linux issue, but that's our starting point.

If you could all please restart your Steam client (make sure to fully exit) and try launching Krita through Steam again, we can see if we've found a solution here or if we need to go back to the drawing board. Resting Steam is necessary for the change to apply! Please let me know if disabling Steam Overlay injection has solved this issue or not.

Again, I just want to reiterate that I'm sorry that this has been such a rough Linux launch and to thank you all again for your patience and willingness to work with me as we try to iron things out.
Last edited by EmmetPDX; Oct 4, 2019 @ 12:45am
OSA413 Oct 4, 2019 @ 5:43am 
I'm still experiencing the issue. I've also tried to disable overlay in properties but it didn't work.
OSA413 Oct 4, 2019 @ 6:26am 
And I tried to manually place libQt5Core.so.5.12 and libQt5Core.so.5.12.2 which I manually downloaded from the opensource version of Qt into /usr/lib/x86_64-linux-gnu and it didn't work.
[BRE] Fortin Oct 4, 2019 @ 11:34am 
I've tried to disable overlay in properties. Did not help. Does not work.
Ganância Oct 4, 2019 @ 2:34pm 
Same thing here, I also noticed that when I run the app through appimage it loads in my native language (pt-br) but when I launch it from Steam it loads in english even with my steam client on pt-br.

By launch I mean the splash screen only
EmmetPDX  [developer] Oct 4, 2019 @ 11:22pm 
You don't need to disable the overlay manually, Valve/Steam have supposedly disabled the overlay injection on their end, so all you should have to do is restart Steam and then run Krita. If that doesn't work the problem is probably elsewhere!

Also, Ganancia, does the Krita splash screen show up? I was kind of under the impression that nothing happened at all when you tried launching it. Is it actually the case that the splash screen shows up, but then the rest of the app doesn't ever load? (Not that it changes much, but it could be a clue.)
< >
Showing 16-30 of 55 comments
Per page: 1530 50