Startopia

Startopia

View Stats:
Startopia > General Discussions > Topic Details
AdApt* Oct 10, 2013 @ 12:50pm
Flickering
I had this game ages ago and the black screen flickering stopped me from playing it and I gave it away. A friend also picked the game up and had the same issue

Disabling vsync and changing the display method to 'Blit' reduced the flickering but it was still there
< >
Showing 1-15 of 16 comments
rogerwilco! Oct 10, 2013 @ 2:02pm 
I too am having a flickering problem with the game
Same here.
ArcticBliss Oct 10, 2013 @ 5:38pm 
http://www.gog.com/forum/startopia/flickering_screen

Maybe there's a tip in that thread that can help you.
mar3usmc Oct 10, 2013 @ 8:12pm 
Unfortunately I tried the vsync options, and while it improved, it did not fix the issue. I will try to turn off the crossfire and see if that fixes it later.
AdApt* Oct 11, 2013 @ 2:12am 
Anyone managed to fix this?
mp.73 Oct 11, 2013 @ 4:26am 
I had this first time on startup, a black flicker every few seconds very distracting.

I am using an Nvidia GTX680 with the latest drivers (327.23)

I fixed it doing this;

Nvidia Control Panel > manage 3D settings > Global Settings > Vertical Sync
I chose the option "Use 3D application setting"
(Its probably set that way by default)

From within the game find the video settings and look for the Vsync options, change that to Blit.

That did the trick for me.
AdApt* Oct 11, 2013 @ 5:53am 
Originally posted by mp.73:
I fixed it doing this;

Nvidia Control Panel > manage 3D settings > Global Settings > Vertical Sync
I chose the option "Use 3D application setting"
(Its probably set that way by default)

From within the game find the video settings and look for the Vsync options, change that to Blit.

That did the trick for me.

This reduces the flickering but doesn't completely eliminate it for some people. I had this issue and looked around on some forums and a lot of people were saying that the flickering was still there just not as frequent
Murder Mountain Oct 14, 2013 @ 4:25am 
god, i fixed it before. Need to remember.

Go to your graphics options, and mess around with the graphics card portion and change it to SOFTWARE. In fact, change everything to software when you get the option to.

Then go down to "display method" and select "blit."

That's how I fixed my flickering. I hope I managed to help some people here.
Last edited by Murder Mountain; Oct 14, 2013 @ 4:25am
This reduces the flickering but doesn't completely eliminate it for some people. I had this issue and looked around on some forums and a lot of people were saying that the flickering was still there just not as frequent

True. I still have this issue. The game used to work fine before, so I believe it must be some other setting.
Kuloth May 5, 2014 @ 6:29pm 
I just made the mistake of buying this game - oops. Flickering doesn't completely go away for me either with the blit trick or any other combination of settings, I find it quite unplayable.
pumilamac Jun 21, 2014 @ 8:59pm 
Disabling CrossFire fixed it for me.

In Catalyst Control Center go to Gaming, 3D Application Settings, add startopia.exe and set AMD CrossFireX Mode to Disabled. I had to restart Startopia to get the CrossFire option to show up.
Kuloth Jun 22, 2014 @ 5:08am 
Not using crossfire here, so that isn't it for me.
ShOdinReepr Jun 28, 2014 @ 12:22am 
I get some flicker on deck three, but it isn't a show stopper for me.
Inari Jul 18, 2014 @ 5:14am 
Worked for me when switching to Blit... note thouhg: you have to change some other options so the Apply button lgihts up and then click that <.<
Kindred Dec 31, 2016 @ 4:55am 
Originally posted by mp.73:
I had this first time on startup, a black flicker every few seconds very distracting.

I am using an Nvidia GTX680 with the latest drivers (327.23)

I fixed it doing this;

Nvidia Control Panel > manage 3D settings > Global Settings > Vertical Sync
I chose the option "Use 3D application setting"
(Its probably set that way by default)

From within the game find the video settings and look for the Vsync options, change that to Blit.

That did the trick for me.

I used Nvidia Inspector to set Vsync to 3D application, also maxed out AA and other settings. Set to Blit in game and it's working great now. Thanks :) I'm playing at 1080p. Does anyone know if there's any way to make the text bigger, it's too small.
< >
Showing 1-15 of 16 comments
Per page: 15 30 50

Startopia > General Discussions > Topic Details