Startopia

Startopia

View Stats:
Startopia > General Discussions > Topic Details
alexgophermix Feb 3, 2014 @ 4:09pm
Bug/Crash megathread
I've noticed a lot of posts asking how to resolve some common problems with this game, so I've put together a megathread of all known issues so far. Please let me know as much as you can about your crash/issue and I can add it to this list. Also if you know of solutions to any of these issues please post them!

Crash after a few minutes of running the game
Possible solution: Install patch 1.01b (unofficial) and/or run Startopia as administrator and with Windows 98 compatibility. You can read the full post about this solution on my post here[www.thegameengine.org].

Crash on building brig
Possible solution: Update your video drivers and build smaller brigs. The maximum size seems to vary by machine. Full post can be found here[www.gog.com].

Crash/Black screen on startup w. sound
Possible solution: Open up Directx control panel (type directx into the run box on start menu). Switch to the directdraw tab, and select the group tab labelled performance. Enable "Use ModeX for 320 by X(DX7-)". Solution posted by mp.73.

Flickering screen
Possible solution: switch "Display Method" to "Blit" and switch "Transform and Lighting" to "Software". You can read the full post about the solution on my post here[www.thegameengine.org].

Multiplayer crashes/desyncs
Possible solutions: There is no complete solution for this unfortunately but there are several things you can try to reduce the number of crash/desyncs.
- Do not use gamespy. The game works much better on TCP IP/LAN
- Do not try to save. Do not pause. Do not open the menu.
- Disable autosaves. There are a number of reports that the autosave itself causes the crashes and that disabled the autosaving by write-protecting the file might help. To disable autosaves find all autosave*.sav files, right click > properties > read only.
You can view the full post about these workarounds on my post here[www.thegameengine.org].

If the mods could pin this, that would be great!
Last edited by alexgophermix; Feb 3, 2014 @ 4:32pm
< >
Showing 1-7 of 7 comments
Peach Jelly Jan 13, 2015 @ 9:19am 
I run Windows 7. The starting screen menus stutter and lag very badly when they animate (like when the spaceship switches screens or flies away). I started the first tutorial, and everything worked fine until I tried placing down my first blueprint. The image would not render correctly when I moved it around on the screen, the whited out image duplicated itself all over the screen, and it ultimately crashed the game.

I've tried installing the patches you recommended, but they both said that both patches have already been applied. Tried running as admin; it didn't really help. Tried setting compatibility for Windows 98, but it wouldn't even start like that.
alexgophermix Jan 13, 2015 @ 11:19pm 
Definitely try switching "Display Method" to "Blit" and switch "Transform and Lighting" to "Software" if you haven't done that already. That fixes a whole host of issues. If you've done that already without success do you mind posting your video card model and maybe a screenshot of the issue if you can grab one?

I personally haven't heard of the blueprint issue you described and I can't find a reference to it on the web so I'm inclined to say it's driver/card specific.

For reference my video card is NVIDIA GeForece GTX 550 Ti and I'm running the game on Window 7 64bit.
Hotpants86 Jan 22, 2015 @ 2:53pm 
Any idea how to implement that DirectX/DirectDraw fix in Windows 8?
Dethstarr Jan 24, 2015 @ 3:00pm 
Using 2 x GTX 980 (Zotac AMP Extreme). The game tells me I have no 3D devices when I launch (SLI on or off makes no difference). It then crashes after telling me it is switching to software raterizer.
Windows 7 Ultimate

Solved - If I switch directly to 2560 x 1440 it crashes. If I increase in 3 hops, increasing the resolution everytime, it is fine. (Rog swift Gysynch enabled 2560 x 1440 monitor).
Last edited by Dethstarr; Jan 24, 2015 @ 3:04pm
Reality Feb 6, 2015 @ 5:35am 
I have two computers.. a stock win7, and a win8. The win7 runs the game perfectly.

Every time I launched the game on win8, I get a prompt to allow the game to make changes to my computer, and then a black screen with the startopia beeping noise, (can't pick any of the file/etc options along the top either) Then I would have to force crash the game with taskmanager to get back to the rest of my computer.

Even though this guy described a different problem, when I put his solution into the game's launch properties (with my own computer's resoltion for the first two numbers) it ran just fine.

Originally posted by Metaloha:
I added "/r1680x1050x32" to the startup options - my desktop is 1680x1050; it seems the game is failing to detect the resolution.

Previously, I would just see immediate errors - no backgrounds, no intros, no sounds, just 5 or 6 dialog boxes I had to click to acknowledge the crashing and get back to the desktop.

YMMV.
Hotpants86 Feb 6, 2015 @ 1:02pm 
That was a good thought, but unfortunately no matter what resolution I try, I still just get a black screen with the loading sounds and then it crashes. I even tried scaling my native resolution down to 1600x900 to see if it just couldn't handle 1920x1080 at all.
Maxcat Feb 7, 2015 @ 10:32am 
I have a diffrent problem with starting the game. When I start, it only shows part of the screen. http://i.imgur.com/cR7OKS0.png
Any advice?
< >
Showing 1-7 of 7 comments
Per page: 15 30 50

Startopia > General Discussions > Topic Details