Superfrog HD

Superfrog HD

View Stats:
Superfrog HD > Report a Problem > Topic Details
Pepe Oct 31, 2013 @ 12:05pm
Linux version - won't start
Here is the log from terminal - Ubuntu 13.10:

pepe@Fifinka:~/.local/share/Steam/SteamApps/common/Superfrog/bin$ ./Superfrog
./Superfrog: error while loading shared libraries: cannot open shared object file: No such file or directory
Last edited by Pepe; Oct 31, 2013 @ 12:08pm
< >
Showing 1-15 of 31 comments
jazztickets Oct 31, 2013 @ 12:41pm 
you want to run instead. However it still doesn't work cause they didn't package all the .so files that it needs.
Pepe Oct 31, 2013 @ 1:13pm 
When you will open my log from terminal, you will see
"/home/pepe/.local/share/Steam/SteamApps/common/Superfrog/ line 5: 12879 Aborted "
But when you will open that file with some text editor, you will see that .sh will open binary "Superfrog" in /bin/.

So, i have right in my 1st post. But i can confirm from you, that .so packages, are missing.
jazztickets Oct 31, 2013 @ 1:45pm 
You can probably just install the necessary 32bit libs that it needs.

sudo apt-get install libsdl-mixer1.2:i386 libsdl1.2debian:i386
GWS Oct 31, 2013 @ 2:32pm 
i installed libsdl-mixer and i have the same problem
Pepe Oct 31, 2013 @ 2:49pm 
jazztickets: You said, that .so packages are you missing and you're giving an advice, which couldnt help, because this problem is only for Superfrog.
When i'll have problem with many games, i will install some packages.
But in this case in my 1st is: "App need shared object, but app coudn't find him, because file or foldery isn't exist."\
Btw. I didn't install some libraries, which could make OS unstable or something else, which i didnt need.. I rather use wine =)

I contacted, if i will receive any answer, i will post here =)
jazztickets Oct 31, 2013 @ 4:48pm 
Alright everyone needs to calm down and run this command in a fresh new terminal:
cd ~/.local/share/Steam/SteamApps/common/Superfrog/ && ./

If it complains about not finding a particular .so file, you gotta install the 32bit version of the library with your package manager. Arch users will need to do the ole "yaourt -S lib32-sdl_mixer lib32-sdl"

ldd is your friend!

The game works for me after you do these chores.
GWS Oct 31, 2013 @ 4:57pm 
user@computer:~$ cd ~/.local/share/Steam/SteamApps/common/Superfrog/ && ./
*** stack smashing detected ***: bin/Superfrog terminated
./ line 5: 7807 Aborted (core dumped) bin/Superfrog

thank you for helping me but the game doesn't run. I have lubuntu 13.10 32bits
BenTeam17 Nov 1, 2013 @ 3:22am 
Good morning all,

For anyone having problems of this nature with Superfrog HD on Linux, could you first please navigate to the page below and follow all of the steps.
Superfrog HD - Support Page

This should either resolve your problem or instruct you on how to supply us with the required information to assist you further.

Kind Regards,
Team17 Support
Stoney_Fish Nov 1, 2013 @ 3:27am 
Same error : *** stack smashing detected ***: bin/Superfrog terminated
Ubuntu 13.10 64 bit
timeskills Nov 1, 2013 @ 3:50am 
0.bit Nov 1, 2013 @ 8:43am 
Originally posted by timeskills:

Confirmed, LC_ALL=C fixes the launching problem for me too :)

You can add export LC_ALL=C to your file until Team17 fixes it, that way you don't have to launch it manually through a terminal every time.
GWS Nov 1, 2013 @ 10:26am 
Originally posted by timeskills:

This doesn't work for me.

user@computer:~/.local/share/Steam/SteamApps/common/Superfrog$ LC_ALL=C LANG=C ./
Setting breakpad minidump AppID = 234000
Steam_SetMinidumpSteamID: Caching Steam ID: 76561198034780132 [API loaded no]
./ line 5: 1909 Segmentation fault (core dumped) bin/Superfrog

I will wait until Team17 fix it
Pepe Nov 1, 2013 @ 11:24am 
bin/Superfrog: error while loading shared libraries: cannot open shared object file: No such file or directory"

Then, i need libraries, what jazztickets say, but i don't want install additional libraries, what i said, because i rather use wine for it..^^
Stoney_Fish Nov 1, 2013 @ 12:09pm 
It worked for me, that frog runs faster than Jazz Jackrabbit
Linux.Florian Nov 3, 2013 @ 12:40pm 
runs fine on Ubuntu 12.04 64 Bit, Ubuntu 13.10 64 Bit and on openSUSE 12.3 64 Bit
< >
Showing 1-15 of 31 comments
Per page: 15 30 50

Superfrog HD > Report a Problem > Topic Details