Spider-Man: Shattered Dimensions

Spider-Man: Shattered Dimensions

Rampage Apr 14, 2016 @ 6:31pm
Resolution help please!
Has anyone been able to change there resolution out of 640 x 840? Everytime I go to change it, I get the message "unable to apply the requested settings. Please make sure that you are applying settings supported by your system"

I have a Nvidia GTXM 970 so its shouldn't be an issue to change it.
< >
Showing 16-30 of 39 comments
Paradox Apr 16, 2016 @ 8:47am 
Same ♥♥♥♥ here, help please
Paradox Apr 16, 2016 @ 11:25am 
Originally posted by JEBUS:
same

Originally posted by RedHorizon:
Same here.
I tried several times to change my resolution with regedit. I also tried to set "luncher" and "game.exe" to run as admin, Win 7 and Vista Service Pack 2 compatibility.
Each time I change the settings (with regedit, I can't change them in the game), the game crash on lunching. Then, it reset the settings to default.

same ♥♥♥♥♥♥♥ problem

HELP!!!!!

I've managed to play it with 1366x768 resolution now! In game options, I made "Texture Filterin" linear, vysnc off , windowed. Then I exit. Run as admistrator and compatible with XP SP2 both "Launcher" and game exe. Then I open the game from steam and now I'm able to change resolution. I think the source of the problem might be filtering so I didn't change that, on the other hand I changed windowed to fullscreen. I hope this helps
Eldritch Monarch Apr 17, 2016 @ 12:09pm 
Originally posted by M&M.Paradox:
Originally posted by JEBUS:
same



same ♥♥♥♥♥♥♥ problem

HELP!!!!!

I've managed to play it with 1366x768 resolution now! In game options, I made "Texture Filterin" linear, vysnc off , windowed. Then I exit. Run as admistrator and compatible with XP SP2 both "Launcher" and game exe. Then I open the game from steam and now I'm able to change resolution. I think the source of the problem might be filtering so I didn't change that, on the other hand I changed windowed to fullscreen. I hope this helps

I tried it, but it didn't work. When I exit the game and launch it again, it crashes.
Paradox Apr 17, 2016 @ 2:55pm 
Originally posted by Gummgs:
Originally posted by M&M.Paradox:

I've managed to play it with 1366x768 resolution now! In game options, I made "Texture Filterin" linear, vysnc off , windowed. Then I exit. Run as admistrator and compatible with XP SP2 both "Launcher" and game exe. Then I open the game from steam and now I'm able to change resolution. I think the source of the problem might be filtering so I didn't change that, on the other hand I changed windowed to fullscreen. I hope this helps

I tried it, but it didn't work. When I exit the game and launch it again, it crashes.

I just checked and find out that when I exit after doing above steps, the game crashes again when I try to launch... So I have to do all these stuff every time when I want to play this game...
Lew Apr 17, 2016 @ 4:08pm 
Well guys I have figured out a way to fix it, so I hope it works for you guys.
Basically you need to start the game on default settings or whatever, go to Graphics, and select Windowed. Exit the game
Re-start the game (it should start in Windowed mode), and go to Graphics, and you SHOULD be able to select resolutions above 800x600, fullscreen and widescreen, etc.
It's a bit of a pain but at least it works.
Hope it works for anyone who is having the problem! :)
(EDIT: you might need to mess around with the Windowed settings in REGEDIT, which is what I have to do sometimes)
Last edited by Lew; Apr 17, 2016 @ 4:09pm
Eldritch Monarch Apr 17, 2016 @ 7:53pm 
Originally posted by Lew:
Well guys I have figured out a way to fix it, so I hope it works for you guys.
Basically you need to start the game on default settings or whatever, go to Graphics, and select Windowed. Exit the game
Re-start the game (it should start in Windowed mode), and go to Graphics, and you SHOULD be able to select resolutions above 800x600, fullscreen and widescreen, etc.
It's a bit of a pain but at least it works.
Hope it works for anyone who is having the problem! :)
(EDIT: you might need to mess around with the Windowed settings in REGEDIT, which is what I have to do sometimes)
Everytime i close the game, it will crash the next time i start it, no matter if it is windowed or fullscreen :(
linkinpark187 Apr 19, 2016 @ 8:06am 
I just bought a Lenovo Y700 earlier this year with the GTX 960M 4GB and had the same issue. I did what was described earlier (regedit) and have had no issues. I didn't bother with running it in compatibility mode and haven't had any issues with saving or resolution. Here's a DropBox link for those that don't feel like messing with the registry:

https://www.dropbox.com/s/pe2ug77nch02bu1/regbkp_spdrmn.reg?dl=0

It should be noted that this is for anyone using a 1920x1080 resolution.
Last edited by linkinpark187; Apr 20, 2016 @ 5:27am
kyro90 Apr 19, 2016 @ 6:49pm 
Originally posted by Le Chili Cheese Fries:
Goto Start, type 'regedit'. Then goto HKEY_CURRENT_USER > SOFTWARE > Activision > Spiderman....> Settings > Display. Change your resolution under "Width" and "Height". Make sure that the values are Hexadecimaal. You can change other display settings here. I changed my VSYNC value to 1. Changed compatibility to Windows 7.

After doing this, I was able to change other display settings in the game.
Cheers!

It seems your solution worked for me but I think my aspect ratio is 4:3 from what it says in the option in-game. Do you know what I would need to type to change that in regedit?
Claymore Apr 19, 2016 @ 7:46pm 
Originally posted by coolsonic64:
I just bought a Lenovo Y700 earlier this year with the GTX 960M 4GB and had the same issue. I did what was described earlier (regedit) and have had no issues. I didn't bother with running it in compatibility mode and haven't had any issues with saving or resolution. Here's a DropBox link for those that don't feel like messing with the registry:

https://www.dropbox.com/s/pe2ug77nch02bu1/regbkp_spdrmn.reg?dl=0
Thank you, this saved me from pulling my hair out. Been trying to get this to work for a week.
SadKatt Apr 19, 2016 @ 8:59pm 
there isnt a fix for it this just the disk version from 2010 none of the bugs on disk were even bothered to be fixed from control deleys to resolution problems to optomization problems it all wasnt even bothered to be fixed you can refund it and buy on console or wait another 6 years for a patch or something thats how long it took for them to do something with this game
Last edited by SadKatt; Apr 19, 2016 @ 8:59pm
GuiOak May 23, 2016 @ 1:26pm 
Go to C:\Program Files (x86)\Steam\steamapps\common\Spider-Man (TM) SD
Right-Click in "Game" and "Launcher", "Properties", then go to "Compatibility", set to "Windows Service Pack 2", apply to both.
Enter the game and check if you are able to change the graphic settings now.
If don't, press "WinKey+R", write "Regedit", press Enter.
Go to HKEY_CURRENT_USER>SOFTWARE>Activision>Spider-Man (TM) SD>Settings>Display.
Change these values:
AspectRatio 3(3)
Brightness 0(0)
Cameras 00 00 00 00....
Contrast 0(0)
Fullscreen 1(1) [The game will run in fullscreen]
Gamma 0(0)
Height 300(768) = Hexadecimal(Screen Size)
MaxAniso 10(16)
QualityPreset 3(3)
QualitySettings 1528(5416)
RefreshRate 0(0)
RenderingFlags 0(0)
Reverb 1(1)
Vsync 0(0)
Width 556(1566)
Height and Width, is the value of my screen, change it to stay in the value that you want.
I'm also using Win 10.
I hope it'll help you guys.
mario64_n64 Jan 30, 2017 @ 9:05pm 
Originally posted by linkinpark187:
I just bought a Lenovo Y700 earlier this year with the GTX 960M 4GB and had the same issue. I did what was described earlier (regedit) and have had no issues. I didn't bother with running it in compatibility mode and haven't had any issues with saving or resolution. Here's a DropBox link for those that don't feel like messing with the registry:

https://www.dropbox.com/s/pe2ug77nch02bu1/regbkp_spdrmn.reg?dl=0

It should be noted that this is for anyone using a 1920x1080 resolution.


Any chance you could upload a version for 4K resolution? I can't seem to change it to 4K in-game or with regedit, I have no idea why it isn't working for me. Any help with this would be greatly appreciated. I tried entering the 4K resolution in hex, but that didn't work (just crashed game and then went back to the default settings).

Thanks.
SadKatt Jan 31, 2017 @ 4:07am 
I really wish they'd fix this game for windows and pc users cause i'd really like to play this on steam
Plexitor Feb 17, 2017 @ 8:58pm 
Originally posted by GuiOak:
Go to C:\Program Files (x86)\Steam\steamapps\common\Spider-Man (TM) SD
Right-Click in "Game" and "Launcher", "Properties", then go to "Compatibility", set to "Windows Service Pack 2", apply to both.
Enter the game and check if you are able to change the graphic settings now.
If don't, press "WinKey+R", write "Regedit", press Enter.
Go to HKEY_CURRENT_USER>SOFTWARE>Activision>Spider-Man (TM) SD>Settings>Display.
Change these values:
AspectRatio 3(3)
Brightness 0(0)
Cameras 00 00 00 00....
Contrast 0(0)
Fullscreen 1(1) [The game will run in fullscreen]
Gamma 0(0)
Height 300(768) = Hexadecimal(Screen Size)
MaxAniso 10(16)
QualityPreset 3(3)
QualitySettings 1528(5416)
RefreshRate 0(0)
RenderingFlags 0(0)
Reverb 1(1)
Vsync 0(0)
Width 556(1566)
Height and Width, is the value of my screen, change it to stay in the value that you want.
I'm also using Win 10.
I hope it'll help you guys.

I love you
Skechy Toothpick Mar 20, 2017 @ 3:40pm 
i may sound stupid, but wheres the rededit
< >
Showing 16-30 of 39 comments
Per page: 1530 50