RaceRoom Racing Experience

RaceRoom Racing Experience

View Stats:
SupremeGoku Dec 17, 2014 @ 1:48pm
Steering Wheel Rotation messed up after lastest update ??
I have my steering rotation set to 900 in the options menu and it has been fine until the latest update. now it wont give me more than 270 even though I have it set to 900 in the menu ???

Has anyone else come across this issue since or before the update ??

Any help would be highly appreciated.
< >
Showing 1-13 of 13 comments
Peter Dec 17, 2014 @ 10:31pm 
What Wheel do you have and what are the Windows settings?
Alucard Dec 18, 2014 @ 1:20pm 
Same problem here, i have g27, I dont get more than 180°
SupremeGoku Dec 18, 2014 @ 3:48pm 
G25, no problems in any other games
The game automatically sets the rotation/steering lock for the various type of car you are using. You can change these default settings in the garage/vehicle set-up.
SupremeGoku Dec 18, 2014 @ 5:15pm 
Originally posted by (ΘČĐ)™Conrad925:
The game automatically sets the rotation/steering lock for the various type of car you are using. You can change these default settings in the garage/vehicle set-up.

I dont think you quite understand what i mean ?

I am talking about the wheel rotation in the cockpit view.
Last edited by SupremeGoku; Dec 18, 2014 @ 5:16pm
Originally posted by acespizee:
Originally posted by (ΘČĐ)™Conrad925:
The game automatically sets the rotation/steering lock for the various type of car you are using. You can change these default settings in the garage/vehicle set-up.

I dont think you quite understand what i mean ?

I am talking about the wheel rotation in the cockpit view.

I only understood what you posted. Wheel rotation in the cockpit view was not mentioned at all. If the wheel animation not being synchronized with your G25 is messing you up, simply turn the wheel off in cockpit view.
kj6zd Dec 18, 2014 @ 11:44pm 
I am having trouble to follow. The wheel rotation? Does it mean how many times the wheel can be rotated or when the animation stops on screen.
The animation stops at the preset rotation lock.
Anything else, may be set in the wheels global setting, if it is a logitech you can use the profiler but set the game to override the globals.
If the Wheel lock is set to 27 (nobody explained it to me, so I think it will stop 270 degrees) then you'll have to make this number larger. This is found in game "Car Settings"
Last edited by kj6zd; Dec 18, 2014 @ 11:46pm
ravenousbeast Dec 20, 2014 @ 6:00am 
The wheel animation together with the driver's hands only goes 270 degrees. Turn off the hands for full rotation.
Demerzel Dec 20, 2014 @ 8:06am 
Originally posted by ravenousbeast:
The wheel animation together with the driver's hands only goes 270 degrees. Turn off the hands for full rotation.
+1. I hope it's a bug....
ravenousbeast Dec 20, 2014 @ 1:13pm 
Originally posted by Demerzel:
Originally posted by ravenousbeast:
The wheel animation together with the driver's hands only goes 270 degrees. Turn off the hands for full rotation.
+1. I hope it's a bug....

It's not a bug, it's been like that for a while. There are no hands animations past that, like there are in Shift, PCars etc. Not a big problem though, most sims so far have been like this.
SLO_Robert Dec 20, 2014 @ 2:42pm 
I was having that problem but i finally fixed ,today .Start the game without stupid Logitech Profiler
Last edited by SLO_Robert; Dec 20, 2014 @ 11:59pm
SupremeGoku Dec 21, 2014 @ 8:35am 
Always used to go round full 900 just like assetto corsa, just seen that the game is updating again, so will try again after update and report back.
SupremeGoku Dec 21, 2014 @ 8:44am 
Just tried it again and still the same. For clarification, its called the "wheel rotation animation". It is located in the option menu then into the vehicle settings tab. I have always had it set to 900 and thats what it has always given me visually and physically, until now.
< >
Showing 1-13 of 13 comments
Per page: 15 30 50

Date Posted: Dec 17, 2014 @ 1:48pm
Posts: 13