Tiny Rogues

Tiny Rogues

View Stats:
 This topic has been pinned, so it's probably important
Resolved : Controls broken since Controller support added
Hello all,
Today after launching the marvelous game that Tiny Rogue is, I discovered (the hard way) that controller support has been added.
In fact, at the bottom of the screen were alterning "Controlling with a mouse" then "Controlling without a mouse" non-stop.
When I walk using the keyboard, the pointer changes and I shoot in the direction of walking, which is undesired. The pointer gets back to normal when I shoot using the mouse but there is a delay.

I thought, it had been updated and I might rebind the keys. The problem is that the game crashes and a red message appears on top of the game. Something like "Sub routine error". At this point, nothing can be done except kill the process.

Anyone else having this problem? The game is -at least for me- unplayable in that state.

Thanks :)
Last edited by Marswaffle ⚡🌷; Nov 26, 2022 @ 10:55am
Originally posted by RubyDev:
1. Make sure if you don't want to play with controller that you unplug the controller.
2. Check that Steam settings of the game under Controller are set to: "Disable Steam Input".
3. Check your keybindings, new buttons for aiming have been added. If you don't control with WASD but arrow keys, you might have "Aiming" and "Moving" now on the same buttons.


The game checks in 3 ways whether or not to switch control scheme:

1. If you move the mouse, it will switch to controlling with mouse.
2. If you press buttons on a controller it will switch to controlling without mouse.
3. If you press the keyboard keys bound for aiming it will switch to controlling without mouse.

Make sure you restart the game after applying all these settings, especially after changing the Steam controller setting.

If it still doesn't work, join the Discord. A few people have found help to set it up correctly now.

https://discord.gg/s5j6SYrMKE
< >
Showing 1-2 of 2 comments
A developer of this app has indicated that this post answers the original topic.
RubyDev  [developer] Nov 26, 2022 @ 4:33am 
1. Make sure if you don't want to play with controller that you unplug the controller.
2. Check that Steam settings of the game under Controller are set to: "Disable Steam Input".
3. Check your keybindings, new buttons for aiming have been added. If you don't control with WASD but arrow keys, you might have "Aiming" and "Moving" now on the same buttons.


The game checks in 3 ways whether or not to switch control scheme:

1. If you move the mouse, it will switch to controlling with mouse.
2. If you press buttons on a controller it will switch to controlling without mouse.
3. If you press the keyboard keys bound for aiming it will switch to controlling without mouse.

Make sure you restart the game after applying all these settings, especially after changing the Steam controller setting.

If it still doesn't work, join the Discord. A few people have found help to set it up correctly now.

https://discord.gg/s5j6SYrMKE
Indeed there are new "manual" aim controls in the Keyboard section. I had my arrows already mapped before the update.

It works fine now !

But in some cases if by mistake you rebind a key to something already used, you have a crash (with an Exception message :) )

Also it is morth noting that I bound the dash on mouse right (Gungeon style I guess? ) and whenever I use something from the menu, it makes me dash. An option to deactivate it would be nice (for instance using the interact key instead :) )

Thanks for the help, and thanks for this brilliant game !
< >
Showing 1-2 of 2 comments
Per page: 1530 50