Soul-Levels Revealed!
67 Comments
< >
Stormbow Feb 17, 2013 @ 12:29pm 
1 - "Soul levels" is two words, not hyphenated.
2 - This mod is being reported as "dirty" by BOSS, needs TES5Edit cleaning.
crazyivanboy Apr 6, 2012 @ 8:47pm 
same here it give none of the cool lights, colors, sounds, animation etc WHEN it does capture a soul but I've noticed quite frequently it does NOT capute a soul even when touch based Soul Trap from the conjuration spells list is cast but it NEVER captures a soul if the creature is killed w/ the first hit (such as foxes, wolves, deer, elk, goats, etc). will unsub for now bc what's the point of using soultrap and killing anything if it doesn't work. am interested when the bugs have been worked out for good.
Klaumbaz Apr 1, 2012 @ 2:11pm 
Same as below, very buggy, stopped all soul collection.
shtkck Mar 28, 2012 @ 8:24pm 
this has potential but dont mess with the lore, just change the output
mayingan Mar 10, 2012 @ 12:24pm 
Would have been a better improvement if souls would automatically go to the right level of soul gem. Isn't that what magic is about?
Dinkle Spark Mar 3, 2012 @ 11:16pm 
I have to agree with Chris, same thing is happening to me.
chris Feb 24, 2012 @ 6:52pm 
Unsubscribing, I'm afraid. While this would be very useful to have, the fact is that it simply doesn't work. No animation (bearable), and capturing souls fails about 2/3 of the time (not bearable). Will resubscribe if the bugs are fixed.
tbkingsbury Feb 21, 2012 @ 6:22pm 
Still needs work... just quit working for me... neither my bow or any of my soul trap weapons now trap souls... disabled the mod and it works fine....MAJOR PROBLEM!
Valtarien Feb 21, 2012 @ 2:31pm 
It works correctly for me about 2/3 of the time. I once got a message saying I captured a lesser soul, when in fact I know it was a grand soul that filled my black soul gem (it was a humanoid). I've unsubscribed for now, but I'll keep an eye on this to see if the problems get fixed. I really do like the premise, and hope for an update.
Darith Feb 20, 2012 @ 8:28pm 
I tried it but it broke Soul Trap for me too. Once that's fixed I'm right back on board. Great idea!
Antomas Feb 20, 2012 @ 3:38am 
A good idea, but so far seems too buggy (soul-trap misses most of the time, and there is no actual soul-trapping effect anymore), I really hope to resubscribe if those issues are fixed.
DietCokeNoIce Feb 19, 2012 @ 4:03am 
Nice enhancement. Works well for me, although sadly I no longer see the purple effect when trapping a soul.
FreshFromHell Feb 18, 2012 @ 8:34am 
@Anonomouscoder, I have tried with the mod disabled and am able to soul trap successfully both with hand weapons up close and with Bow kills at over 35 paces away. One thing I have noticed is no longer getting the soul trap resisted message. I appreciate the work as always.
-FFH
Nebelfetzen Feb 18, 2012 @ 7:29am 
Broke soul trap completely for me. Weapons with soul trap ability did not trap any souls when this mod was activated. Worked fine again as soon as I deactivated this mod. Sorry, dislike it.
FabledGentleman Feb 18, 2012 @ 7:26am 
This mod makes a few missions in game almost impossible to complete because you cannot see the "lasers" you are suppose to align corectly. And the soul trap aura dissapears completely.
anonomouscoder  [author] Feb 18, 2012 @ 6:38am 
@FreshFromHell: Thanks for the detailed testing! Glad to hear that it didn't consume empty gems. Have you tried disabling the mod and testing it? I've tested close to the same way (spell vs enchanted dagger), and when I disable the mod i get about the same ratios of success to failure.
@Scott:Please keep trying, I have seen in the vanilla game that sometimes soul capture just doesn't work even without a resistance message.
FreshFromHell Feb 18, 2012 @ 12:57am 
Bug further tested - one out of 30 kills with a bow at various distances ( including point blank) excuted soultrap with correct message ( this was at 9 normal moving paces away).
Zero messages regarding resisting the soul trap. Tested with dagger with soul trap enchant resulted in consistant soul trap message every time. The one successful bow kill with soul trap did fill a soul gem and keep it in my inventory correctly.
-FFH
Scott Feb 17, 2012 @ 9:07pm 
Currently getting no soul captured messages with mod enabled :/
FreshFromHell Feb 17, 2012 @ 5:56pm 
@Anonomouscoder, Bug? I need more data and experimentation but wanted to get this out for others to look at. I'm possibly losing soul gems on capture due to distant. Shot and killed an Elk with Bow enchanted with soul trap at a pretty good distance from me. On checking my inventory I lost a empty petty soul gem and did not have a filled petty soul gem. Again I need to do more experiements on this. Appreciate any observations.
-FFH
H2O Feb 17, 2012 @ 8:28am 
Yes, I was referring to the thunderclap and purple energy bolts. It was a lot of fun. If you can get it back, that would be great. But like FreshFromHell says, the info is the important thing.
FreshFromHell Feb 16, 2012 @ 7:44pm 
@H2O and Anonomouscoder, Yes I lost the Soul Capture animation also. But if it can't be fixed i won't be complaining. I'd rather have the info then the sound/flash. Thanks for the Mod Anonomouscoder.
anonomouscoder  [author] Feb 16, 2012 @ 4:29pm 
@H2O:what do you mean by soulstealing animation? the purple-ish lines coming out of an enemy after you soul trapped it? cause actually im seeing that too. thanks for pointing it out. I disabled my mod and as you say, the animation comes back; but for me the soul stealing still works...i'll look into this some more.
anonomouscoder  [author] Feb 16, 2012 @ 3:55pm 
@chris:keep trying, i just made sure that it works. like i said before i think they implemented some kind of failure % that they dont show the player? i dont know? Also, i find it hard to hit with the soul trap, as it has a small range, just my preference though
chris Feb 16, 2012 @ 3:23pm 
I haven't seen the message at all since installing this mod. I'm using the Soul Trap spell, rather than an enchanted weapon, in case that has anything to do with it.
H2O Feb 15, 2012 @ 9:59pm 
I have a problem with the soul-stealing animation not working. I tried unsubscribing, but that broke soul-stealing completly. I resubscribed, and stealing works again, but still no animations. Anyone else have the same issue?
anonomouscoder  [author] Feb 15, 2012 @ 7:12pm 
@Pheonixforce: as for the other mod, I'm sorry. There's not much I can do to cope with that mod, seeing as how he completely overhauls the soul-capturing system. You could ask him to implement my changes, I'll help him if he needs it (i doubt he will need any though)
anonomouscoder  [author] Feb 15, 2012 @ 7:09pm 
@Pheonixforce: I think I see something weird? I'm using a knife enchanted with soul trap and sometimes it doesn't seem to register or something so I'll kill something with it, have ample soul gems, and no message is displayed. Sometimes it does work however: I just captured a common soul in a grand soul gem. If this is happening to you and you are using a spell, or the staff or something else please tell me and I'll try to recreate it more accurately. I think it's just either not activating in time for some reason, or they actually resist it and its not being shown.
anonomouscoder  [author] Feb 15, 2012 @ 4:39pm 
@Pheonixforce: thanks for the info, i'll look into both issues.
Pheonixforce Feb 15, 2012 @ 2:26pm 
No idea why but this mod was making it so i couldnt capture (ex.) petty souls in lesser gems. i could not capture a soul in any gem other than the one it was intended for. Plus, it makes the soul forge mod glitch.
The Grand Marmot Feb 14, 2012 @ 12:02pm 
Yeah it works for me now! Who hoo I captured a lesser soul!

Just one minor recommendation... I think it might look better if it just said "Lesser soul captured!" - simple and concise. Or of course "Lesser soul captured in Common gem!" would be even better!
Blackheart Feb 14, 2012 @ 12:38am 
DUDE!!! THANK YOU SOOOOOO EFFFIN MUCH!!! I always thought this is the way it should be so I wouldn't have to keep track what creep gave me what type.
anonomouscoder  [author] Feb 13, 2012 @ 6:19pm 
XD thanks Chesko
Chesko Feb 13, 2012 @ 6:17pm 
I can confirm that the latest version of this mod works as intended. The issue stemmed from a bug where modified script files with the same name as original game script files will not load from an uploaded .BSA file. Now that the author has changed the name of the script (and edited the Soul Trap spell to point at the new script instead), it works like a boss.
skowron Feb 13, 2012 @ 6:14pm 
@anonomouscoder: Thanks!
anonomouscoder  [author] Feb 13, 2012 @ 6:07pm 
[Papyrus]
fPostLoadUpdateTimeMS=500.0
bEnableLogging=1
bEnableTrace=1
bLoadDebugInformation=1
skowron Feb 13, 2012 @ 5:59pm 
@anonomouscoder: Unfortunately I don’t have these values in my “Skyrim.ini” file at all. I need to add them manually. Could you give me the title of the heading under which they should be placed?
anonomouscoder  [author] Feb 13, 2012 @ 5:30pm 
@Aust [FuG]" Thanks. It does help a lot!
Dainyl Feb 13, 2012 @ 5:12pm 
After a little testing I discovered the following:
1.) Using the mod as it was installed removes the "Soul Captured!" message and nothing more.
2.) Extracting the script from the .bsa and disabling the mod shows both "Soul Captured!" and your message.
3.) Extracting the script and leaving the mod enabled hides the "Soul Captured!" message and shows your message (i.e. working as intended)

Hope this helps.
anonomouscoder  [author] Feb 13, 2012 @ 4:17pm 
@pazoozoo:In order to enable debug messages: go to your Skyrim.ini file (mine was in /Documents/My Games/Skyrim ) and scroll down to near the bottom and change these 3 values to 1: bEnableLogging, bEnableTrace, bLoadDebugInformation. After that if you start up skyrim and after you see the issue go to the same directory but look in /Logs/Script and you should see files labeled: Papyrus.#.log where # is a number 0-3 denoting the history of the log file (0 is newest 3 is oldest).
toxwenius Feb 13, 2012 @ 12:33pm 
does anyone had this mod working?? Everyone seems to say it doesnt work. Ill try it now and report back later :-)
burghler Feb 13, 2012 @ 2:11am 
It's not working for me either; TBH I have so many mods that a conflict seems likely, but I have no idea which one. I don't have anything else that affects soul capturing though
skowron Feb 13, 2012 @ 12:43am 
Sorry for a lame question but how I can turn debug messeges (or debug.trace logs) on?
Dr.SaladFingerz Feb 13, 2012 @ 12:06am 
not working so down vote ;)
anonomouscoder  [author] Feb 12, 2012 @ 8:10pm 
@Pheral:I run SkyUI as well...doesn't seem to affect me...
anonomouscoder  [author] Feb 12, 2012 @ 8:09pm 
@The Grand Marmot: you shouldn't have to do anything like that...my guess is the mod didnt load correctly, do you have any other mods that affect soul capturing stuff? or anything that might affect the audio/visual effects of spells? if you could turn on debug.trace logs and post some of it i could help out a lot more.
Pheral Feb 12, 2012 @ 8:06pm 
It doesn't seem to working for me either. It could be a conflict, I'm running SkyUI as well as Skyrim Script Extender (other mods as well but those are the most likely ones to cause problems). Great idea for a mod though, exactly what I was looking for.
The Grand Marmot Feb 12, 2012 @ 6:14pm 
This doesn't appear to be working for me; I double-checked that it was checked to load in the launcher, and cast soul trap on a cave bear, a normal bear, a draugr wight, and a skeleton and was careful to watch the pop-up text and never saw anything but "soul captured". Is there something else I need to do to get it to work? Maybe I should drop all my soul gems and pick them up or get some new ones or something?
BioHazard Feb 12, 2012 @ 5:35pm 
@shit hawk: thats the mod I really want to see. I miss being able to keep a soul as a souvenir. In morrowind I had a collection of unique souls.
anonomouscoder  [author] Feb 12, 2012 @ 4:01pm 
@shit hawk:I don't think thats possible, souls dont seem to be attached to the creature (so it could be impossible to rename the soul gem upon capture), rather its just a straight actor level to soul level fix. Maybe it is possible and I'm not editing the right file yet...I'll look into it
Wednesday's Child Feb 12, 2012 @ 3:49pm 
I would rather see the soul type before the fact, perhaps next to the enemy's name on its health bar. I should know by now what animals are what, but, in the excitement of battle I either forget or forget to look. Seeing you have just captured a _ soul is rather like seeing a street sign saying you have just hit a speed bump: Informative, but nothing you can do about it. Thinking along the right lines, though.