achilles2k Jul 16, 2013 @ 4:35am
Max Payne 3 is not running after "Preparing to Launch..."
First of all, for those of you who has this problem before with a frozen screen saying "Initialising...", basically you have to log in to Social Club and that is it..

The problem I have is something else.. I have been playing the game for a couple of weeks now. One day, I quit the game and a couple of hours later, I wanted to open again.

For some reason, the icon pops out on the dock and disappears at the same, and then the game sync with Steam Client and that is it. I have tried everything! Deleted the game and installed it again, deleted Steam and installed it again, verified the cache and all other stuff. But it is not working!!

I have sent an inquiry to Steam Support but these amateur people couldn't even reply to me. It has been 10 days!! I requested a refund but still no reply. This is very disappointing, I wasn't expecting to see this kind of a amateur behaviour from Steam.

Nevertheless, if there is anyone here who can help me about the issue I would be so grateful.

Thank You.
Last edited by achilles2k; Jul 16, 2013 @ 9:02am
Showing 1-15 of 17 comments
< >
Cgeorge13 Jul 16, 2013 @ 6:04am 
I just spent 12 hours installing the game and now it won't launch. When I click the Play button, the screen sort of flashes and goes right back to the Steam window, and when I look at my dock, there isn't a Icon for Max Payne 3.
achilles2k Jul 16, 2013 @ 9:01am 
You are lucky m8, my screen doesn't even give any kind of flash or something.. I just see the icon on the dock and in the next second it is gone! After telling to these Steam amateurs beforehand that I have done all the necessary steps to fix the game, they've sent me the same e-mail exactly on the website. This is miserable for this company I can say that..
anathem Jul 16, 2013 @ 1:06pm 
Have the same problem! Any solutions?
MegaJames Jul 16, 2013 @ 3:46pm 
Same problem here. I'm running Lion.

First game I've purchased on steam and will definitely be the last if I can't find a solution.
Sylar Jul 16, 2013 @ 4:21pm 
Download a launch file from the internet and replace it wth the steam one! injoy
anathem Jul 16, 2013 @ 11:06pm 
Hah... it would be better to download the whole game :D It is steam last update problem — we need to wait new update of steam or find in internet previous version of steam, install and do not update it :)
xtycjd44 Jul 17, 2013 @ 12:02am 
gg
without"Toil" Jul 17, 2013 @ 2:10am 
Report this lack of concern and respect to nswombo@ombo.nsw.gov.au
Shadow Yuk Jul 17, 2013 @ 2:35am 
Same problem.
Just wait for the new update
yairw Jul 17, 2013 @ 3:33am 
I'm having the same issue and steam support isn't helping very dissapointing.
achilles2k Jul 17, 2013 @ 12:35pm 
I just downloaded the new update.. the problem still exists.. these people don't wanna fix this problem I guess!!
Dr. Horrible Jul 21, 2013 @ 11:45am 
does anyone know how or when this problem is gunna be fixed? This is ♥♥♥♥ing ridiculous >_<
MegaJames Jul 23, 2013 @ 6:23pm 
Update worked for me. It ran the entire intro in scaled up 800x600 resolution but it worked. Although I tried to mess around with the graphics settings, and when it restarted to initialize it got stuck on that screen for like 10 mintues so I quit. Now the icon shows up on the dock but nothing else happens. I guess that's an improvement at least?
Last edited by MegaJames; Jul 23, 2013 @ 6:23pm
achilles2k Jul 24, 2013 @ 3:06am 
Yeah, the new update worked for me as well guys.. I think they mananged to nail it this time :)
MegaJames Jul 24, 2013 @ 3:06pm 
Hm, mine fails to start now. I tried reinstalling but no luck. Icon in the dock but no Max Payne goodness.
Last edited by MegaJames; Jul 24, 2013 @ 3:06pm
Showing 1-15 of 17 comments
< >
Per page: 15 30 50
Date Posted: Jul 16, 2013 @ 4:35am
Posts: 17