Vaiels Jun 7, 2013 @ 10:53pm
Crashes
My client always crashes on startup, anyone else having this problem?
Showing 1-7 of 7 comments
< >
SUPAPLEX.ME Jun 8, 2013 @ 2:21am 
Same for me. If i'm trash library/application support/steam folder, then steam launches, but till first reboot.
Vaan_ Jun 12, 2013 @ 2:28pm 
Same thing, and it started same day as you. That was 4 days ago, I've still no reply to my ticket either. I've downloaded the game twice & restored it from a backup (that works) as well. In addition, since I have 2 computers & 2 steam accounts, I already HAD a working copy of SR3 on BOTH computers, so its nothing I did at my end - the problem is STEAM.
CreeperSweeper Jun 12, 2013 @ 4:13pm 
Same problem on an iMac running 10.8. Here's my log file after a attempted launch:

DebugAssert, Name: ?, Line: 3712, Expr: "Create semaphore failed in CreateSemaphoreInternal" && !pchErr, File: /Users/buildbot/buildslave_steam/steam2_rel_beta_osx/build/Projects/GazelleProto/Client/Engine/../../../Common/Misc/PosixWin32.cpp


DebugAssert, Name: ?, Line: 3712, Expr: "Create semaphore failed in CreateSemaphoreInternal" && !pchErr, File: /Users/buildbot/buildslave_steam/steam2_rel_beta_osx/build/Projects/GazelleProto/Client/Engine/../../../Common/Misc/PosixWin32.cpp

CsComm Session Jun-12-2013 19:00:01.132 [2958618624] ReconnectThread (2958618624) Starting

DebugAssert, Name: ?, Line: 558, Expr: (ResetEvent(m_hSingleInstanceFlag)) != 0, File: /Users/buildbot/buildslave_steam/steam2_rel_beta_osx/build/Projects/GazelleProto/Client/Engine/Src/EngineClientManager.cpp


DebugAssert, Name: ?, Line: 4615, Expr: lReleaseCount >= 1, File: /Users/buildbot/buildslave_steam/steam2_rel_beta_osx/build/Projects/GazelleProto/Client/Engine/../../../Common/Misc/PosixWin32.cpp


DebugAssert, Name: ?, Line: 4624, Expr: pSem->m_pPThreadSem->m_cSem > 0, File: /Users/buildbot/buildslave_steam/steam2_rel_beta_osx/build/Projects/GazelleProto/Client/Engine/../../../Common/Misc/PosixWin32.cpp

CsComm Session Jun-12-2013 19:00:01.317 [2958618624] ReconnectThread (2958618624) Told to exit
Vaiels Aug 21, 2013 @ 4:40am 
Originally posted by Fortunate:
I had this problem too, lot of people told me to download an extra dll. file (sorry can't remember the name) but it didn't work for me. However there was this smart guy who did know the right answer:
Go to your hardrive, go to: users > (your name) > AppData > Local > PAYDAY 2.
There is a file named 'renderer_settings.xml' , delete that file.
Then just run Payday 2 and it works, at least for me it worked.
Hoped it helped.
I think you're in the wrong thread mate
Nitehawk Oct 17, 2013 @ 7:27pm 
Started doing it to me today in Win7 whenever I try to update or install a game.
fahad_m7md97 Feb 17 @ 4:29pm 
I have found the solution!!! I have the exact same problem, my steam works fine but the moment i click anywhere on my Library, it completely becomes unresponsive and crashes...

Fortunately i have found solution today with only 3 simple steps!

1) Open an application called "Run"
2) Type "steam://flushconfig" , it will load up steam clinic and a message will appear, click "ok".
3) After clicking "Ok", steam login will appear, DO NOT LOGIN, simply restart your PC/laptop!

And Voala! Steam is perfectly Stable and running just like new for me! 8D
Hope this helped!
Enjoy :D
aassdfghjkl Feb 18 @ 1:42am 
try to re-download
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Jun 7, 2013 @ 10:53pm
Posts: 7