neogeo May 19, 2013 @ 8:41am
Problems with Steam on iMac 2011 with Mac OS 10.8.3
Hi,

i've purchased the retail version of Portal 2 and already had problems with installing from the CD. 3 weeks ago I downloaded the steam for mac client from the steam site and first time it ran ok. I could go to My Games,download Portal 2 and even play it for a while. But the 2nd time I tried running it again I came as far as running steam, entering my password and once the small "connecting with steamaccount ...." it crashes and I have to force quit.

After numerous tries i gave up. Today I tried again and ran into the same problems as described above.

I couldn't find any solution on the net, that would help me so I sent a ticket to the hotline.

Can the community help in the meantime while I am waiting? Any tips?

Thanks and greets from Germany!
Neo
Showing 1-2 of 2 comments
< >
ian.adkins May 19, 2013 @ 11:53pm 
same issue here in Australia... with Civ 5
neogeo May 21, 2013 @ 3:51pm 
I've found a SOLUTION!!!!!! At least this is how I finally got Portal to run on my Mac.

First: Support answered within 24hrs. Even though they came up with an advise, which can be found with a simple search on the net as well (deleting all but /Steamapps and /Userdata in the Users/[username]/Library/Application Support/Steam directory and then re-start) and what I already tried with no success, they answered quite swiftly. And that's what counts first. So I am fine with the reaction time of the support so far (it must be mentioned I sent them my support query on a sunday!!!) though the answer was not that helpful ...

so what happened that i finally got to play Portal?

Well, after having received the email from support this morning, I thought, so what, give it another try
So I deleted all files accordingly, shut down the mac, rebootet, started the client, entered my pw and ......? Nothing happens. ♥♥♥♥. A check in the activities after a minute or so confirmed "steam.app not reacting"... Aargh!
Anyway I was busy doing other stuff on my Mac and forgot that I started the client and didn't (force)quit it.

Guess what: no earlier then ca. 17 minutes after I started the steam client all of a sudden it popped up out of nowhere, perfectly running.

How do I know it's about 17 minutes? Because I tried it a couple of times and measured how long it took until the Steamclient would finally run.

So to all of those out there having the same problem (Steamclient not starting on their macs and behaving like it crashed): Just keep waiting like for 15 - 20 minutes and consider it loading time .... :D

Btw, it takes about 10 min to start Portal 2 then from my Steam games library...

I've informed the support about this and hope they'll be able to help me from here.

Last edited by neogeo; May 21, 2013 @ 3:58pm
Showing 1-2 of 2 comments
< >
Per page: 15 30 50
Date Posted: May 19, 2013 @ 8:41am
Posts: 2