Evil Lemons Feb 25, 2014 @ 4:25pm
Low framerate, good PC - Help
I have a pretty good laptop here:

GPU: NVIDIA GeForce GTX 765M, 2.00 GB vRAM
CPU: Intel(R) Core(TM) i7-4700HQ CPU @ 2.40GHz (For some reason, I get 3.19GHz...)
Memory: 12.00 GB RAM (11.92 GB usable)
Resolution: 1920 x 1080, 60Hz, 1280 x 1024, 40Hz (Two monitors)
OS: Windows 8.1

For a while, everything worked out fine. That means 35-50 FPS in Skyrim ultra graphics. But lately, everything slowed down; 15-25 FPS. It is happening in multiple games, and I don't know what to do. I even got a PC cleanup tool.

Thank you SO MUCH in advance for your knowledge.
Showing 1-9 of 9 comments
< >
Mr. Hankey (Banned) Feb 25, 2014 @ 4:31pm 
It's probably using Intel HD graphics instead of the 765m.
Evil Lemons Feb 25, 2014 @ 5:29pm 
Do Intel computers come with the Intel HD graphics cards, along with others you bought?
Rove Feb 25, 2014 @ 5:39pm 
Almost all Intel CPUs have integrated Intel HD graphics of some sort or another.
Evil Lemons Feb 25, 2014 @ 5:43pm 
Thanks for the reply, and is there a way to disable it?
_I_ Feb 25, 2014 @ 7:41pm 
it cannot be disabled, the geforce card writes to the intel igp frame buffer to be displayed

you need to use optimous to tell it to use the nvidia card for the games
or set windows power saving to performance and keep it plugged in
Last edited by _I_; Feb 25, 2014 @ 7:41pm
DeadPhoenix Feb 26, 2014 @ 3:57am 
open Nvidia Control panel and force Nvidia as main GPU. this should fix the issue :)
Bad-Motha Feb 26, 2014 @ 6:27am 
Originally posted by DeadPhoenix:
open Nvidia Control panel and force Nvidia as main GPU. this should fix the issue :)

^This

Open NVIDIA CP, go to Manage 3D Setting. Set "NVIDIA GPU" as the preferred default one.
Also in the Global Settings, set the Power Management to "Prefer Max Performance". Be sure to apply your changes. You can always revert back if needed, or for testing, etc.
rad87gn Feb 26, 2014 @ 9:27am 
Try running heavy games in 1368x768 resolution instead of 1920x1080. Your laptop with that video card may struggle running 1080p with the high end games.
Evil Lemons Feb 26, 2014 @ 1:22pm 
Thanks everyone for the replies. My PC only detects my NVIDIA graphis card, and I have everything set accordingly. In all, it kind of worked.
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Feb 25, 2014 @ 4:25pm
Posts: 9