Toebus Jun 22, 2013 @ 9:26am
Windows 8: Fatal error could not load module 'bin/vgui2_s.dll'
Steam will not start and I receive the error in the subject.

Things I've tried:
-Checked the /bin folder, the vgui2_s.dll is in there
-Deleted ClientRegistry.blob and restarted steam
-Uninstall and reinstall steam
-Delete any steam registry keys, uninstall reinstall steam
-Run repair option of steam install
-Check registry keys to see if they are pointing to the wrong directory, doesn't seem to be the case.
-System restore to an earlier date

Nothing has worked.

Running out of options here. I've had no hardware changes and no software changes other than regular windows updates. Everything else on the PC is running fine. Steam ran fine up until a few days ago. I really don't want to reinstall the whole system just to get steam working.

Any help would be great. Thanks.
Showing 1-15 of 30 comments
< >
Toebus Jun 22, 2013 @ 12:57pm 
Bump
EKO Jun 23, 2013 @ 6:35pm 
Found a solution; delete your vgui2_s.dll that's in the bin folder. Copy it just in case.
Though, it makes an entirely new one and launches steam immediately. I was so scared haha though it worked perfect!
Toebus Jun 23, 2013 @ 9:00pm 
Thanks, good to know. Got so frustrated that I just restored my system.
Moar Jul 9, 2013 @ 9:47am 
thanks man i had same problem and now it works
Wilhelm Jul 9, 2013 @ 1:48pm 
Tx! It worked perfectly (I was scared too).
henryg Jul 9, 2013 @ 3:44pm 
Do any of you use AVG or Avast anti-virus software?
Sandman Jul 11, 2013 @ 1:20am 
yep thanks soundeko. STEAM SUCKS
jenz Jul 11, 2013 @ 3:48am 
thanks alot soundeko your tip worked, and yes henryg i use AVG
Abraheliel Jul 11, 2013 @ 9:44am 
GODDD , MAN you are the best TY i was looking some fix but nothing , was scaring delete the vgui2_s.dll file XD
Mistress Kitten Jul 11, 2013 @ 11:38am 
For anybody else facing this same issue:
This occurrence is not limited to Windows 8 operating systems.
I'm currently operating off of a Windows Vista (Do not recommend) and the error is the same.
Luckily, the solution is the same.
Just go to C:\Program Files (x86)\Steam\bin to find the file named "vgui2_s.dll"
After that, you should copy the file (ctrl+c) and then delete it.
After deleting it, try to run Steam again.
This should allow you to run Steam once more.
If steam doesn't start running again then paste the file (ctrl+v) back to where it was.
Shade Jul 12, 2013 @ 3:19am 
Ty worked for me too!
CronoGamer Jul 12, 2013 @ 4:47am 
SoundEko, thanks a ton! Worked perfectly for me.
F-16 Jul 12, 2013 @ 8:39am 
...suspect Microsoft's recent updates created this problem for me....also use AVG....thanks Soundeko...worked!
[CBG] Bloodwars59 Jul 12, 2013 @ 8:41pm 
I did the suggestion in the comments, deleting the file in the bin folder. It works PERFECTLY. Started up as usual, though it took slightly longer on the "Connecting to steam account: ..."
Tyrannosaurus Jet™ Jul 13, 2013 @ 12:43pm 
tnx to toebus and eko! for the post and solution, got that message today, afraid of need to reinstall everything, works like a charm, you save my life.
Showing 1-15 of 30 comments
< >
Per page: 15 30 50
Date Posted: Jun 22, 2013 @ 9:26am
Posts: 30