mr.dynamite Mar 26, 2013 @ 12:25pm
Bioshock Infinite Keeps freezing: need help
I pre-purchased Bioshock Infinite and my comp. has all the required specs and it started up just fine but after a few min it stops and i have to force quit out of the porgram, any suggestions?
Showing 1-8 of 8 comments
< >
Mikruella Mar 26, 2013 @ 5:59pm 
Yeah, I'm having almost the same problem. The thing is: sometimes it opens, sometimes it doesn't. It doesn't matter what I do, it opens only when it wants to, aparently. AND when it works, it ALWAYS freezes at the same scene. I managed to play for 2h more or less, and when I'm fighting some crow guy it always freezes when I'm almost killing him. Then I force it shut and it doesn't work again for a long time. It's ♥♥♥♥ing me off, I've waited for this game for a long time and when I finally get it, it crashes all the time, and it doesn't even open most of the times. My note is not that good, it doesn't run anything in very high quality, but it has the minimum specs, it should run at low quality at the very least.
Set Mar 26, 2013 @ 8:48pm 
It seems to happen mostly with i7 cpus+ high end video cards. I have been past the crow guy and have played for about 2 hours with no problems.

intel e8500 3.16 ghz dual core cpu
nvidia geforce 9800gtx+ 512 mb video card
4 gigs ram
windows 8

Is there a way to turn off AA, physx and stuff ?
Last edited by Set; Mar 26, 2013 @ 8:48pm
SN8KEDR Mar 27, 2013 @ 3:28am 
Hiya - I am having the same issues (freezing after 4-10minutes of gameplay). I have started a thread at irrational games which has yielded some suggestions. I also started my own discussion here too, which again has a number of suggestions but nothing that has worked for me as yet.
You might be lucky and one of these may work for you.

1. It could be something to do with the UE3 engine. Apparently tinkering with the PoolSize in xGame.ini file can help with stuttering and possible freezing issues.
Here;s the link to the thread JaseC's thread: http://www.neogaf.com/forum/showthread.php?t=529440
2. Check you have the lates Catalyst or Nvidia drivers (if you do I recommend rolling back and trying the game, if still no joy reinstall the latest drivers again)
3. In your steam library right click on the game in your library and select the Properties option, then under the Local Files tab select the 'VERIFYING INTEGRITY OF GAME CACHE'. This takes a minute or so to run and complete. I'm not sure if this is what triggered a small 8mb download for the game via Steam but I just checked and whatever it was updated my game files.

So far none of this has worked for me but like I said, you might be one of the lucky ones that one of these (or all) options will work for. Can't hurt giving it a shot.

If you wanna take a look at the irrational games thread to stay updated here is the link:
http://forums.2kgames.com/showthread.php?220551-Bioshock-Infinite-keeps-freezing-after-4-5-minutes-of-gameplay&p=2853896#post2853896

Good luck!
Mikruella Mar 27, 2013 @ 8:11am 
Sn8kedr, thank you! Unfortunatelly, none of this worked. I hope it works for other people though :)

Set, thank you! But I can't even open it anymore :( Tried several times this morning and nothing.
RonMcDon Mar 27, 2013 @ 11:29am 
I've been having the same issues. I tried all recommended fixes on the forums but none of them seemed to fix my issue.

What I did notice tho is every time it crashed it appeared that Steam was attempting to update the Bioshock Infinite game.

I turned off automatic updating for the game and low and behold that seems to have fixed it for me. Just played for 2 hours straight without any more issues.

Give it a go and let me know if it helps you guys too.
Mikruella Mar 28, 2013 @ 9:58am 
Well, here it didn't have this same problem with the update, but thanks :D

After all my attempts to make it work, I just gave up and just kept trying to open it sometimes cuz hope dies last. So last night it worked out of the blue AND the game finally didn't crash with the Crow Guy, I managed to play for hours. But today it won't open again, lol. I guess my note is experiencing some PMS.
aLfaNerd Mar 28, 2013 @ 11:08am 
I have the same problem. Will try all recommended hope one of them work. I tried noting is worked :(
Last edited by aLfaNerd; Mar 28, 2013 @ 12:45pm
yuvl32 Dec 10, 2013 @ 11:05pm 
I've had the exact same issue, freezing in the first minutes of the game, then I've switched from full-screen to full-screen window in graphic settings, that worked for me, played a few hours without problems since then.
PS. I know this is old thread, but I didn't found this solution on Google and figured somebody else could bump in this problem...
Last edited by yuvl32; Dec 10, 2013 @ 11:07pm
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Mar 26, 2013 @ 12:25pm
Posts: 8