[遊戲.浪人.奇異果]@ART Feb 16, 2013 @ 10:39pm
For someone who get endless "Extracting package..." @ steam client updater.
I am mad for the hell "Extracting package...", so i did this with a little complicated method. you don't have to follow all of this. Maybe you just need step 3. (My OS is Win7 x64.)

  • 1. Check or disable OS firewall. (on my PC, steam client try to connect some IP that i blocked.)
  • 2. Make sure Steam.exe is not running. (If you can't kill it, try to disable Steam client [Auto-start with OS] and reboot OS. For my case, i just delete [Steam]@[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run] in Windows Registry to disable the auto-start of Steam.)
  • 3. Negative to [%ProgramFiles(x86)%\Steam\], rename files and directories to backup:
    • rename file [debug.log] to [debug.Backup01.log]
    • rename file [steam.log] to [steam.Backup01.log]
    • rename file [ClientRegistry.blob] to [ClientRegistry.Backup01.blob]
    • rename file [AppUpdateStats.blob] to [AppUpdateStats.Backup01.blob]
    • rename directory [config] to [config.Backup01]
    • rename directory [package] to [package.Backup01]
    • rename directory [logs] to [logs.Backup01]
    (Some files come when i run steam with "-developer -console", so your PC may miss some files. Why i rename some directories is because i find some file IO error msg in steam log and I AM MAD!)
  • 4. Run ["%ProgramFiles(x86)%\Steam\Steam.exe" -language "english" -developer -console -fs_log -fs_logbins] in windows' Cmd as Admin. (I AM MAD, so i use all that i think may help...)
  • 5. After Steam updater download finish, "Extracting package..." just run a little time, and than i see the login screen, finally...


p.s.
  • Sry for my bad english~
  • if you tried running Steam.exe with the opt[-developer -console] and Steam still not work fine,you can check log files to see if Steam logs some Error msg:
    • file [debug.log]
    • file [steam.log]
    • files in directory [logs]
    In my case, i find this in my [debug.log]:
    [0217/044746:ERROR:backend_impl.cc(2123)] Corrupt Index file
    [0217/044746:ERROR:cache_util_win.cc(48)] Unable to move the cache: 5
    [0217/044746:ERROR:backend_impl.cc(134)] Unable to move cache folder
    [0217/044746:ERROR:backend_impl.cc(264)] Unable to create cache
Last edited by [遊戲.浪人.奇異果]@ART; Feb 18, 2013 @ 2:49am
Showing 1-1 of 1 comments
< >
KaRaTe.^ Mar 10, 2013 @ 12:19pm 
Nu inteleg ce trebuie sa fac ma poate ajuta cineva va rog?
Showing 1-1 of 1 comments
< >
Per page: 15 30 50
Date Posted: Feb 16, 2013 @ 10:39pm
Posts: 1