Vincent Dec 14, 2012 @ 1:11pm
[How To] Fix Low-Res Textures/Graphics Problem
EDIT:
Thanks to y4n on page 2 for coming up with an easy fix.
A dx8 wrapper where all you have to do is download it and place it along your RRT3 .exe in the RRT3 folder.
No restarting your pc or anything.
Thanks again y4n!

Download Link:
http://depositfiles.com/files/w6b7zylvt
Alternate Link:
http://www.gamefront.com/files/23629348/RT3-texture_fix.zip
Hawk & Badger Link
http://hawkdawg.com/rrt/rrt3/rrt3.htm

Hello.
I had posted this on the Steam forums awhile back, but since it's far less likely for anyone to come across those, now with the Game Hubs up, I thought I'd repost here.

RRT3 has an issue with most modern computers that causes the graphics in game to turn up being much lower-res than they were originally.
Many people have searched in the past for a fix, myself included.

Luckily I had come across an answer, although it would probably be considered more of a work around, it's still not too difficult to do.

For some reason RRT3 doesn't seem to like large amounts of RAM, not sure why.
But reducing the RAM on your system will fix the issue.
Of course you don't have to start ripping hardware from your computer to get this to work, fortunately there's a much easier way.

=====
Solution:
-On your task-bar click the 'Start' button, which may also appear as the 'Windows' symbol, depending on your operating system.

-In the search area, there should be a box you can type in;
type msconfig and hit enter. (msconfig) <- For clarity, without the brackets.

-A box should pop up with the heading 'System Configuration'
Beneath the heading should be several tabs; click the one that reads 'Boot'

-On this tab should be a button which reads 'Advanced options...' Click it.
A new box will pop up with the heading 'BOOT Advanced Options'

-There will be a number of tick boxes with titles, tick the one that reads 'Maximum memory'
Then proceed to enter the numbers 2048. This means 2GB RAM, and limits your system to using this amount.

-Click OK on the BOOT Advanced Options box.
Then click Apply on the System Configuration box, followed by OK.

-A notification may pop-up asking you to restart.
You may restart at your leisure, but the change will not take affect until you reboot.

-At any time you wish to revert to your original settings, follow the above instructions, in the BOOT Advanced Options, untick the Maximum Memory box and reboot.
=====

Any systems with more than 2GB of RAM seem to cause the games graphics to set to low-res, no matter what the in-game settings are set to.
So far the above is the only solution I could find.

The required max RAM settings may differ from computer to computer. If you feel like playing around with it you could try 2.5 or 3 GB, but for me 2GB works.

Since this game is virtually a classic, and people still play it (and rightly should) I am re-posting this to make sure it is seen, hopefully this will allow more people to avoid the frustration I went through trying to get this issue resolved myself.

Vince
Last edited by Vincent; Aug 21, 2013 @ 9:33am
Showing 1-15 of 43 comments
< >
la_nague Dec 31, 2012 @ 3:54am 
how do i know my graphics are lowres?
Vincent Dec 31, 2012 @ 4:36am 
Here is what it looks like in low-res.
Low-Res[img221.imageshack.us]
And normally.
Normal[img20.imageshack.us]

One thing that you might also do to help you notice, is when loading your game (ie saved game) within the first few seconds zoom in to something, preferably a building or some trees;
if you're affected with the low-res issue, you'll be able to see the graphics drop, right before your eyes. The above solution fixes this.
Last edited by Vincent; Dec 31, 2012 @ 4:39am
la_nague Dec 31, 2012 @ 11:23am 
my game is fine usiing 8gb memory, i think your theory is off :p
Vincent Dec 31, 2012 @ 3:25pm 
I have 8GB as well, so maybe I'd consider you lucky.

The only changes I did when taking the above screenshots was changing the amount of RAM my computer was using.

This issue is real and affects at least a few people, so if you don't have the problem then no worries.
There's probably other things that affect whether people have this issue or not, but I do know that changing the amount of RAM fixes it.
So far this has worked on my old PC and my new PC, and for whoever it was I learned this trick from.

I didn't just randomly pull this out of my hat. When suffering this issue I searched for a very long period of time and eventually thought there was no hope in finding a solution.
I finally came across a very hard to find forum, where someone posted a solution similar to the one above.
I tried it and it actually worked.

Unfortunately I've lost the location of that forum, so I am unable to give this person due credit.
Last edited by Vincent; Dec 31, 2012 @ 3:29pm
MonsieurFreeze Jan 4, 2013 @ 10:18am 
Hi, I have the same problem, on my recent system (win7 64b with 12Go RAM) the texture switches to low res after few seconds but on my older pc (XP 32b 2Go RAM) I can keep the highier texture.
I don't want to limited the RAM available for my system just for this game specially that I already use more than 3Go when iddle...
Did someone think to another solution? Can I just replace the low res texture by the high res one?
Vincent Jan 4, 2013 @ 11:31am 
So far lowering the RAM your PC uses is the only way I've found to fix this.
I wish there was an easier way, I've searched everywhere, and was so glad just to find this one.

It can be a pain, changing RAM just for a single game, if I ever find an easier way I'll be sure you post it. But I wouldn't get my hopes up.

And when you say 'Can I just replace the low res texture by the high res one?' "
I'm not sure exactly what the games doing, but something causes it to automatically switch the games graphic settings to the lowest shortly after loading into the game.
It must be mis-reading pc hardware or something, I don't know.
It's almost like it doesn't understand high amounts of RAM, and when it detects high amounts it auto-switches to super low graphics. Like it thinks you have a bad computer, even though you don't.

That's just a shot in the dark, since I don't know really what's happening.
But again, I wish there was an easier way, I really do.
Basically the real inconvenience will be restarting your computer before and after playing RRT3 (when changing RAM in msconfig) if you want to have all your RAM enabled when you're not playing RRT3.
The Bytemaster Jan 6, 2013 @ 12:51am 
Is this on a 64-bit Windows? That could make a difference because the RAM window for 32-bit applications is 2 GB MAX on older versions (default anyway) and under 64-bit te 32-bit apps can see 4 GB of RAM.
Vincent Jan 6, 2013 @ 2:25pm 
Yes, this has always been happening on 64-bit Windows, all my PC's are 64-bit, I haven't tried it on 32, though I don't have a 32 to try it on.
werewolf1326 Jan 13, 2013 @ 4:03pm 
Set boot mem to 2048 or 8192 and the textures are low res on my RRT3. Same same 2Gb or 8Gb.

I'm running the game at 1600X1024 so maybe that res is too high for a game that came out almost 10 years ago.

Also using 64Bit Win 7 with an nVidia 560 with 2Gb onboard RAM.

Solution didn't work.
Vincent Jan 13, 2013 @ 5:35pm 
You have 8GB of RAM total?
I've noticed different results on different computers, but the only other suggestion I can come up with at the top of my head is to try lowering your RAM further, through msconfig.

Try 1024 or 1536. I noticed that I was able to get mine working at 2.5 Gigs, but I was sure my previous PC worked at 3.0.
I'm not sure why it wouldn't be working for you at 2GB.
To make sure it's not user error, did you make sure you restarted your PC after changing the max RAM in msconfig, and after restarting did you try going back into msconfig to make sure it saved your settings?
werewolf1326 Jan 13, 2013 @ 6:09pm 
Powered completely down and then back up. Opened boot options with MSCONFIG and it was still set to 2048. Right clicked on computer and selected properties. Showed 8Gb installed but only 2Gb available. Still low res textures.
Last edited by werewolf1326; Jan 13, 2013 @ 6:50pm
werewolf1326 Jan 13, 2013 @ 6:49pm 
OKAY...
Did some investigating myself. Vincent is right. There are two sets of textures. Like him I am convinced that RRT3 is using the low set. I've tried forcing Win 95, win 98 and XP SP2 compatibility on with no visible results.

That said some improvements can be made.

For an nVidia card override everything. Set FXAA on. Set anything that has a performance or quality setting to the highest quality. Set AA to the highest setting your board supports (mine goes all the way up to 32X CSAA. Set anisotropic filtering to max. No frame rate loss for me and some visible improvement in visual quality, not a lot but some.

YMMV...
Stick Jan 16, 2013 @ 1:37am 
Anyone try swapping the texture files?
Stick Jan 16, 2013 @ 4:17am 
After looking at this myself I see what you are talking about. I imagine that they meant to load the textures into high ram but the game code can not read above a certain limit. I guess that at the time they never expected we would have 16gig systems. :)

I do not see making a quick reboot after adjusting ram settings as a horrible thing. One can set it right back afterwards. So, appreciate you posting this here. I beleive its worth making the adjustment to use the thing.

However! This little application will limit the amount of ram any processs uses. You select which processes it limits. So , it could resolve the problem and work on the fly. When you want to RT3, you launch it first and have it set to limit RT3.exe to 2048K. Might work. I plan on testing it tomorrow.
http://www.kiwimonitor.com/kiwi_application_monitor.php

Last edited by Stick; Jan 16, 2013 @ 4:19am
Stick Jan 17, 2013 @ 12:45am 
I set ram to 2048 and upon launching RT3 I get a popup saying Failed to find Steam. Will try 4096 and report back.
Showing 1-15 of 43 comments
< >
Per page: 15 30 50