martin.redsupra Dec 22, 2012 @ 6:56am
Amnesia won't launch (Linux)
I've installed the beta of Steam and purchased Amnesia. Everything is fine until I go to play the game. An 'empty' window called Amnesia: The Dark Descent Launcher opens but then nothing happens. At all. No error messages either. I cannot close it without killing the process.

I've tried updating the video drivers but that hasn't helped.

Any ideas?
Showing 1-15 of 62 comments
< >
The Raccoon Dec 22, 2012 @ 8:56am 
delete it then install it again
shelter Dec 22, 2012 @ 11:13am 
I have the same problem.
OS - Xubuntu 12.04
Grundik Dec 22, 2012 @ 1:43pm 
Debian x64, same issue. Application just crashes:

$ ./Amnesia.bin64
Segmentation fault (core dumped)
...
Core was generated by `./Amnesia.bin64'.
Program terminated with signal 11, Segmentation fault.
#0 0x00000000006e82c0 in cLuxPreMenu::cLuxPreMenu() ()
(gdb) backtrace
#0 0x00000000006e82c0 in cLuxPreMenu::cLuxPreMenu() ()
#1 0x00000000007d89fb in cLuxBase::InitGame() ()
#2 0x00000000007dc664 in cLuxBase::Init(std::string const&) ()
#3 0x000000000068d960 in hplMain(std::string const&) ()
#4 0x000000000091b889 in main ()
us Dec 22, 2012 @ 2:16pm 
Hi.
I'm having the same Problem.
My solution:
I'm starting the script "run_steam.sh" from "~/Steam/SteamApps/common/Amnesia The Dark Descent". The games run fine.

Have fun
Last edited by us; Dec 22, 2012 @ 2:16pm
Grundik Dec 22, 2012 @ 2:37pm 
Doesn't work for me
Grundik Dec 22, 2012 @ 2:44pm 
Windows version runs fine with wine.
mashdar Dec 22, 2012 @ 8:59pm 
Originally posted by us:
"run_steam.sh" from "~/Steam/SteamApps/common/Amnesia The Dark Descent"
Was having the same problem. This works for me!
For reference, I'm on Ubuntu 12.04 on a Llano A4-3300M laptop. Tried with default Ubuntu fglrx and 12.10 fglrx. Both had the "empty window" crash.
shelter Dec 22, 2012 @ 10:40pm 
Originally posted by us:
I'm starting the script "run_steam.sh" from "~/Steam/SteamApps/common/Amnesia The Dark Descent". The games run fine.
It's works, thanks !
nydde Dec 23, 2012 @ 1:17am 
same here, run_steam.sh works
martin.redsupra Dec 23, 2012 @ 2:50am 
run_steam.sh working for me too. Thank you 'us' for the solution. Shame I took the first option and reinstalled before that.
martin.redsupra Dec 23, 2012 @ 6:38am 
Disabling 'Enable Steam community in-game' option fixes this too.
Grundik Dec 23, 2012 @ 12:26pm 
No, does not work for me. Both x32 and x64 versions crashes with same backtrace, no matter what.
Grundik Dec 23, 2012 @ 12:39pm 
Problem solved by switching game language hither and thither in launcher.
mashdar Dec 23, 2012 @ 12:50pm 
Grundrik, were you actually getting to the launcher? The rest of us were not even getting that far; an empty window would appear when we clicked "play" from Steam.

One issue with run_steam.sh is that it does not count play time in the Steam interface, if you care about that. Will try disabling community in-game later to confirm.
Grundik Dec 23, 2012 @ 1:06pm 
As I shown before in backtrace, in my case game was crashing in amnesia.bin[64] binary, after clicking "play" in launcher. Or by manually executing game binary.

Now game runs fine, seems like game settings were somewhat broken.

So, there is some different bugs.
Showing 1-15 of 62 comments
< >
Per page: 15 30 50
Date Posted: Dec 22, 2012 @ 6:56am
Posts: 62