Left 4 Dead 2

Left 4 Dead 2

View Stats:
skully Jul 2, 2013 @ 3:41pm
Failed to create OpenGL device!
Hi,after the last patch i have L4D2 out of beta,when i try to lauch i received an error
"Failed to create OpenGL device!"
I have an ATI 4730 HD and with the beta i dont have any problem,sorry for my english,hope valve resolve this problem
< >
Showing 1-15 of 36 comments
doktorseven Jul 2, 2013 @ 5:42pm 
Same problem here, I ran the beta L4D2 yesterday and it worked just fine.
skully Jul 3, 2013 @ 2:44am 
Now i have 2 beta of L4D2
L4D2 (beta) "This is the stable version that change"
L4D2 beta
I try to launch the (beta) but same error again
jonasan Jul 4, 2013 @ 11:21am 
same error here - old Beta works fine - as well as all other source games i have - but (Beta) fails to load and give the "Failed to create OpenGL device!" error. Strange huh?!

I've logged the error on steam support and waiting for reply. For sure Valve will have this fixed up soon - then we can all join the masses on the L4D2 servers!
Ernesto Jul 4, 2013 @ 3:36pm 
Another here. LFD2 do not work, i use Ubuntu 12.04, ATI Radeon HD5670
doktorseven Jul 4, 2013 @ 7:07pm 
Just to push the issue, I can confirm what someone else reported -- that other Source games still work just fine, and the old beta still works fine. It is ONLY the new (Beta) L4D2 game that gives me this "Failed to create OpenGL device!" issue.

Hopefully we'll get a fix soon.
Last edited by doktorseven; Jul 4, 2013 @ 7:07pm
Mr. PunKMaN Jul 4, 2013 @ 7:28pm 
Same here ati 4250 hd
jonasan Jul 5, 2013 @ 2:13am 
bumping this in case it speeds up the fix!
anyone else who has this problem please post...
wonder how many people are installing the new 'finished' linux version of l4d2 on the free promotional weekend and finding this problem.... hopefully not too many... really want this to be a success for valve and the future of gaming on linux.
Same problem here, the old beta worked fine as well. ATI Mobility Radeon HD 4650 Graphics Card running the AMD Drivers. Ubuntu 12.04.02 if it matters.
Last edited by Jek Nkik the Jawa; Jul 5, 2013 @ 10:59am
Richie442 Jul 5, 2013 @ 9:08am 
Same here. AMD ATI HD 3600
TheParadox116 Jul 5, 2013 @ 9:53am 
same here. AMD ATI Mobility HD 4270
Ernesto Jul 5, 2013 @ 10:39am 
jonasan Jul 5, 2013 @ 11:24am 
i wonder what could be causing this - its got to be something relatively simple i'm guessing - and it seems to be affecting plenty of people - come on valve stick someone on this bug!!
Cheers :)
yashax Jul 5, 2013 @ 12:54pm 
Same here. ATI Radeon HD 4850.
doktorseven Jul 5, 2013 @ 1:02pm 
Originally posted by jonasan:
i wonder what could be causing this - its got to be something relatively simple i'm guessing - and it seems to be affecting plenty of people
Most of us seem to be fglrx-legacy users (most reports say that we're using HD4xxx and below). My guess from the start was yet another fglrx-legacy incompatibility like the one that TF2 for Linux shipped with originally and AMD had to bring out a new version of the legacy drivers to fix.

Is anyone that's using the latest non-legacy drivers (you have an HD5xxx card or above) getting this EXACT error? I see one person with a 5670 above that just says "does not work", but I wonder if this is just another issue or the same one?

If legacy is the issue, we might be stuck waiting for an AMD fix, sadly... which stinks because the actual beta (not release-beta) didn't and still doesn't need it.
Last edited by doktorseven; Jul 5, 2013 @ 1:04pm
jonasan Jul 5, 2013 @ 2:37pm 
well mitterco if that turns out to be true that will be a terrible shame... and given that the original beta was and is still working fine its just very strange...

what could have changed at the last minute when they took the beta version and made it into the full game? its a little baffling?

just reading another thread which stated 31400 people playing l4d right now.... old beta was always around 30 - 60 people - imagine it will be less tonight when i play.... what a shame not to be involved....

your spot on about the legacy driver thing and it would definately be good to get clarity from Ernesto and anyone else that might be experiencing this same error ("Failed to create OpenGl Device!") who is not using the legacy driver from AMD. Would certainly make me more hopeful that valve might fix this if it was not purely a legacy issue.... can anyone confirm?
< >
Showing 1-15 of 36 comments
Per page: 15 30 50

Date Posted: Jul 2, 2013 @ 3:41pm
Posts: 36