Left 4 Dead 2

Left 4 Dead 2

View Stats:
Micoo Jul 5, 2014 @ 8:11am
My Left 4 Dead 2 keeps crashing?
I've recently installed a ton of mods for L4D2, but when ever I start the game up it makes a whistle noise and then crashes instantly. At first I though that the mods were causing the problem so I uninstalled them and launched the game; the same thing happened.
I really don't know what the problem could be..? Help would be really appreciated.
< >
Showing 1-15 of 15 comments
FenixMelhado Jul 5, 2014 @ 8:32am 
Try to verify the integrity of files in the properties of the game. This had happend to me twice and after I verified the files the game ran just fine.
Micoo Jul 5, 2014 @ 8:35am 
Thanks.. I'll try that
Micoo Jul 5, 2014 @ 10:55am 
It didn't work ^^
Micoo Jul 5, 2014 @ 1:46pm 
I've even uninstalled the game, reinstalled it, and then tried to laumch it, but the same thing keeps happening
Yamaha Jul 5, 2014 @ 8:05pm 
Set Launch Options "-autoconfig".
I doubt it's a hardware conflict, but it won't hurt to try.
Last edited by Yamaha; Jul 5, 2014 @ 8:06pm
Micoo Jul 6, 2014 @ 5:15am 
None of these things work, but I think it might be due to the fact that I've recently downloaded Windows 8.1 because it seems a few people are have a similar problem
Micoo Jul 6, 2014 @ 5:30am 
I've ran in in compatabillity mode and it seems to work.. I needed to downgrade to windows 7;
For anyone else that has this problem

C:\Program Files (x86)\Steam\steamapps\common\game\

Right click application file then properties then compatibilty.
>=) Jul 11, 2014 @ 3:05pm 
Yeah the game started crashing for me today after I downloaded Windows 8.1. It loads up the game I joined, but when I "click to play" it instantly crashes. I will try this. ^
>=) Jul 11, 2014 @ 3:11pm 
I tried running in Windows 7 Compatibility mode but it didn't fix the issue.
Damp CZ Jul 11, 2014 @ 3:12pm 
whats your problem?
>=) Jul 11, 2014 @ 3:16pm 
Everytime I join a game, it loads up the game and then I'm spectating the character I'm about to play as (like it normally does) and it says "IDLE: (player name)" and "Click to play as (survivor name)". When I click to join in and control the character the game crashes. It doesn't matter what mode I'm playing, Campaign, Versus, Single Player, they all do the same thing. This started happening after I downloaded Windows 8.1. And the compatibility mode hasn't worked for me either.
xXMasterJ360Xx Nov 11, 2015 @ 2:33pm 
I honestly dont think there is a fix for this without reinstalling the game which I consider to be a last resort removing any custom sounds you had which isn't a big deal, but yeah Ive read so many topics about this and not 1 of them had any solutions. Most people had simple outdated drivers that were their fix but ppl like me are still locked out from playing this game
underwater Dec 6, 2015 @ 12:41pm 
Originally posted by >=):
Everytime I join a game, it loads up the game and then I'm spectating the character I'm about to play as (like it normally does) and it says "IDLE: (player name)" and "Click to play as (survivor name)". When I click to join in and control the character the game crashes. It doesn't matter what mode I'm playing, Campaign, Versus, Single Player, they all do the same thing. This started happening after I downloaded Windows 8.1. And the compatibility mode hasn't worked for me either.
I have the same problem with Win10. Is there a solution?
Originally posted by FenixMelhado:
Try to verify the integrity of files in the properties of the game. This had happend to me twice and after I verified the files the game ran just fine.
mine didn't.
I had this problem. as soon as I got to the loading screen my game crashed
< >
Showing 1-15 of 15 comments
Per page: 15 30 50