Rgonomike Mar 16, 2013 @ 9:45am
This game is great but not optimized enough
Hi,

I have a GeForce 560 TI, an Intel Q6600 2.4Ghz and 5 Gigs of RAM, the last 314.07 drivers and I play with everything in low settings in 1980*1080p, the game manages to drop below 20 fps quite frequently... It's never very fluid I'd say.

What kind of PC do you need to run this game properly, seriously?

If it was a game in open world I'd say "yeah okay" but this is not the case... I don't think my PC is that bad...

What do you guys think about this? Am I the only one?
Showing 1-15 of 30 comments
< >
Vargas78 Mar 16, 2013 @ 10:53am 
2.4ghz is not that great and the game may not be optimised for multi core.

I dunno though. We should get more input as i'd still expect more fps from your pc. Maybe a lower res will help a bit.
Rgonomike Mar 16, 2013 @ 11:42am 
I have a 7.1 Windows experience rating... I used to play Assassins Creed Brotherhood in full details 1080p... it was working fine.
I could run a 3DMark benchmark but I'm sure I'd get a descent rating...
I wonder what's so ressource consuming in this game... Probably the processor but it's not normal...

Does anybidy with a first gen quad core have the same issue? Mine is the Intel Q6600 2.4Ghz?
Oh Noes Mar 16, 2013 @ 11:48am 
You shouldn't be worried about your graphics card and drivers, this game is very CPU intensive. You need to overclock your CPU or consider buying a new one.
Rgonomike Mar 16, 2013 @ 11:58am 
This topic says it all: http://steamcommunity.com/app/4920/discussions/0/828925216497326420/
I'm just worried that nothing will be done about this and I'm pretty sure it got worse with the not so gorgeous "Gorgeous update".

So basically, if you need to buy a new PC after each update that's a bit stupid... and no, this is not a game that should require so much processing power... or they should explain why.

There is something wrong for sure, come on let's face it...

Originally posted by RST Moskeeto:
Originally posted by =DDG= DR Nibbles:
my cpu is almost at the 3.0Ghz mark at 2.93, the game runs fine for me untill i get really close up to other marines and aliens, it does get a bit annoying has most marines i face against just run right into your face and shot at you.
Yeah, I've got a quad core at 2.8 GHz. Running this game is painful because it runs between 16 and 25 fps no matter the resolution or graphics settings. I really want to enjoy this game too.

Not optimized... that's all.
I might stop playing it because of that. That's too bad but I guess they don't give a damn, they got my money ^^
Last edited by Rgonomike; Mar 16, 2013 @ 12:12pm
Oh Noes Mar 16, 2013 @ 12:09pm 
A lot of modern games are becoming more CPU intensive. Yes, this game is poorly optimized and the patch added more stability issues. But you have to realize that your CPU is not high end or even mid-high anymore.
Rgonomike Mar 16, 2013 @ 12:18pm 
I realize that, of course. But that's not very clever from them... you decrease everything you can in the settings and it's still not working well.
My processor is still a good one, check it out, it's still correct.
#sixty Mar 16, 2013 @ 2:05pm 
Originally posted by Oh Noes:
A lot of modern games are becoming more CPU intensive. Yes, this game is poorly optimized and the patch added more stability issues. But you have to realize that your CPU is not high end or even mid-high anymore.

I have the same graphics card as him and a more powerful cpu (i5 2500k quad core @ 3.7ghz) and have the same BS. Everything on low and then game still drops to low 20-30fps in fights or heavy combat. Absolutely unacceptable that a mid-range $800 gaming computer not even a year old can't maintain a stable frame rate at lowest settings. Even dropping the resolution to 800x600 and forcing even lower settings through nvidia control panel still have awful drops in fights. It's the reason why I stopped playing this game and probably why the playerbase is so small. It's beyond frustrating.
Last edited by #sixty; Mar 16, 2013 @ 2:05pm
Threx Mar 16, 2013 @ 2:13pm 
I have no trouble playing except minor, VERY MINOR, lag end game. I'm using a I5-2500 and a gtx 570 :)
dave Mar 16, 2013 @ 2:51pm 
It run pretty much flawlessly on my i5 750 and amd 7870.
Rgonomike Mar 16, 2013 @ 3:13pm 
I'll try to play only on 10/12 players servers... it might work a bit better.
It's too bad though, it's an amazing game...

Originally posted by dave:
It run pretty much flawlessly on my i5 750 and amd 7870.

Originally posted by Thr3x:
I have no trouble playing except minor, VERY MINOR, lag end game. I'm using a I5-2500 and a gtx 570 :)

You don't notice it maybe guys, but everybody's affected...
It's playable on my machine, but when the framerate drops below 25-20 fps as Alien especially it's really hard to compete...
I end up playing as commander...

This game is in closed environments, it should be 60fps at all time... even with my machine in medium settings (high should also be okay).

PS: I'm also starting to be fed up with the ready room now... it's pointless if on top of everything it uses resources.

If only they could fix this ULTRA MAJOR problem... (sigh)
Oh Noes Mar 16, 2013 @ 3:13pm 
Originally posted by lagosta:

I have the same graphics card as him and a more powerful cpu (i5 2500k quad core @ 3.7ghz) and have the same BS. Everything on low and then game still drops to low 20-30fps in fights or heavy combat. Absolutely unacceptable that a mid-range $800 gaming computer not even a year old can't maintain a stable frame rate at lowest settings. Even dropping the resolution to 800x600 and forcing even lower settings through nvidia control panel still have awful drops in fights. It's the reason why I stopped playing this game and probably why the playerbase is so small. It's beyond frustrating.

Your computer should be getting 60fps on mid/high settings. Is your GPU only 1GB?
Oh Noes Mar 16, 2013 @ 3:18pm 
I know everyone is affected, I have 10-20 fps spikes based on the command r_stats.

Try overclocking your CPU to 3.00GHz or more and let us know how your FPS is affected.
Last edited by Oh Noes; Mar 16, 2013 @ 3:18pm
#sixty Mar 16, 2013 @ 3:30pm 
Originally posted by Oh Noes:
Your computer should be getting 60fps on mid/high settings. Is your GPU only 1GB?

Yes, it's 1GB GDDR5, but I don't think that is relevant to poor performance. And my CPU is already at 3.7ghz.
Rgonomike Mar 16, 2013 @ 3:36pm 
Originally posted by Oh Noes:
I know everyone is affected, I have 10-20 fps spikes based on the command r_stats.

Try overclocking your CPU to 3.00GHz or more and let us know how your FPS is affected.

Dude, I'm not going to overclock anything to gain 5 fps. It's nonsense...
I checked other posts and it now becomes obvious that there is something terribly wrong with this game.
I noticed a guy saying the deleting/rennaming the "infestation" directory can solve the prob...
I already suspected that infestation is the mainproblem in this game.

I'll try to do it tomorrow, see what happens... or if somebody could try now and tell us if it has any effect, let us know...
Oh Noes Mar 16, 2013 @ 3:39pm 
Originally posted by lagosta:
Originally posted by Oh Noes:
Your computer should be getting 60fps on mid/high settings. Is your GPU only 1GB?

Yes, it's 1GB GDDR5, but I don't think that is relevant to poor performance. And my CPU is already at 3.7ghz.

VRAM is probably the issue for you, since 1 GB is the minimum. I made my friend return his 7850 to Microcenter so he could get better performance. 2GB did wonders for him in this game. Hopefully Unknown Worlds helps you guys out with optimization.
Showing 1-15 of 30 comments
< >
Per page: 15 30 50
Date Posted: Mar 16, 2013 @ 9:45am
Posts: 30