TechPriest44 Nov 10, 2013 @ 6:24am
Lagging like hell
This game is unplayable for me. I have a top notch AMD computer and no matter what I do it is lagging like hell. At one time I had 2 frames per second. On the internet they say that only people with Intel computer parts (What the ♥♥♥♥?) can play this game, not to mention that the game crashes if you have headset or is using any kind of sound-improving software.

After some tips from several people, I got the game working properly. As many have stated, you need to disable Pysx, which are located in the game options and not the Video options. :)
Last edited by TechPriest44; Nov 20, 2013 @ 3:24pm
Showing 1-11 of 11 comments
< >
Doc. Daryl FNxD Nov 10, 2013 @ 6:40am 
Try to disable PhysX on the settings. It could be a problem.
HunterKiller Nov 10, 2013 @ 7:11am 
I had the same problem with my AMD Card and I disabled the Advanced Physix and problem solved. I was having a hard time in a firefight and had to log out of the game. I went into my Options and disabled it and all was good after that. Moving right along now. :)
Doc. Daryl FNxD Nov 10, 2013 @ 7:36am 
Advanced PhysX is bad also on Nvidia cards actually -.-
cartman-2000 Nov 10, 2013 @ 9:47am 
Well without a nvidia card, physx gets stuck processing on the cpu which can be a bit slow in areas with heavy physx effects. Generally a gfx card whould be over 10-20 times faster than the cpu at physx(With multithreaded cpu physx using all cores on a high end cpu. Most games only use single threaded physx when in cpu mode.).
CursedPanther Nov 10, 2013 @ 6:44pm 
Sorry I just gotta say this...

Whenever I read or hear 'AMD' and 'topnotch' being used together I just can't help think how ridiculous that sounds. No offence to AMD users.
Last edited by CursedPanther; Nov 10, 2013 @ 6:44pm
HunterKiller Nov 10, 2013 @ 6:48pm 
I got an easy 100-180 FPS in this game now. And I'm an AMD user. That's using BandiCam at the same time.
TechPriest44 Nov 13, 2013 @ 8:41am 
Originally posted by Doc. Daryl FNxD:
Try to disable PhysX on the settings. It could be a problem.
I tried it and it got a little better, but i still only have about 18 - 20 frames per second, hitting 2-3 frames per second later in the game. Sigh.....
Manicz'Ka [CZ] Nov 13, 2013 @ 9:19am 
Got the same problem some times...
Squee Nov 13, 2013 @ 10:13am 
My suggestion would be to turn off features starting with SSAA, then tesselation and then just whatever. If it still lags on low settings something else is going on. I got a realtively old card ( 470 ) and it worked fine for me. And even though the game might not be optimized for AMD, i doubt it would bring the to the pre-470's era.
ibbles Nov 13, 2013 @ 12:52pm 
How do I know if all these features are on or off? My settings window is just a single slider with no information on what is enabled.
Squee Nov 13, 2013 @ 12:54pm 
Originally posted by ibbles:
How do I know if all these features are on or off? My settings window is just a single slider with no information on what is enabled.
Then you got mac/linux version. Dunno about those settings. You could check your user folder for a user.cfg of the file. Thats where we could do edits on the PC.
Showing 1-11 of 11 comments
< >
Per page: 15 30 50
Date Posted: Nov 10, 2013 @ 6:24am
Posts: 11