DaggieBe Jan 7, 2013 @ 1:16pm
Verify if performance is normal (Linux)
I'm trying to run SS3: BFE on my HP EliteBook 8560w laptop. The laptop has an i7 running at 2.3 Ghz (indicator-cpu-freq), 32 Gb ram (I'm a software developer) and the Nvidia Quadro 2000m. I'm running Ubuntu 12.04.01 64 bit. I have the latest Nvidia driver (310.14), set for maximum performance. I don't have any powersaving on in the bios. I'm on the public beta.

In-game, I have settings "automatic". At a resolution of 1920x1080, I have approx 30fps, which lowers (a lot) when enemies pop-up.

I know the Quadro 2000m isn't a powerhorse, but is this performance normal? Or should my fps be higher? I would like to know what to expect (take or leave 20 fps), before I start putting a lot of time in my set-up.

I haven't experienced any performance issues with my laptop in other cases. However, this is the first game I try on it. Let me know what information you want if you need more. Thanks in advance.
Showing 1-15 of 43 comments
< >
2infibidyanbeon Jan 7, 2013 @ 3:24pm 
This is the only game in my library where I have to have the settings pretty low to run it at a playable level. Ultra just kills it to about 5fps
KingBeowulf Jan 11, 2013 @ 5:32pm 
You have to twesk the performance settings. I have
AMD64 X2 4800+ 2.4GHz
4 GB RAM
Geforce GT430
Nvidia 310.19 (latest and has been out awhile!)

I get 35-45 fps on average in most parts, quiet areas go 60+ fps. This game is not CPU intensive but can bring a GPU to its knees. shadows, lightmap, AF, FSAA, and AO need to be lowered. I have most everything else on High. You will also need to fiddle with your driver settings, some of those override settigs in SS3.

And then there are the reports that SS3 is about 2x slower on Linux than Windows7/8. I can't verify that since I only use Linux and WINE as a last resort.

See
http://forums.steampowered.com/forums/showthread.php?p=33643413
http://www.hardocp.com/article/2011/12/21/serious_sam_3_bfe_performance_iq_review/3
DaggieBe Jan 13, 2013 @ 3:49am 
Thanks a lot for the feedback and links. I hope changing some settings improves performance .. while still looking good.
Schnurri Jan 13, 2013 @ 8:55am 
According to the in-game FPS counter, the linux version has about the half performance compared to the windows version on my machine. (I have 6GB RAM, Core i7-920 @ 3Ghz, GTX 670 OC, newest drivers for linux/win)
DaggieBe Jan 13, 2013 @ 11:50pm 
That's just sad .. This is my first Steam experience (as I don't care about Win/Mac) and it's not a good one. I know Steam is not to blame, but the experience doesn't convince me to buy something else .. Since it's probably not going to work anyway.

I tried the links by KingBeowulf and I do get an improved performance, making the game 'pretty' playable .. still .. support for Linux (by the developer) should become better.
neowiz73 Jan 14, 2013 @ 12:49am 
I know the Quadro is good for designing but I don't think it's really great when it comes to gaming. I tried using one about 6 years back and got less performance than the GTX series.
I'm only on a 3.4ghz core duo, nvidia GTX460, 4GB ram system and I'm getting fps of 20~45, high quaility textures no FXAA or FSAA.
neowiz73 Jan 14, 2013 @ 12:50am 
Originally posted by Schnurri:
According to the in-game FPS counter, the linux version has about the half performance compared to the windows version on my machine. (I have 6GB RAM, Core i7-920 @ 3Ghz, GTX 670 OC, newest drivers for linux/win)
Do you have the nvidia drivers installed? the 310.xx version?
AlenL  [developer] Jan 14, 2013 @ 8:20am 
DaggieBe, Autodetect will never change your resolution, because it can get tricky on some systems, and it is not necessary in most cases. It will just lower the actual 3d rendering buffer size. For most GPUs, this is enough. However, for some integrated and mobile boards, even the strain of upscaling the buffer to higher screen resolution is too much. You can try to lower the resolution, not just settings, that might help.

Also, you should definitely try the 313 driver. It is faster for most people.

Finally, I hope you have disabled various power-savings and made sure that the CPU is running in performance mode. Please post Sam3.log so that we can see exact settings.

Note that there are no real reasons from application side for the game to be slower on Linux than on Windows. Currently, we are seeing performance drops due to Linux scheduler not properly enabling performance mode on the CPU, and performance issues in the OpenGL drivers. Performance mode you can force by yourself, and OpenGL drivers are something that IHVs are working on very actively. We expect the game to actually run faster by a small margin on Linux than on Windows, once the driver issues are sorted out.
DaggieBe Jan 14, 2013 @ 11:02am 
AlenL: Thnx a lot for your response. I really appreciate it. I tried changing the resolution manually to 1280 x 720, but that doesn't render the game playable.

I uploaded a fresh sam.log here: https://www.dropbox.com/s/6k8zdr8ccavu991/Sam3.log
It has this:
19:55:11 LOG: CPU Power saving is enabled and governor is set to performance.
I use indicator-cpufreq to set the "governer".

Hope you can help.
Schnurri Jan 14, 2013 @ 2:41pm 
I double-checked it, I'm still having a significant loss of fps in linux, even with the 313 driver. (although it is maybe more than half the rate, its about 45 fps in linux vs. 60 fps in windows, but i didn't really benchmark it). Disabling vsync will increase the framerate slightly in linux, no additional effect in windows. Can't really tell if this is the driver's fault. Runs good enough though! :-D
AlenL  [developer] Jan 14, 2013 @ 9:59pm 
DaggieBe, there are still a few things you can try:
- lowering resolution further
- lowering GPU speed and memory settings in Performance options to Low (AFAICS, it seems to be on medium). As you notice, 2000M is not a fast card. In particular, it has 128bit bus, probably causing it to be sensitive to fill rates. Thus, high resolution, complex shaders and post processing, high resolution textures... Those will all be a problem for it.
- upgrade to the 313 driver

If you experience not only low perf, but stuttering (you can check it via prf_bShowFPS and seeing if it shows large oscillations - check the +/- percentage number), it might be that performance governor is not doing its job, and some of the cores are still running in powersave. It happens to a lot of people. The only thing that helps for this is disabling power saving in BIOS. But in your case, I'd say it's more likely to be the GPU that is the problem.

Let me add one more note... There's this strange situation with OpenGL drivers ATM, especially on Linux. Strictly speaking, latest NVidia driver itself is slightly faster in OpenGL/Linux, than in Windows/D3D. However, seems that shader performance when running with it is much lower. This is the 50% speed difference people are talking about. Shader performance is largely a factor of shader compiler embedded in the driver. NVidia is working on this, and if they make it as fast as on d3d, cards like yours will probably benefit the most, due to the aforementioned bandwidth issue.
Last edited by AlenL; Jan 14, 2013 @ 10:01pm
Schnurri Jan 15, 2013 @ 1:23am 
I highly appreciate your support, AlenL!
For the CPU issues, i guess it should suffice to manually set the CPU scaling governor to 'performance', i think this should also work (and doesn't require altering the BIOS settings). For some reason, frequency scaling sometimes doesn't work good in linux, I had plenty of issues with that when using x264...
AlenL  [developer] Jan 16, 2013 @ 6:42am 
Schnurri, unfortunately it is not true. Even with performance governor, there are some machines and cases where performance is still jittery. It is very rare, but happens, and BIOS settings solve it all. Dunno why that would be like it, but that's the word we get from some users.
DaggieBe Jan 16, 2013 @ 12:38pm 
AlenL: my feedback.

I changed my resolution to 1024x768 (which is really low ..). Under "performance" I changed everything to Low. I set my cpu frequency to performance. I also set the Nvidia Powermizer to 2 (= performance). I put SS3 full-screen.

My FPS:
- menu: 30 fps
- outdoor: 50-60fps, sometimes dropping to 40-ish (eg. Spider's Nest in the atrium section)
- indoor: 90fps, sometimes even higher

This renders the game playable (and enjoyable) .. however it looks rather ugly. What settings would make it look better without having a huge impact on performance? I understand my laptop (due to GPU) will never be able to play the newest 3D games in great resolution, but I'd like to play SS3 as good as I can.


Driverwise, I'm running 310.14 ... I haven't found 313, I suspect you meant 310.13? That would be a downgrade and thus I didn't go that way. I briefly tried 310.19 .. but that made my X crash (kernel stuck on 310.14, Nvidia API at 310.19). Pretty sure I can figure that out, but I haven't had the time.

In conclusion: thanks for your assistance. I can play SS3 now. However I would appreciate some settings that would make it look better, without killing performance.
Last edited by DaggieBe; Jan 16, 2013 @ 12:38pm
AlenL  [developer] Jan 17, 2013 @ 6:41am 
Here's some notes:

30fps in menus is max. This is limited to give "air" to background loading.

Latest beta driver on Linux definitely is 313. it is "experimental" , but a lot of users say it improves their performance. Google around for how to install it. I've found this: http://techhamlet.com/2012/12/nvidia-beta-drivers-in-ubuntu-and-mint/, but I haven't tried it yet.

Regarding making it look better, you might want try to up performance options one by one and see which results you like. Upping CPU to medium will probably be ok. GPU memory can also probably be upped a bit. For GPU performance, that one will be the most sensitive, but generally, low should look "ok". It's "lowest" that looks really bad. Are you sure you are not at "lowest"?
Showing 1-15 of 43 comments
< >
Per page: 15 30 50
Date Posted: Jan 7, 2013 @ 1:16pm
Posts: 43