Thomas Apr 6, 2013 @ 12:02am
CAUTION: People With Nvidia 600 Series will BSoD
There's currentyl a problem with the Nvidia 600 series and the game that is leading to BSoD (Blue Screens of Death).
Showing 1-15 of 118 comments
< >
Wind Nvidia 3D G-SYNC Apr 6, 2013 @ 4:36am 
I noticed while playing MP after 15 minutes game crashed, no BSOD just a full hard freeze, no ability to CTRL ALT Delete etc; had to reboot the system. running SLI 680 GTX's with newest beta drivers 1350 Core clock 3500 memory clock.

- Thanks for the heads up; I bought (pre-ordered) the game on launch and only played it for about 4 hours; I loved the idea but found the learning curve steep and I believe Battlefield 3 was coming out (or I was playing Bad Company 2 it is hard to remember) - Jumping back in for that 15 minutes after playing the Single player toturial and re-learnign how to snipe was quite exhilerating, especially now having a rig to play it on all ultra.

What are your thoughts of using the "War Film" Post Processing? Do you think it looks to grainy etc or that it is a tasteful and broad used option (as in which is the favorite amongst the playerbase; especially the players who are vets to the game).
Muldoon Apr 6, 2013 @ 4:44am 
I am having the exact same problem this game hard locks my computer, it did it about 8 times now and im forced to manually reboot my pc. Is this game damaging my pc , And is there any way to ♥♥♥♥ing fix this ♥♥♥♥...im currently running a GTX 680
[F]lawless! Apr 6, 2013 @ 9:15am 
no tengo pantallazo azul pero tengo otro problema, en tiempos relativos el juego siempre se crachea y la pantalla se pone en negro y tengo que reiniciar el pc para que vuela a la normalidad :\, corro el juego con una gtx680 evga signature 2, tengo problema con este juego solamente. :\
Ponu Apr 6, 2013 @ 9:49am 
Well it's working for me on my 670
Using driver version 310.90
Wulfriic Apr 6, 2013 @ 10:14am 
i have a 660 and the game runs great for me. no crashes or problems
Danh {TP} Apr 6, 2013 @ 10:16am 
What is your driver version and waht are your other specs?
Bludshott Apr 6, 2013 @ 10:29am 
hey i rolled my nvidia GTX 650 ti drivers back to 310.90 also and now the game is working for me now, danh you might want to ask some people to test it to make sure but it is working perfectly for me now
Danh {TP} Apr 6, 2013 @ 10:33am 
Someone else tried it too!

Originally posted by Sal the Stockbroker:
hey I read someone using the 310.90 drivers for nvidia 600 series saying he had no problems so i rolled my drivers back to 310.90 and so far ive played two full games no problem which is a lot more than ive been able to play since i downloaded RO2

Please change the title to possible fix!
Last edited by Danh {TP}; Apr 6, 2013 @ 10:33am
Bludshott Apr 6, 2013 @ 10:44am 
crap man, i swear before i couldnt play more than 30 seconds without freezing, and then when i rolled back to the 310.90 drivers i saw someone using on here i was able to play 3 full games with no problem, and then this last game froze again on me, sorry for jumping the gun on that one, was excited to finally play
Danh {TP} Apr 6, 2013 @ 10:46am 
Originally posted by Bludshott:
crap man, i swear before i couldnt play more than 30 seconds without freezing, and then when i rolled back to the 310.90 drivers i saw someone using on here i was able to play 3 full games with no problem, and then this last game froze again on me, sorry for jumping the gun on that one, was excited to finally play

3 hours stll great! But we need a better fix now.
Bludshott Apr 6, 2013 @ 10:55am 
This time i did see the ROgame.exe error which i do not remember seeing in all my other crashes before i rolled back the drivers, not sure if its a different kind of error than i was getting before
Zealos0413 Apr 6, 2013 @ 11:17am 
how about GT650M? I'm running RO2 on my laptop.
Raincoats George Apr 6, 2013 @ 12:48pm 
Started having the same problem. GTX 670, crashes regularly.
Wind Nvidia 3D G-SYNC Apr 6, 2013 @ 1:15pm 
I just played for over 3 hours then had that samae crash :( - I was really rocking too as a Elite Riflemen; my third online kill was 260M headshot as the Allies on the bridge map; just behind cover set it to 300 meters and aimed correctly SPLAT headshot. been getting 15-20 Kills a match while holding objectives etc :)
TheMailMan Apr 6, 2013 @ 2:12pm 
Same here. I just uninstalled it. Sucks that I paid 3 bucks. Thats a Big Mac Ill never get back.
Showing 1-15 of 118 comments
< >
Per page: 15 30 50
Date Posted: Apr 6, 2013 @ 12:02am
Posts: 118